Jump to content

[GUIDA] INSTALLAZIONE LEOPARD FINAL


  • Please log in to reply
216 replies to this topic

#1
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
Scrivo questa guida per quelle persone che si trovano in difficolta' con Leopard.
In particolare per quelle persone che usano la Rc2 di ToH

Per chi all'avvio ha il cursore che lampeggia e' perche' ha saltato lo STEP 1.

Cio' di cui abbiamo bisogno :
Dvd Di Leopard Patchato. Io ho usato la ToH RC2
Dvd Di Tiger. Io ho Usato il jas 10.4.8, ma va bene qualunque dvd.

STEP 1
VI conisglio di dare un nome semplice alla vostra partizione.
Installate Tiger solo con il sistema base, non e' necessario installare tutti i Drivers compreso x11, lingue aggiuntive, Drivers stampanti.

STEP 2
A fine installazione Avviate dal vostro dischetto di installazione di Leopard, e quando avra' finito di caricare, aprite il terminale e digitate:

cd /Volumes
pwd ( serve per vedere se ha accetato la directory che avete dato)
cd XXX ( Dove XXX sta per il nome che avete dato alla partizione)
rm -rf * ( cancella tutto il contenuto della partizione)


Chiudete il Terminale

Installate Leopard.

(Se usate il dvd patchato con Brazil ricordatevi di levare le altre lingue e levare x11, visto che gli script dei brazil levano questi elementi.
Se non li levate il sistema potrebbe non partire.)



Ora avrete il vostro Leopard funzionante.

STEP 3 SOLAMENTE PER LE PERSONE A CUI COMPARE UN PANIC ALL'AVVIO


Se Vi Compare un Panic ( schermata con la mela con scritte sopra), all'avvio di darwin premete F8 e al prompt scrivete : -legacy ( boot grafico ) oppure -v ( se Volete il boot in verbose mode)

Avviato Leopard, aprite il terminale e digitate:

sudo bash ( dovrete inserire la vostra password )
nano /Library/preferences/systemconfiguration/com.apple.boot.plist

Vi compararira' una schermata con delle scritte simili:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com.../PropertyList-1$
<plist version="1.0">
<dict>
<key>Boot Device</key>
<string>/PCI0@0/IDE0@1F,1/CHN0@0/@0:1</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<keyBoot Graphics</key>
<string>Yes</string>
</dict>
</plist>

Voi Dovete modificare quella stringa sotto Kernel Flags aggiungendo -legacy
Il Risultato finale dovra' essere:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com.../PropertyList-1$
<plist version="1.0">
<dict>
<key>Boot Device</key>
<string>/PCI0@0/IDE0@1F,1/CHN0@0/@0:1</string>

<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-legacy</string>
<keyBoot Graphics</key>
<string>Yes</string>
</dict>
</plist>

La Parte Rossa e' quello che dovete aggiungere.
Per quanto riguarda la parte blu, forse potrebbe non esserci o essere diversa. Non preoccupatevi.

ora premete CTRL + O ( per salvare la modifica )
e poi CRTL + X ( per uscire)

Ora sul terminale digitate:
diskutil repairpermission /
reboot

E ORA GODETEVI IL VOSTRO FELINO!!!


PICCOLI CHIARIMENTI:
alcuni utenti hanno riscontrato che il sistema non bootava, e rimeva con il cursore lampeggiante. Dipendeva dal fatto che abbiamo bisongo del botloader di Tiger, per questo installiamo tiger prima di tutto.
Poi come leggete nello step 2 tutto il contenuto della partizione viene cancellata, perche' non serve, ecco perche' vi ho consigliato di non installare cose supplementari.
Se usate il dvd patchato con Brazil ricordatevi di levare le altre lingue e levare x11, visto che gli script dei brazil levano questi elementi.
Se non li levate il sistema potrebbe non partire.


Punk92
Ringraziamenti a DavidGilmour per il suo aiuto.


Posted Image


AGGIORNAMENTO:
STO RIMEDIANDO LA ISO ORIGINALE, PER AIUTARE CHI NON HA USATO LA ToH.
MI MANDI UN PM CHI E' DISPOSTO A TESTARE AMD

#2
thristan

thristan

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
Grazie della guida...

Sai mica se Leo su processori AMD SS3 funziona? So che sui SS2 non va...

#3
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
Scusa mi correggo. I Decrypter ci sono, e anche per SSE3, visto che alcuni utenti hanno installato, ma devi mettere i decrypter AMD apparte.

#4
AsterixTheVicking

AsterixTheVicking

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
Beh! che dire? Lavoro eccezionale. I miei complimenti non solo perch hai scritto in maniera chiara e sequenziale le operazioni da farsi, ma perch hai spiegato anche la procedura. A volte mi trovo a digitare dei comandi giusto perch l'ho vistro scritto in qualche messaggio senza conoscerne il significato preciso, invece tu con questa guida hai voluto dare spiegazione anche di quello che si va facendo.

Bravo e grazie!

#5
stationapollo

stationapollo

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 616 posts
  • Gender:Male
Punk...piccolo kiarimento....io domattina avr una immagine scaricata dal demonio: nella descrizione ci sta scritto ke non bisogna installare tiger prima di leopard....io sono un p perplesso di questa cosa, contavo di seguire quella descrizione, ma la tua guida (come quella per la 9A466,9A499) dice di installare Tiger per avere il Boot Loader....ke faccio?

#6
God93

God93

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Italia
ottimo lavoro punk domani la provo ;)

#7
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
metti tiger, senno non ti parte.
cmq che immagine stai scaricando? niente link pero'

#8
tonino_l

tonino_l

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
Amici esiste una iso "Format & Make Bootable HD for Leopard" che serve solo per abilitare il Bootloader la fatta kalyway. NOn il DVD completo ma solo un disco auto partente leo. Non ho ancora provato vi faccio sapere.

#9
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
prova e poi dirmi. se e' provo e aggiungo alla guida.

#10
uukk

uukk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
Ho un'ASUS P4C800E DL lo shutdown non funziona insieme alla LAN integrata Intel. Ho anche una scheda video NVidia 5700, anche questa da configurare.
Premetto che con la 10.4.8 di Jas funzionava tutto...

#11
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
allora per la lan dimmi il modello preciso. per la scheda video devi reinstallare i natit.
CMq basta rimettere i drivers che avevi prima.
nella jas, che e' un dvd completo ci sono tutti i drivers aggiunti e integrati, qui invece no, li devi aggiungere a mano.

#12
uukk

uukk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

allora per la lan dimmi il modello preciso. per la scheda video devi reinstallare i natit.
CMq basta rimettere i drivers che avevi prima.
nella jas, che e' un dvd completo ci sono tutti i drivers aggiunti e integrati, qui invece no, li devi aggiungere a mano.


Allora la LAN questa:

Intel CSA 82547EI Gigabit Ethernet Controller

I Natit posso rimettere gli stessi, non possibile spengere il PC hai qualche dritta?

Grazie

#13
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
per la eth se non sbaglio ci sono dei drivers nella uphuck. ora appena posso provo a postarteli.per lo spengimento, mi pare strano, che macchina hai?Prova con questo per la lan.

Attached Files



#14
uukk

uukk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
La scheda madre un'P4C800-E Deluxe con chipset Intel 875P

Anche con il DVD d'installazione solito problema. Non riesce a fare il riavvio/spegnimento.

#15
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
la rc2 nn ha bisogno di tiger...

#16
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
Scusami Midral, ma a me senza di quello non partiva..

#17
rubens

rubens

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Location:italy
ma con cpu sse2 non va leo, vero?

#18
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
certo che va, al nostro midral che hai un notebook sse2, leo va..Usa la ToH RC2

#19
pivy

pivy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 139 posts
ciao a tutti, scusate se vado off topic ma io ho un portatile con core duo e gma 950 vorrei sapere se installando la toh potrei avere problemi e se lo speedstep abilitato

grazie ciao!

#20
pox.84

pox.84

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 234 posts
  • Gender:Male
  • Location:Cosenza
posso suggerirti di inserire anche il metodo per i decrypt amd e temporalmente dove vanno messi?
mettete la guida in fisso...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy