Jump to content

Asus P5W DH Deluxe thread for 10.5.x Leo - 10.9.x Mavericks


  • Please log in to reply
1484 replies to this topic

#1421
su4chris

su4chris

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Budapest, Hungary
Hi all,

I used to have a 10.5.6 Leopard, then a 10.6.3 Snow Leopard on my P5W DH Deluxe, so I have some experience with hackintosh.

Recently I decided to move my hackintosh system on a bigger HDD and I wanted to install Lion so I decided to do a clean install on an empty 500GB HDD.

I followed some guides to create a bootable USB stick to install Lion.

It worked perfectly so I have Lion running and I installed the latest Chameleon bootloader (Chameleon_v2.1svn_r1547.pkg.zip) to be able to boot from HDD but I need some advice for post installation.

#1 At the moment I have no LAN, no WLAN, no sound. Could anyone give me some kexts to get LAN & Sound to work?

#2 I have an old DSDT.aml which I compiled for my old system, can I use that one with Lion?

#3 My GFX card is an Nvidia 8800 GTS 320 and I have a HEX code ready for it, which I used to put in Extra/com.apple.Boot.plist (now with the new Chameleon bootloader it has to be Extra/org.chameleon.Boot.plist). Is this the rcorrect method to run the GFX card or is there something better? With this I can run my 24" monitor at native resolution 1920x1200.

My specs:
ASUS P5W DH Deluxe with 3001 BIOS and correct settings (AHCI, etc)
Core2Duo E6600 2.4 ghz CPU overclocked at 3.0 ghz
4GB 800 mhz DDR2 RAM
ASUS 8800 GTS 320
Samsung SATA2 500 GB HDD

#1422
G5rocks

G5rocks

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male
  • Location:Europe
My safari issues are related to 8800 problems since lion. But I also have audio problems (USB sound sticks). Can someone enlighten me if this is an USB or audio problem?

#1423
abbundanz

abbundanz

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi guys,

first time posting after perusing this forum as a lurker…
first of all thanks for all the priceless info I found here.

I've a P5W based system and I need some help with USB and FW after upgrading from a fully functional 10.6.3 to 10.6.8


Hardware:
P5W DH Deluxe - BIOS version 2602
Pentium DuaCore E2220
GeForce 9600 GT
4gb (1+1+2) ddr2 667 - memory mapping enabled in the bios


Issue:
USB12 not working.
All others functioning at 12Mbps speed.
Firewire not recognized.

I originally installed Snow Leopard retail DVD, booting with Nawcom Boot CD.
It was long ago so I don't remember the post-install steps I took and where I got my kexts but the system was fully functional.
Recently I ran 10.6.5 update combo and I got those issues with USB and Firewire.
Tried to fix USB reverting to 10.6.4 IOUSBMassStorageClass.kext and IOUSBFamily.kext to no avail.
Ran 10.6.8 update combo, same issue.


Configuration:

/System/Library/Extensions folder:
Stock 10.6.8 +
VoodooHDA.kext

/Extra/com.apple.Boot.plist contents:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Timeout</key>
	<string>5</string>
	<key>Kernel Flags</key>
	<string>arch=i386</string>
	<key>Graphics Mode</key>
	<string>1024x768x32</string>
	<key>GraphicsEnabler</key>
	<string>y</string>
	<key>PciRoot</key>
	<string>0</string>
</dict>
</plist>

/Extra/Extensions folder:
Posted Image


Any suggestions? =)
I'm a bit confused on the path to take - do I need to update the BIOS, and/or to make a DSDT, or I just need to download the right kexts somewhere?...

#1424
marliwahoo

marliwahoo

    Marliwahoo

  • Members
  • PipPipPipPipPipPipPip
  • 604 posts
Why not Lion ? It works great. Hopefully 314TeR will make a P5W Lion boot/iinstall cd for Lion :)

For snow leopard go here:

http://translate.goo...view-vt4415.htm

use a newer version of chameleon than comes with his cd.


As for you boot.plist -

pci root - not needed
graphics flag - not needed
kernel flag - not needed - 64 bit works great - x32 only if you want to use the built in p5w wi fi.

voodoo kext not needed - use the above link for audio solution
usb kext - not needed
EvOreboot - not needed - with correct dsdt - restart fix in chameleon is better
ionetworking - not needed - add network fix in chameleon
RTC kext not needed with good dsdt.

#1425
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
Hi,
nice Xmas to everyone!

One question I wanna ask.
I install 10.6.8 with 4.0DP1 and follow Instructions. ( don't wont to use lion !! )
System works nice, but sometimes (not often) the system gets kernel panic while booting.
My system E6600 + 8800GT + P5Wdh del.
Must I change anything in the DSDT, because of Processor spek.?
After booting there are problems in the codedirect. of AppleHDA. (I use Version 10.6.7 - extract it with PAcifist)
see Jpeg below

Dont know what todo!
Sorry for my bad english!!!!

Attached Files



#1426
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
when the system get a kernel panic - system can't boot up again and again.
first time I think firewire is the problem. disable it but no result!
When I add arch=i386 the system comes up ! (know i checked up and added i386 to my boot.plist) <-we will see!
Wanna use this Board - works like a charme .
So

#1427
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
so, I test a lot!
it makes no different to boot in 32bit.
system makes kernel panics in 32 and 64bit.
Also sometimes k.panics after getting it back from sleep!

is there nobody who can help me a bit?

Extra/Kexts:

ALC882v34b
AsusP5WDHDeluxe
FakeSMC
HDAEnabler
JMicronATA

#1428
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
fresh install, same problem!
use 4.0DP1 install it, make AppleHDA rollback and use command in terminal
( sudo perl -pi -e 's|\x85\x08\xec\x10|\x82\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA
sudo touch /System/Library/Extensions)

BIOS like in http://forum.osx86.o...tosh-vt1132.htm

and get KP sometimes when the system boots up!
Use different DSDT from BootCD PAck 3.0 final - same problem!
with another DSDT I get another KP, see attachment:

Attached Files

  • Attached File  Foto.jpg   1.35MB   10 downloads


#1429
314TeR

314TeR

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:Poland
@buschi2626, replace FakeSMC with older version, for example 2.5 from netkas. I used unstable wersion FakeSMC in latest relase.

#1430
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
hi 314TeR THX for your answer.

Before your Post I changed and tested a lot!
In my case older version (like 2.0 or 3.0installer) also don't run in my case!
But I try and try and at least I used 4.0DP1 installer but make AppleHDA rollback from ##### (10.6.2 I think) , since I do so system runs without KP.
I also get no errors from AppleHDA in "HDD-Tool".
With AppleHDA 10.6.7 (incl. Terminal scripts) I get errors, KP and get "Soundclicks" and "Blopps" after Boot!

Does it make sense?

@314TeR
""Great Support and Work""

#1431
gavspav

gavspav

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
I installed 10.6.3 with UnibootX v4 then installed the 10.6.8 Combo Updater before installing Uniboot.

Everything worked fine and it was painless - thanks!

But then I began to run into problems. Spotlight indexing constantly (mdworker crashing), the software installer crashing, programs not opening. Often when I rebooted the disk repair had to run and eventually I had to use Disk Warrior to repair the drive.

I suspected the drive might be faulty so I got a brand new drive and did a fresh install. But now I'm having similar problems. Disk utility says the disk needs repairing but cannot be repaired. I can't repair disk permissions, getting crashes and now the bootstrapper has crashed and I can't get into the system at all.

I guess I can fix with disk warrior and reboot but something is seriously wrong somewhere and I don't know where to start?

Can anyone offer any advice? Thanks


EDIT ***Weirdly - or maybe not - this appears to be a problem with Ram. I had 8GB of Ram in my machine - I took 4 out for the install. Now if I put the extra 4 back I get occasional kernel panics and other weirdness. I have to turn the machine off which I think was causing the disk problems.

So I'm not sure if the problems are caused by dodgy Ram or some driver/addressing issues. Guess I'll try with 6GB and see what happens.

#1432
marliwahoo

marliwahoo

    Marliwahoo

  • Members
  • PipPipPipPipPipPipPip
  • 604 posts
Mountain Lion DP1 running smoothly. Sleep wake up not working correctly yet. New Chameleon, Same DSDT, Fake SMC, Woody HDA, IOAHCIBlockStorageinjector.

#1433
LuSTRaRe

LuSTRaRe

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:UK
@gavspav

I had an issue a while back that stopped my system posting. After some time consuming tests with Memtest86+ it turns out my RAM slot 4 is faulty and not a RAM module. You should try testing your RAM in different configurations and see if you have a faulty module or slot. A faulty module or slot could well be the cause of your problems.

Download Memtest86+ Bootable ISO

#1434
314TeR

314TeR

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:Poland
I made a new LegacyHDA compatible with 10.6.8 and up. Download from here:
http://forum.osx86.o...4ter-vt4435.htm
They should also work in Lion and ML. To install Use a "HDA Wizard".

I am also working now on a new UniBootX and UniFix for P5W DH Deluxe, fully compatible with the Lion. Details coming soon.

#1435
986

986

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

I made a new LegacyHDA compatible with 10.6.8 and up. Download from here:
http://forum.osx86.o...4ter-vt4435.htm
They should also work in Lion and ML. To install Use a "HDA Wizard".

I am also working now on a new UniBootX and UniFix for P5W DH Deluxe, fully compatible with the Lion. Details coming soon.


nice man, can't wait

#1436
steadyfastchip

steadyfastchip

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi everybody!

I wanted to share this one, I've been going bananas over it, and maybe save some of you of a serious headache. :D
I have been running OSX for 4 years now on my P5W DH Deluxe and I've been (mostly) very happy with it.
I still run 10.5.8 (Kalyway 10.5.2 + iDeneb upgrade) very easy and stable, I've upgraded to Snow and have come back from it because I experienced a decrease in speed.
I'm thinking about upgrading to Lion because software vendors are pushing me to it, due to increasing compatibilty issues (actually this is mostly Apple's fault), anyhow I would be interested in your experiences especially towards speed with Lion compared to Leopard.

Back to what I wanted to share, my system was running fine until last week I started to experience kernel panics when shutting down, not when restarting oddly. I always keep some disk images at hand for when stuff goes wrong so I restored my system and and was like it used to be. Until a few later I started to experience issues with sleep a bit later shut down as well. Anyhow after a lot hassle with new restores, rechecking all the bios settings, etc.. without any luck. I discovered that my usb dongle for the keyboard and mouse was the troublemaker. It sits the lower second USB port of the motherboard and is detected as a wake up port.
So after changing this, shutdown works fine again, I'm still experiencing troubles with sleep however, so I'm not completely out of the water yet, any input on this one would be greatly appreciated. ** UPDATE: I had been experimenting with sleepenabler.kext, deleting this brought back sleep :D fully operational once again.

So I hope I save some of you from future headaches.

Cheers

Chip

#1437
steadyfastchip

steadyfastchip

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Has anyone got the Kext.P5W10.6.7.By.PIEROF81 package
These were shared on megaupload, can't find anywhere.

Another issue I'm having after installing comboupdate 10.6.8 my screen is cut in two halves, I fixed it with installing the proper ati drivers but whenever i boot in verbose mode it is still split in two, as with the circular loader which appears off center.
Anyone any input on this?

Cheers!

#1438
VincentBlack

VincentBlack

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I have a retail Snow Leopard install with dsdt and a boot string for an nVidia 9800 GT with 1 gig of RAM. It ran great for months, I was able to upgrade from 10.6.3 all the way up to 10.6.7 with no problems, other than usual sleep enabler stuff. I (stupidly) attempted to upgrade to 10.6.8 and broke everything.

I attempted to upgrade from 10.6.7 to 10.6.8 using the combo updater. After reboot I was stuck at [PCI Configuration Begin] so I swapped IOPCIFamily.kext, AppleACPIPlatform.kext, and IO80211.kext for the old 10.6.7 ones, changed permissions on the newly installed kexts, then rebooted with -f -x. Now it tries to boot, but hangs when the airport card connects. The line it hangs on is something like "airport: Link up on en1, handshake RSN....." Once it hangs it will accept input from the keyboard and print it to the screen, but it doesn't do anything. I don't think airport is the exact problem. There are two lines with errors before that:

USBF: 0.360 AppleUSBEHCI[0x7dbb000]: unable to get filterInterruptEventSource
USBF: 0.360 AppleUSBEHCI[0x7dbb000]::UIMInitialize - Error occurred (0xe00002be)

Is this a USB, PCI, or display driver issue? I attempted to boot with USB turned off on the mobo (results in kp), with the boot string for graphcis removed from the plist in /Extra (freezes at same place). Do I need to re-create my dsdt file? Is there a hacked version of IOPCIFamily.kext that I need?

My computer has an old Leopard (10.5) install I can use to access the filesystem on my Snow partition, but I can't boot into Snow anymore. Any advice or asssitance would be appreciated.

My setup is:

P5WDH Deluxe
Core2Duo E8600
PCI Broadcom WiFi card for native airport
nVidia 9800 GT 1 gig
Chameleon 2.0 RC4 (forget exact rev version)

I can provide boot plist or the contents of /Extra folder if necessary.

Thanks in advance for any help!

#1439
marliwahoo

marliwahoo

    Marliwahoo

  • Members
  • PipPipPipPipPipPipPip
  • 604 posts

After reboot I was stuck at [PCI Configuration Begin]


Most likely still has to do with "PCI Configuration Begin" Search for "Configuration Begin" or "ncpi=0x2000" . You'll need to edit the boot.plist.


<key>Kernel Flags</key>
<string>npci=0x2000</string>

#1440
VincentBlack

VincentBlack

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Thanks for the reply Marliwahoo. I already tried ncpi=0x2000 both at the boot prompt and in the boot plist and it didn't help.

I found the problem though, I'm now able to boot. I only changed permissions and ownership on the newly installed kexts from myLeo partition. I had to boot Snow into single user mode and chmod and chown the new kexts from there. The ownership was "_unknown:_unknown" instead of "root:wheel". I should have known that . . . I'd been troubleshooting so long my brain was fried.

I'd like to thank Marliwahoo and everyone that has posted in this thread, it's an invaluable resource for us P5WDH users. Hard to believe this thread is going on 5 years old. Thanks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy