Jump to content

Broadcom 440x & Leopard GM...


  • Please log in to reply
2 replies to this topic

#1
mac.nub

mac.nub

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:cd /world/uk
Hey All,

Posting this from my shiny Leopard GM install using my Wireless LAN - Got to say, I love Leo so far!
I'm using a Dell Inspiron 6400 - well, if you can still call it that, i've replaced pretty much every component in it... even upgraded the CPU! Anyway Wireless Works (out of the Box - DW 1500), Sound Works after some removal of kexts, replacement of kexts etc. Graphics work (GMA 950), only problem I have is the Wired LAN.

Now my problem is the Broadcom 440x LAN - which has always seemed to just work "out of the box" for as long as I can remember under Tiger.

Unfortunately... there seems to be no support for it under Leopard I tried copying IONetworkingFamily.kext from 10.4.10 but that broke the wireless, tried copying just the BCM440x kext from the plugins folder of it to the plugins dir of the Leo IONetworkingFamily.kext... but that didn't fix it either - it was recognized, but didn't work it just said it was in an error state.

Any suggestions are much appreciated!

~mac.nub

#2
mac.nub

mac.nub

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 409 posts
  • Gender:Male
  • Location:cd /world/uk
Managed to solve my own problem... copied AppleBCM440XEthernet.kext from an older ( 10.4.8 ) IONetworkingFamily.kext to /System/Library/Extensions - not the plugins folder of the Leo IONetworkingFamily.kext as I did last time - repaired permissions and chown'd it.

Connected it to the LAN... still the same error state. Unloaded the kext and loaded it again... and now it works. Weird.

Bleh, the X key on my laptop keyboard is almost non-functional now! :thumbsup_anim:

~mac.nub

#3
nofxx

nofxx

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Wow !! ! ! great great great.... the BCM440x from kalyway, dont even need to reboot.. just installed the kext, and a pop-up came up "new interface detected" huahuahuahau !!

Here is the kext:
http://uploaded.to/?id=6rayth





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy