Jump to content

Topic sur les cartes directx 10 sous Mac OS X


  • Please log in to reply
113 replies to this topic

#1
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
MàJ 03/01/08

Voilà un topic qui en satisfera plus d'un!
Support ATI
Il suffit de lancer l'installeur présent sur mon site, concernant votre carte graphique.

Issues connues: (Leopard)
_2400 non détérminé
_2600 XT / PRO OK (XT reconnue en PRO) uniquement DDR3
_2900 PRO / XT OK
_3850 OK
_3870 OK (juste besoin de changer le devid, par contre quelques bugs graphiques apparemment)

Merci à Netkas pour son aide au niveau des 3850 http://netkas.org/?p=47

Support nVidia
Pour Leopard vous avez besoin de:

_"Leopard geforce 5/6/7/G80" disponible sur mon site si vous avez une 8800 G80 (320 640 ou 768) => Pour de meilleurs performances opengl vous pouvez flasher votre 8800 GTX en QUADRO FX 5600

_"8x00 Installer Leo Only" disponible sur mon site si vous avez une nvidia 8x00 autre que les 8800 G80 => TOPIC complémentaire: http://forum.insanel...showtopic=77383

Pour Tiger vous avez besoin de:

_"G80 installer" disponible sur mon site si vous avez une 8800 G80 (320 640 ou 768) => Pour de meilleurs performances opengl vous pouvez flasher votre 8800 GTX en QUADRO FX 5600

_pas de support autre que 8800 G80 sous Tiger.


Merci à Gotoh pour ses kexts, présents sur http://nvinject.free.fr/downloads.php qui supportent maintenant deux cartes pour la version 2.0 et qui est universel (Tiger/Leo) à partir de la version 2.0 (CF: se référer aux indications présentes sur le site)


PS: http://alex.upsidedown.free.fr mon site où vous pouvez tout télécharger

#2
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
pas besoin du kernel 8.10.3, 8.10.1 ou 8.9.1 ça marche.

#3
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
tu es mon dieux :blink:

#4
RIPS

RIPS

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
Petite précision, il s'agit bien de faire fonctionner QE/CI avec ces cartes, il en s'agit pas que de résolutions :blink:

#5
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
alex, il ne vaut peut-être mieux pas faire de mirroir des téléchargement pour l'instant, étant donné que je fais souvent des mises à jour des kexts vu que c'est en cour de développement...
En théorie, il ne faut pas insérer la deviceID dans NVDAresman (qui ne gère que les anciennes cartes). Il n'y a que dans NVDAnv50HAL que l'ID des GeForce8 devrait apparaître. Le dernier paquet d'installation que j'ai mis en ligne devrait corriger ça, et NVinject doit être installé manuellement, afin que chacun puisse modifier soi même la quantité de mémoire.

#6
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
bon et bien moi je test de suite :rolleyes:
peut être que sa marchera un peu mieux
merci gotoh :D


EDIT: euu où dois je rajouter la quantité de vram ?j'utilise notepad++ sous windows :/

#7
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
qu'as tu comme carte xinux, et comme version d'OS X ?
si tu as un peu de temps, on peut faire quelques tests (donne moi ton mail par PM que je t'envoie différents fichiers)

@+

#8
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
libre pour les tests :P
si je peux faire avancer les choses, se sera avec plaisir :)

j'ai une BFG geforce 8800 GTS 320 Mo oc2 (en gros un 8800 GTS 320 ^^)
et je suis sous:
Mac OS X 10.4.10 (kernel 8.10.1) mais je peux mettre le 8.10.3 si tu veux ;)

je t'envoie un mp de suite :D

#9
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
Oh, escuse moi gotoh, je ne savais pas que les kexts venaient de toi... Je croyais qu'ils venaient d'aquamac. Je les met à jour régulièrement donc ça devrait être bon, et bravo ça marche impec chez un pot sur une ASUS 8800 GTS 320 (reconnue à 256)

#10
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
bon et bien chez moi sa marche pas ;)

j'ai essayé les derniers kext que m'a envoyé Gotoh, et kernel panic à chaque boot, et meme en -x
il a tenté de me faire enlever le nvinject, mais rien à faire, toujours kernel panic ;)

#11
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
Alors mon compte rendu pour ma BFG Geforce 8800 GTS 320 Mo oc2

ça marche nikel, et ce grace à Gotoh, après quelques tests, et un formatage, il a trouvé la bonne solution:

- installer MacBookProSoftwareUpdate1.1.dmg (grace à pacifist)
- rajouter NVinject.kext320Mb.zip
- réparer les permissions
- rebooter

- et profiter du resultat :wacko:

voici un petit screen :(

Attached Files



#12
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
Quelqu'un pourrait me confirmer pour les 8600 svp car je sais que la résolution marche mais pas le qe/ci, mais c'était avec nvinject B alors que peut-être qu'avec le C ça marche.

#13
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
Gotoh attend de recevoir la sienne, pour continuer les tests et paufiner le nvinject :( :)

#14
bejito73

bejito73

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
g une ati radeon hd 2600 pro 512 sapphire mais ca marche pas.... c normal??? ya til une manip a faire??

merci

#15
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
Salut, ici c'est un forum pas un message sms, pour une meilleur lisibilité et compréhension il serait aimable de ta part de l'éditer. Merci.

#16
Dawoud

Dawoud

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
Bonjour, j'ai tenté d'installer le drivers pour ma carte radeon HD2400 mais je n'arrive même plus à démarrer sur osx, je reste sur un écran noir.

Lorsque j'ai tenté d'installer le kernel 8.10.3, l'ordinateur reboot sans arret.

Une personne d'entre vous aurait une solution à mon problème ?

Merci à vous ;)

#17
xinux

xinux

    InsanelyMac Geek

  • Members
  • PipPipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:France - Caen (14)
essaye de démarrer en mode sans échec (au démarrage presse F8, tape -x, et enter)
si ça marche pas essaye le -v (verbose) et dis nous ce qui est affiché comme erreur ;)

#18
Dawoud

Dawoud

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
je réinstalle en ce moment même ;)

Ensuite je met le kernel 8.10.3 et je regarde si le pc "mac" ne reboot pas sans cesse.
C'est dommage parce que le son fonctionne, l'usb2 fonctionne, l'éthernet, le wifi, tout fonctionne ... sauf la carte video !!
Je vous tient au courant.

Voici des captures des lignes de codes qui défilent sans cesse suite à l'installation du driver de ma carte video :

http://www.hiboox.co...mg=b2tk6k1y.jpg

http://www.hiboox.co...mg=jx5msnfp.jpg

#19
bejito73

bejito73

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Support ATI 2400/2600 PRO/XT


cet installateur ne fonctionne pas avec ma carte graphique ati radeon hd 2600 pro 512mo de chez sapphire, de meme j ai tenté d installer le kernel 8.10.3 mais ça empeche le boot.
Quelqu'un aurait il une solution a me proposer???
merci

#20
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Déjà ne pas installer le kernel 8.10.3, il ne sert à rien.

Ensuite, la HD2600 PRO devrait passer, je sais pas si la 512Mo passe, mais je vois pas pquoi pas...

Quant à la HD2400, essaye de voir si ça boot sans natit, si c'est le cas, le bug vient sûrement d'une erreur permission sur OpenGL.framework ce qui fait l'écran noir.

Bonne chance !





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy