Jump to content

ATI MOBILITY RADEON X2300


  • Please log in to reply
8 replies to this topic

#1
MakAsus

MakAsus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Moscow
hello dear DiaboliK!

Excuse me for my bad English, I live in Russia!

I have an ATI MOBILITY RADEON X2300 128 mb M54 PCI\VEN_1002&DEV_718A (Noutbook ASUS A8Jr)
Here all data that I could to get about it:

Display adapter
Adapter description: ATI MOBILITY RADEON X2300
Adapter device ID: 0x718A1002
Display settings: 1280x800, 32bpp

Display:
Manufacturer: AUO
Plug and Play ID: AUO2344
Manufacturer: AUO
Model: 2344
Serial number: 0
Manufacture date: 2005, ISO week 1
EDID Version: 1.3
Display type and signal: Digital Display Input
Screen size: 300 x 190 mm
Display gamma: 2.20
Red chromaticity: Rx 0,580 - Ry 0,340
Green chromaticity: Gx 0,310 - Gy 0,550
Blue chromaticity: Bx 0,155 - By 0,145
White point (default): Wx 0,313 - Wy 0,329
Manufacturer's mask: 0
Supported additional Video Mode:
clock: 71.1 MHz Image Size: 304 x 190 mm
h_active: 1280 h_sync: 1328 h_sync_end 1360 h_blank_end 1440 h_border: 0
v_active: 800 v_sync: 803 v_sync_end 809 v_blanking: 823 v_border: 0

AUO: B141EW02 V3
EDID (in hex):

00ffffffffffff0006af442300000000
010f0103801e13780a87c594574f8c27
25505400000001010101010101010101
010101010101c71b00a0502017303020
360030be100000180000000f00000000
00000000000000000020000000fe0041
554f0a202020202020202020000000fe
004231343145573032205633200a00d9

Raw EDID base
00: 00 FF FF FF FF FF FF 00 06 AF 44 23 00 00 00 00
10: 01 0F 01 03 80 1E 13 78 0A 87 C5 94 57 4F 8C 27
20: 25 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
30: 01 01 01 01 01 01 C7 1B 00 A0 50 20 17 30 30 20
40: 36 00 30 BE 10 00 00 18 00 00 00 0F 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 20 00 00 00 FE 00 41
60: 55 4F 0A 20 20 20 20 20 20 20 20 20 00 00 00 FE
70: 00 42 31 34 31 45 57 30 32 20 56 33 20 0A 00 D9

Printing DDC gathered Modelines:
Modeline: "1280x800" 71.11 1280 1328 1360 1440 800 803 809 823 -hsync -vsync

The first time, i install the diabolik NATITX1300 (R1V1) and i reboot my laptop. But after the grey apple i got a black screen...

Now, i install the diabolik MOBILITY.KEXT (R1V1) and i reboot my laptop. And then i got this one again.

Could'nt you make something with one of the KEKST, That I could force to work this stupid device?

Thanks for your work, DiaboliK!
With the my best regards, Sergey.

#2
Dainix

Dainix

    Level 12 Warmage

  • Members
  • PipPipPipPip
  • 204 posts
  • Gender:Male
  • Location:In a Toaster Oven
  • Interests:15% APR for three years. After that, it's 20%.
You're using the wrong drivers. As of now, I don't know of any drivers available for the X2300. If you know someone who has bought a new iMac, ask them about it. The new iMacs have the X2x00 series, so I'm sure you could find the drivers you need.

#3
Azurael

Azurael

    How many Ace Rimmers does it take to change a lightbulb?

  • Members
  • PipPipPipPipPipPipPip
  • 776 posts
  • Gender:Male
X2300 is not an X2xxx chip. It's an X1300 with UVD lifted from the X2xxx series. This may mean you're in a black-hole driver-wise, unable to use either the X1xxx or X2xxx drivers.

#4
MakAsus

MakAsus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Moscow

X2300 is not an X2xxx chip. It's an X1300 with UVD lifted from the X2xxx series. This may mean you're in a black-hole driver-wise, unable to use either the X1xxx or X2xxx drivers.

I understand!

X2300 Mobility Radeon= X1450 Mobility Radeon+ UVD=X1XXX Series Mobility Radeon= DX9:(
Adapter device ID: 0x718A1002==Adapter device ID: 0x71861002 !

Some strings from Windows Vista Driver: CL_40818.inf

[Version]
Signature="$Windows NT$"
Provider=%ATI%
ClassGUID={4D36E968-E325-11CE-BFC1-08002BE10318}
Class=Display
DriverVer=12/20/2006, 8.33.0.0
;;LayoutFile=layout.inf
CatalogFile=CL_40818.CAT

[SignatureAttributes]
atiumdva.dll=SignatureAttributes.PETrust
atiumdag.dll=SignatureAttributes.PETrust

[SignatureAttributes.PETrust]
PETrust=true

[DestinationDirs]
DefaultDestDir = 11
R300.OGL = 10 ; Windows
R300.Miniport = 12 ; drivers
R300.Display = 11 ; system32
R300.DXX = 11 ; system32

[ControlFlags]
ExcludeFromSelect=*
;
; Driver information
;

[Manufacturer]
%ATI% = ATI.Mfg

[ATI.Mfg]
"ATI MOBILITY FireGL V5200" = ati2mtag_M56GL, PCI\VEN_1002&DEV_71C4&SUBSYS_13121043
"ATI Mobility Radeon X1400" = ati2mtag_M54, PCI\VEN_1002&DEV_7145&SUBSYS_13331043
"ATI Mobility Radeon X1450" = ati2mtag_M54, PCI\VEN_1002&DEV_7186&SUBSYS_12311043
"ATI Mobility Radeon X1600" = ati2mtag_M56, PCI\VEN_1002&DEV_71C5&SUBSYS_10B21043
"ATI Mobility Radeon X1700" = ati2mtag_M56, PCI\VEN_1002&DEV_71D5&SUBSYS_12421043
"ATI Mobility Radeon X1700 " = ati2mtag_M56, PCI\VEN_1002&DEV_71D6&SUBSYS_12B21043
"ATI Mobility Radeon X1700 " = ati2mtag_M56, PCI\VEN_1002&DEV_71DE&SUBSYS_14E31043
"ATI Mobility Radeon X2300" = ati2mtag_M54, PCI\VEN_1002&DEV_718A&SUBSYS_14491043

#5
pere

pere

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 726 posts
Hello.

Sony Vaio VGN-CR11z, ati Hd2300 Gpu here on uphuck 10.4.9
Tried everything to get qe and ci working, but no success, just resolution change on apple.boot.plist

Have you find any solution for qe and ci?.
Is there any way to tweak any kext?.
Any news?.
Seems there is not so much people with this mobile card :(

Hope we can finally find a way to make it work.

#6
Spirit412

Spirit412

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
Таже проблема!
Купил ноут ASUS F3Jr с видеокартой ATI X2300
Поставил Хакинтошь..... теперь вот мучаюсь..... немогу найти драйвер для видяхи.... с поддержкой "правильного" разрешения и чтобы 3D ускоритель работал :(

#7
igyo

igyo

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
and hd2600 mobility not working :)

#8
gilead

gilead

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I also have a laptop with this card. I was thinking of putting osx86 on it.... do get any form of graphics?

#9
GTOnizuka

GTOnizuka

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Move here: http://forum.insanel...o...id=635864





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy