Jump to content

[GUIDA] AGGIORNAMENTO 10.4.10 v 1.1


  • Please log in to reply
29 replies to this topic

#1
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
in seguito ai numerosi problemi di aggiornamento alla 10.4.10 (ke comunque sconsiglio ancora una volta di mettere) ho pensato vi servisse una mezza guida...

Premesse...
- guida testata sul mio mhackbook...
- la guida è testata su osx 10.4.9 con kernel 8.9.1
- nn mi assumo responsabilità su eventuali format quindi backuppatevi i vostri dati...
- la guida è beta proprio perke va testata su piu makkine possibili

vi consiglio di procedere a piccoli passi.... allora salvatevi i seguenti files....

mach_kernel (8.9.1)
SYSTEM.KEXT (8.9.1)
IOATAFAMILY.kext (preso dalla 10.4.8)
IOPCIFAMILY.kext (preso dalla 10.4.8)
IONDRVSUPPORT.kext (preso dalla 10.4.7)
APIC E ACPI kext
nel mio caso è servito anke rimettere il vekkio IOFIREWIRE kext... per far funzionare la firewire...
cercate in giro il kext SMBIOS di netkas...

quindi ora dovreste avere tipo una cartella con 7 - 8 files.....

aggiornate tramite software update

installatelo normalmente alla fine... NON RIAVVIATE
forzate la chiusura del aggiornamento...

ora sostituite tutti i kext con i vostri backuppati....

cancellate i files extensions.mkext e kextcache

e riparate i permessi da terminale ( diskutil repairpermissions /)

riavviate

al prompt del boot di mac scrivete -v -f....

e voilà.... macosx 10.4.10....


PER POSSESSORI DI CPUS INTEL SSE2...
il kernel disponibile è l'8.9.1 NON AGGIORNATE IL KERNEL!!!


PER POSSESSORI DI CPUS INTEL SSE3...
il kernel 8.10.1 è disponibile dove sapete.... ricordatevi ke insieme al kernel dovete inserire anke il SYSTEM.kext.....


testate e fatemi sapere

ps. ritestata sul mio portatile e su un hp nx7300 aggiornamento perfetto...

#2
iPablos

iPablos

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 399 posts
bella :2cents:

#3
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 391 posts
  • Gender:Male
  • Location:Roma
Ciao Midral,
la guida sembra semplice.... ora una domanda: secondo te posso installarlo su IBM A31? P4 1700mhz 1G ram (SSE2), ora ho la 10.4.8 kernel 8.8.1, ma non sono mai riuscito a mettere la 10.4.9 e ogni voltra che ho provato niente....
che mi consigli? :D

#4
tonino_l

tonino_l

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
fatto su una asurock CnRoe 1333 da 10.4.9 a 10.4.10; esito negativo non riparte.... :D
ho ripristinato la partizione e poi ho usato koolkal 10.4.10 patchata tutto ok :blush:

#5
AppleLooney

AppleLooney

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male
Ciao raga allora se voi cercate c'è qualcosa da scaricare e questa cosa si può installare senza problemi

e nn crea nessun problema del mondo io l'ho installato su 10.4.9 con kernel 8.10.1 e l'unica cosa ke ho

dovuto fare è stata ripristinare i driver della skeda audio poi x il resto era ed è tutto a posto, tra l'altro

se si passa a 10.4.10 su software update c'è la security update ke si può scaricare e installare e nn crea

problemi, ciao a tutti, spero di nn aver disturbato nessuno con queste mie affermazioni!!! :) :) :D

#6
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
update

#7
brazorf

brazorf

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
ciao Midral ti chiedo una cosa
ho un travelmate 430 con P4 ( SSE2) e ho provato la Jas 10.4.8. Mi rileva tutto però non posso vedere i dvd se non con artefatti verdi e anche con i divx ho problemi. Ho provato ad aggiornare alla 10.4.10 con i pack che ho trovato in giro sia il koolkat sia con quello che ha dentro i pack per intel e amd ( tanto per capirci).

In entrambe le situazioni il sistema non parte più e non posso nemmeno partire con la console.

Leggendo in giro ho letto che conviene passare dalla 10.4.9 alla 10.4.10 e allora ho provato a mettere la uphuck 1.4i, si installa ma non parte al riavvio e da lo stesso errore di quando avevo la jas10.4.8 e facevo gli update.

Dici che potrebbe essere incompatibile il kernel dell 4.9 o 4.10 ?

hai consigli ?

grazie in anticipo

#8
brazorf

brazorf

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
rettifico una cosa sulla uphuck 1.4

bastava selezionare la rimozione del kext powerqualcosa( ora non ricordo il nome preciso ) dove dice che a volte deve essere levato soprattutto se si usa un celeron D. Ho un P4 e spuntando quella voce il sistema parte. Non ho selezionato niente altro.
con calma proverò l'aggiornamento alla 10.4.10.
ogni idea funzionante è ben accetta :)
thx

#9
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
update

#10
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 391 posts
  • Gender:Male
  • Location:Roma
ciao midral,
ho fatto come hai descitoo ma non va, ho aperto anche un post ma non ho ricevuto aiuto(help aggiornamento 10.4.10 su IBA A31)
la domanda è questa, installando l'aggiornamento con software update come faccio a non aggiornare il kernel?

#11
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
il kernel si aggiorna per forza pero' backuppando il tuo vekkio kuando finisce l'update lo rimetti...

#12
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 391 posts
  • Gender:Male
  • Location:Roma
ok! ma dove lo trovo?

#13
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

ok! ma dove lo trovo?

trovo ke?

#14
frankyweb

frankyweb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 391 posts
  • Gender:Male
  • Location:Roma
fatto grazie

p.s. non trovavo il mach_kernel

#15
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
ok

#16
egarim

egarim

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
Volevo dare solo uno spunto visto che è una cosa che interessa pure me....
E se qualcosa dovesse andare storto con la procedura di aggiornamento ?
Come ripristino il mio sistema senza dovere reinstallare tutto da capo ?
Magari c'è già solo che non l'ho trovata! Grazie

#17
soledo

soledo

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Grazie alle dritte di Midral ho aggiornato alla 10.4.10 partendo dalla uphuck v1.4i r3 10.4.9 :D
Ecco passo passo cosa ho fatto:

1) Dal terminale
sudo -s
cp /mach_kernel /m_k
cp -R /system/library/extensions/system.kext /
cp -R /system/library/coreservices/loginwindow.app /
cp -R /system/library/extensions/AppleSMBIOS.kext /
cp -R /system/library/extensions/AppleACPIplatform.kext /
cp -R /system/library/extensions/AppleAPIC.kext /
cp -R /system/library/extensions/IOATAFamily.kext /

2)
Fare l'update software e selezionare SOLO l'aggiornamento 10.4.10 , normalmente si sono
anche che aggiornamenti per iTunes e QuickTime , e fatelo FINIRE ma NON RIAVVIATE

3) Dal terminale
cp /m_k /mach_kernel
cp -R /system.kext /system/library/extensions/
cp -R /loginwindow.app /system/library/coreservices/
cp -R /AppleSMBIOS.kext /system/library/extensions/
cp -R /AppleACPIplatform.kext /system/library/extensions/
cp -R /AppleAPIC.kext /system/library/extensions/
cp -R /IOATAFamily.kext /system/library/extensions/
rm -rf /system/library/extensions.*

4) A questo punto bisogna riparare i permessi io per pigrizia invece di dare i permessi
manualmente ho fatto riparare i permessi a Disk Utility

5) Ora potete riavviare

6) Appena ripartito OSX verificate che la versione sia la 10.4.10 (se si è piantato
all'avvio allora qualcosa non è andato per il verso giusto)

7) Rieseguire l'update software ho trovato delle altre patch di sicurezza dopo
l'installazione della 10.4.10 , ma non aggiornare iTunes e QuickTime

8) Riavviare

9) Rieseguire l'update software e finalmente aggiornare iTunes e QuickTime ,
ho preferito aggiornare alla fine per essere sicuro che non interferissero con i
vari aggiornamenti così da capire in caso di blocco cosa fosse successo.

10) Riavviare

Finalmente avete il vostro OSX aggiornato alla 10.4.10 con tutte le patch di sicurezza
ed i vari aggiornamenti software. Questo è quello che ho fatto io ed ha funzionato
per la mia configurazione. Buona fortuna.

#18
egarim

egarim

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
Ho appena controllato in /system/library/extensions/ ma è normale avere 265 kext ? Attualmente uso uphuck 1.3 me li devo copiare tutti e poi ripristinarli ?

Questa procedura si riverisce solo per sistemi INTEL ? Ho provato su un amd con uphuck 1.3 con SSE2 ma non ha funzionato al riavvio ho avuto una schermata in fase di boot con kernel panic

#19
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
il nn riavvio dopo la procedura è normale fatelo continuare e si riavvierà da solo ora aggiorno la procedura...

#20
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
vorrei dirvi una piccola cosa. Ho provato, un paio di mesi fa o forse uno, a fare questo procedimento da solo. Anche a me e' andato in panic. Quando ho provato a rifarlo, senza di system.kext rimesso, il hachintosh era partito. ora uso la patch.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy