Jump to content

uphuck 10.4.9 v1.3 sur P4I65G et sur un disque USB?!

- - - - -

  • Please log in to reply
11 replies to this topic

#1
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Salutation à tous :rolleyes:
Je vous écrit pour 2 soucis liée au boot de mac osx après une installation réussi.
Tous d'abord, sur un PC fixe :
µP : Pentium 4 (socket 478)
C-M : P4I65G
Mémoire : 1 Go Kingston
Disque durs : 1*15Go avec OSX desssus, 1*80Go avec Windows XP
1 lecteurs DVD + 1 graveur CD.

J'ai effectué l'installation de MACOSX en mettant sur la même nappe IDE : le lecteur DVD (en master) et le disque de 15Go en slave.
J'ai installé tous les patchs etc...
Au 1er reboot, j'ai un écran noir avec l'underscore et sa bouge pas.
J'ai lu plusieurs poste (ici/google..) qui indique de mettre en option de boot : disk1s1/disk1s2 ...
Cette soulution fonctionne mais uniquement si j'ai booter d'abord sur le DVD d'installation, appuyer sur F8 pour avoir le menu de boot puis entrer la commande.
Sans le DVD d'installation, en entrant la commande avec le menu boot, cela ne passe pas.
J'ai lu ceci aussi : http://wiki.osx86pro...L_10.4.8#ASRock concernant ma carte. Si je réinstall MACOSX en suivant les conseils de cette page, pourais-je apres :
- démarrer MACOSX sans devoir entrer de commandes spécifiques et SANS le DVD ?
- mettre mes deux disques sur la même nappe pour apres tenter un éventuel multiboot ?

ou le probleme vient d'ailleur?!
J'ai un autre souci mais chaque chose en son temps....
Merci de votre aide précieuse. :unsure:

#2
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
c'est juste le bootloader qui ne s'est pas installé.
J'avais donné les info pour l'installer manuellement dans un autre post il y a quelques jours :unsure:

#3
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Merci pour ta réponse gotoh.
Mais, comment ce fait-il que ne se soit pas installé durant l'insallation de MAC OSX?
Sinon, j'ai fait une recherche dans le forum, je n'ai pas encore retrouver ton post .. je poursuis mes recherches..

#4
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Salutation,
Bon, j'ai avancé dans mon problème. Enfait, j'ai vu sur ce forum qu'il ne fallait faire qu'une partition et la formaté en tant que syteme dos/windows et non le format par défaut.
Donc maintenant, j'arrive à booter sans le DVD donc de maniere normal, j'ai le son, je suis en 1024*768 et les clés USB sont reconnus :D (manque encore le wifi mais j'ai pas encore regarder...).
Par contre, maintenant que mon systeme est operationnel, j'ai voulu mettre le disque contenant MAC OSX en slave avec celui de XP mais sa passe pas : je démarre l'ordi (le boot par défaut est le disque XP) : le bios se charge puis un long écran noir d'au moins une minute et enfin XP se lance. Si je selectionne le disque avec MACOSX dessus (via la touche F8), idem, un long écran noir et c'est XP qui finit par se lancé. En enlevant le disque MACOSX, le chargement d'XP redevient "normal".
Enfait, je suis obligé de mettre le disque conteant MAC OSX sur la nappe contenant le lect. DVD pour le démarrer.
Comment faire du multiboot sachant que les deux systemes sont sur des disques different et non sur une partition differente? Les tutos multiboot sur le même disque peuvent s'appliquer dans ce cas là?!
Merci!

#5
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Un ptit UP :(
Merci!

#6
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France

Merci pour ta réponse gotoh.
Mais, comment ce fait-il que ne se soit pas installé durant l'insallation de MAC OSX?
Sinon, j'ai fait une recherche dans le forum, je n'ai pas encore retrouver ton post .. je poursuis mes recherches..

c'était pas si loin :rolleyes:
http://forum.insanel...howtopic=58978#

#7
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Je pense que tu parles de cela?

diskutil list
## write down the volume name and disk identifier info example: (disk1s1)


## unmount the disk that needs the boot loader
## remove quotes if you do not have space
diskutil unmount "/Volumes/volume name"

## replace out 1s1 with your disk# and partition #
## this installs boot1h in the 1st 512 blocks
dd if=/usr/standalone/i386/boot1h of=/dev/rdisk1s1 bs=512 count=1

## replace out 1s1 with your disk# and partition #
## this installs the 2nd stage boot loader to the target disk
/Applications/Clonetool/sbin/startupfiletool /dev/rdisk1s1 /usr/standalone/i386/boot

## bless the target device
sudo /Applications/Clonetool/sbin/bless -device /dev/disk1s1 -setBoot -verbose

## replace out 1s1 with your disk# and partition #
## note this entry is NOT a raw disk
## mount device
diskutil mount /dev/disk1s1

## remove quotes if you do not have space
## Bless the mount
sudo /Applications/Clonetool/sbin/bless -mount "/Volumes/volume name" -setBoot -verbose



Si j'ai bien compris, cela permet de changer la recherche du boot? Ou de mettre le bootloader?
Si je mets le bootloader sur le disque MACOSX et que apres je branche les deux disques sur la même nappe, je pourrais avoir le choix au boot? Si oui, c'est niquel chrome! En plus je touche pas au disque Windows,c 'est encore mieux..

#8
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
ça installera un bootloader darwin sur le disque sur lequelle Mac OS X est installé (si tu suis bien ce guide)
Si Windows est sur un autre disque physique, tu dois pouvoir choisir le disque de démarrage par ton BIOS directement (sur ma carte mère, si je fais F12 au démarrage, ça me permet de choisir sur quel disque je veux démarrer)

#9
w0lf

w0lf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Mais ce bootloader n'est pas déjà present? Il me semble que si...
Par contre, cette procédure va donc me permettre de pouvoir brancher le disque OSX et le disque Windows sur la même nappe sans qu'ils se mélangent les pédales ?!
J'ai aussi une option de choix de boot sur ma C-M (F11)...

#10
spootnack

spootnack

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Hello everybody ! Désolé je sais que ce post n'est plus d'actualité mais c'est le seul site que j'ai trouvé avec une réponse probable au même problème cité ci-dessus. (J'ai installé Mac OS X pour PC et quand je boot j'ai aussi un underscore sur écran noir sans qu'il ne se passe quelque chose) J'aimerais savoir si j'ai deux disques durs branché en S-ata il y'a aussi le même problème de Maître et Esclave (Il me semble que non ?! ) Même si je choisis manuellement (F8) de booter sur mon DD avec Mac OS X cela ne marche pas......je suis perdu HELP please sinon j'ai plus ou moins esssayé cela:

QUOTEdiskutil list
## write down the volume name and disk identifier info example: (disk1s1)

## unmount the disk that needs the boot loader
## remove quotes if you do not have space
diskutil unmount "/Volumes/volume name"

je crois que j'ai mis /dev/disk1 mais j'ai pas tro comrpis le quel choisir par ce que y'a au moins 3 sous- partitions

## replace out 1s1 with your disk# and partition #
## this installs boot1h in the 1st 512 blocks
dd if=/usr/standalone/i386/boot1h of=/dev/rdisk1s1 bs=512 count=1

## replace out 1s1 with your disk# and partition #
## this installs the 2nd stage boot loader to the target disk
/Applications/Clonetool/sbin/startupfiletool /dev/rdisk1s1 /usr/standalone/i386/boot

La il me mettait "No such file directory" ou "not a directory"

## bless the target device
sudo /Applications/Clonetool/sbin/bless -device /dev/disk1s1 -setBoot -verbose

Et là "sudo: command not found"

## replace out 1s1 with your disk# and partition #
## note this entry is NOT a raw disk
## mount device
diskutil mount /dev/disk1s1

## remove quotes if you do not have space
## Bless the mount
sudo /Applications/Clonetool/sbin/bless -mount "/Volumes/volume name" -setBoot -verbose


J'ai un P4 avec une carte mère Asus P4P800 SE et deux DD aec XP et Mac (10.4.8 je crois suis pas sur)

Help please. Merci d'avance

#11
wazzamad

wazzamad

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Il faut mettre la partition du ton disque OS X comme ACTIVE sinon il ne boot pas qd il a une autre partition active

#12
spootnack

spootnack

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Comment ca "active" ????? Dsl j'ai jamais entendu ce terme. Et comment on fait ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy