Jump to content

atheros 5006EG WORKING!


  • Please log in to reply
94 replies to this topic

#61
tdo

tdo

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
i was thinking about switching out my atheros card with another wifi card that works.

anyone tried this?

#62
espskog

espskog

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Norway
I am going crazy cause the link in this thread with the Header files is not possible to download :-\

An someone please post the files needed to get AR5006(GE) working, please ?


Espen

#63
macconvert

macconvert

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:eastern penn's woods

OK...Let's try this:
Kext and Headers
This has the pre-extracted kext and header folder, I also included Kext Helper to install the kext, just drag the kext package into the Kext Helper window (NOTE: if you are not using a password, in the password field type any character, like a period, to activate the easy install button, then delete the character).


Can anyone tell me what's supposed to be in said Headers folder. The update 2007004 doesn't have a headers folder. so i'm a bit confused. The links are broken again. I've got my Atheros AR5004x installed and recognized using the 10.4.5 update IO80211family.kext, however it won't turn on. ;)

I have a Thinkpad T60p (2613-CTO) with the IBM 802.11 a/g mini pci-e adapter (aka Atheros AR5004x). Help? Anyone.

For now I'll try only installing the IO80211family.kext from the airportextremeupdate2007004.dmg.

#64
macconvert

macconvert

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:eastern penn's woods
Ok so it's working... only os x shows it as off in system prefs.

I used the 10.4.5 IO80211family.kext (no edits) and the recompiled IONetworkingFamily binary from a post i can't now find. so it's working! pretty much.

#65
NRGZR

NRGZR

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
macconvert can you PM me your kext? im try setup my Atheros 168c,1c with 10.4.8 without luck :( and after using installer from this topic i have blue screen... maybe your kext helps me

#66
sjb05004

sjb05004

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I know this thread is somewhat buried, but I could really use the 5006-wireless-install.zip if anyone could re-host or send it via e-mail. I had it backed up somewhere and seem to have misplaced it. Many thanks!

#67
sjb05004

sjb05004

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
anyone???

#68
teknojunkie

teknojunkie

    InsanelyMac Legend

  • Donators
  • 829 posts
  • Gender:Male
  • Location:Corona, California USA
  • Interests:Computers, Coding, Skateboarding, Snowboarding, Video Games
Attached File  5006_Wireless_install.zip   1.69MB   2972 downloads

here it is

#69
sjb05004

sjb05004

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
You are a godsend! Thank you so much!!

#70
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
this driver doesnt work on 5007?

#71
Hendry Lai

Hendry Lai

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I tried the instruction but it's still not working for my Leopard 10.5.2. Anyone tried it in Leopard 10.5.2? Thanks B4

#72
diverse

diverse

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

1) download airport extreme update 04-2007 from apples website.2) installer will say no supported hardware, cant install.3) manually extract io80211.kext and new included frameworks from airport update.4) replace io80211.kext in /system/library/extensions5) insert provided framworks (directory name is - headers)into /system/library/frameworks/kernel.framework/versions/A/6) run terminal, type sudo -schown -R root:wheel /S*/L*/E*/chmod -R 755 /S*/L*/E*/7) open disk utility and repair disk permissions8) restart and enjoy working WIFI!!!**optional**you may have to insert your Device ID into io80211.kext/atheros.kextLET ME KNOW IF THIS WORKS FOR ALL OF YOU?

Thanks so much for your help, is there a work around for Leopard, when i try to drag and drop the headers folder into versions/A/ it says i do not have permission....... any help would be so greatly appreciated

1) download airport extreme update 04-2007 from apples website.2) installer will say no supported hardware, cant install.3) manually extract io80211.kext and new included frameworks from airport update.4) replace io80211.kext in /system/library/extensions5) insert provided framworks (directory name is - headers)into /system/library/frameworks/kernel.framework/versions/A/6) run terminal, type sudo -schown -R root:wheel /S*/L*/E*/chmod -R 755 /S*/L*/E*/7) open disk utility and repair disk permissions8) restart and enjoy working WIFI!!!**optional**you may have to insert your Device ID into io80211.kext/atheros.kextLET ME KNOW IF THIS WORKS FOR ALL OF YOU?



#73
nanobrat

nanobrat

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
>3) manually extract io80211.kext and new included frameworks from airport update.

Can someone explain how to extract this? Do I extract it from the airport update 2007-04? Where/how do I extractorate this?

Thanks!

#74
Netola

Netola

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Nanobrat, excract this to your /System/Library/Extensions folder
dont forget to fix your kext permissions, open your terminal and do the following:

chmod -R 755 /System/Library/Extensions/
chown -R root:wheel /System/Library/Extensions/
touch /System/Library/Extensions
exit
sudo -k


The Atheros 5006EG works out of the box on the great Leo4AllV3 distro.
Im on in my toshiba satellite with atheros 5006EG right now with Leo4Allv3 ;)

#75
nanobrat

nanobrat

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Nanobrat, excract this to your /System/Library/Extensions folder
dont forget to fix your kext permissions, open your terminal and do the following:

chmod -R 755 /System/Library/Extensions/
chown -R root:wheel /System/Library/Extensions/
touch /System/Library/Extensions
exit
sudo -k
The Atheros 5006EG works out of the box on the great Leo4AllV3 distro.
Im on in my toshiba satellite with atheros 5006EG right now with Leo4Allv3 ;)


Hi Netola, thanks for the speedy help! Are you saying I should just extract/unzip the contents of this installer into the extensions folder? Headings folder and all? (and then do the permissions stuff after)

thanks so much

#76
Marcelo Mendes

Marcelo Mendes

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Worked perfectly on my Toshiba P205-S6327 laptop with Atheros AR5006X wireless. Thank You very much. If you know how to make an installer, others would be forever in your debt (or for a while anyway), the extraction and installation required me to use Pacifist, but the process could be greatly simplified.


You can send our IO80211Family.kext for me?

#77
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime
After reading the posts on this thread I managed to get the Linksys WMP300N PCI Wireless N Adapter (Atheros 5416)
working with iAtkos v1.4a.

Thx !

#78
feliplay

feliplay

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
not working for me on leopard 10.5.2 , when i reboot i got a blue screen .

#79
braveskunk

braveskunk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male
  • Location:Poland
i got this weird loaded unsuccessfull which i doesne even now what means? i managed to have kext loaded on startup so OS sees the card but still cant attach device HAL 3 when -v is used when booting. anyone any ideas?
using leo4all v3

#80
nieuk

nieuk

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hello i hope people still read this topic.

I have MSI Wind and use the MSIWindosx86 10.5.4 and Atheros 5006X

at the begining i have to admit that im totally new to Macs and know nothing about them, this is my first attempt to get to know each other better.

To the point:
Card seems to be detecred coz it is listed in the Network Preferences how ever i can not turn it on. I tried to download the .kext files but when unzipped it always crashed with loads of errors.
im stuck hereandwithout working Wifi Macis uselesstome:(

Thanks for your help in advance





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy