Jump to content

OSX86 Games problem


  • Please log in to reply
15 replies to this topic

#1
thirin

thirin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi OSX lovers,

I have an problem. I've tried Luxor 2 and Civilization 3 but everytime i start them i get blank screen on my laptop. I think it has some connections with refreshing rate because i get same effect when trying to switch 70hz refresh from desktop. My Machine is IBM thinkpad t40, calisto 006, ati 7500 pack, and config:

Radeon Mobility 7500:

Chipset Model: Radeon Mobility 7500

Type: Display

Bus: AGP

VRAM (Total): 32 MB

Vendor: ATI (0x1002)

Device ID: 0x4c57

Revision ID: 0x0000

Displays:

Color LCD:

Resolution: 1024 x 768 @ 60 Hz

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported













Please help, everything else is working perfectly.



P.S. Is there any way to specify refresh rate for all aplications?

#2
R2k.

R2k.

    One minute to midnight

  • Members
  • PipPipPipPipPipPipPip
  • 917 posts
  • Gender:Male
  • Location:Serbia
  • Interests:Music production and sound design
same problem with ATI 9600xt ,without answers ....


~R

#3
gadzhev79

gadzhev79

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
same problem i can't play any game just black screen and i can hear just sound.
i have 2.6MHz Core2Duo 8GB RAM NVIDIA 8800 GT 512MB and ABIT IP35Pro Motherboard
Please send me an e-mail if you know how to fix it.
Thanks :unsure:

#4
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
dunno about the others cuz these cards are too old and are using CAllisto which is a framebuffer made by omni, but gadzhev79, you should try your other DVI port.

#5
no.fear3224

no.fear3224

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
lol i spent hours trying to figure out why i couldnt change my screen resolution or start a game on my new computer i built..has a 8800gt OC manufactured by zotac, i thought it was the card so i tried tons of different drivers and everything i could think of to get the resolution to change (without restarting the PC and getting games to play) of course after a wasted saturday i tried the other dvi port and it works flawlessly.

#6
ZenecadE

ZenecadE

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I should give this a try. My notebook running x700 runs most games flawlessly on 10.4.9. My desktop got dual DVI 8600GT and games got sound alright but no picture. Exiting the game doesn't help my cause as a full on reboot is required. Sexy!

#7
lnerrrka

lnerrrka

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
In many games, look for some kind of settings file and change resolution from full screen to windowed. It worked for me in NFS Carbon, Luxor and some others :D ^_^

#8
mannenberg

mannenberg

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

i spent hours ...
i tried the other dvi port and it works flawlessly.


Thank you! The same for me. It solved the problem.

#9
Danimt

Danimt

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

same problem i can't play any game just black screen and i can hear just sound.
i have 2.6MHz Core2Duo 8GB RAM NVIDIA 8800 GT 512MB and ABIT IP35Pro Motherboard
Please send me an e-mail if you know how to fix it.
Thanks ;)


Happens the same to me.
When I start Battlefield screen goes black and I can only hear sound.

According to my system configuration all looks ok...

Posted Image

#10
venerzky

venerzky

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Same problem here, qe/ci fully supported and enabled, using nvidia geforce 9500 gt,, only blue screen w/ sounds when I try to play games for mac os x,,


#11
Shadow_2k

Shadow_2k

    InsanelyMac Geek

  • Donators
  • 128 posts
  • Gender:Male
  • Location:Germany

Same problem here, qe/ci fully supported and enabled, using nvidia geforce 9500 gt,, only blue screen w/ sounds when I try to play games for mac os x,,


Try switching video ports as suggested by cyclonefr a few posts earlier. That work for mE when I built my first hackintosh a year ago.

#12
BLARGiAMdEAD

BLARGiAMdEAD

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts

Try switching video ports as suggested by cyclonefr a few posts earlier. That work for mE when I built my first hackintosh a year ago.


Same (although I've only tried Rise of Nations under Rosetta, so that might be the problem). I've got a 9800 GT.

#13
nozz93

nozz93

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts
  • Gender:Male
  • Location:Germany
Had that problem too, first I switched to the other DVI port (that one that is nearer to your mainboard) and then I installed another graphics kext. Switched from NVkush to NVdarwin. You could try that. And if you have a DVI and VGA port, use the DVI port.

#14
BLARGiAMdEAD

BLARGiAMdEAD

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
My games now work, having switched the monitor port. :wacko:

#15
frankov

frankov

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I'm having the problem you all describe with Sims 3.

My card (9800GT) is installed correctly, the game starts and I only see the cursor (the rest is a black screen).

I know you're suggesting to use the DVI port instead of the VGA one, but I'm already using the DVI port.

I'm going to restart and try the VGA port in a couple of minutes (waiting for a download to finish). I'll post if it worked or not.

#16
frankov

frankov

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I tried restarting only using the VGA connector only, but it didn't work.

Could it have something to do with the fact that :

  • I don't have a DVI cable with my monitor, only a VGA one (it has the 2 connectors on the monitor, though)
  • I use a VGA-DVI convertor to connect to my PC

Any thoughts ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy