Jump to content

texture fix for GTA:San Andreas under Cider?


  • Please log in to reply
18 replies to this topic

#1
segaprophet

segaprophet

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've been following everyone's progress on making Windows games work under the Cider template in the other thread for a while, but seeing as no one has posted there in over a month, I figured I'd put my question in a seperate thread -

Anyway, has anyone found a fix yet for the missing people-textures problem in GTA:San Andreas under Cider yet?

#2
swistak

swistak

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
either download my config, or try emulating win XP with pixel and vertex shader version set to 1.3 or 1.4

have you possible managed to fix the mouse centering issue?

#3
isometric

isometric

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

either download my config, or try emulating win XP with pixel and vertex shader version set to 1.3 or 1.4

have you possible managed to fix the mouse centering issue?



I'm wondering the same thing. graphics don't seem to be a problem but the Mouse Centering Issue is! :(

#4
nortonjg

nortonjg

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
i am having problems with the texture and the mouse thing any help would be great thanks

either download my config, or try emulating win XP with pixel and vertex shader version set to 1.3 or 1.4 have you possible managed to fix the mouse centering issue?

What do u do when u download that i saw there was a config file in the preferences folder and replace that but still the same what am i ment to do with this?

#5
Grind

Grind

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have a problem with GTA San Andreas too. The mouse stays in the center..How can I fix this?

#6
ciderguy

ciderguy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
After reading this thread and some others, I have my own fix for the mouse pointer locked centering issue taken from a post realted to the Far Cry Mouse fix: (sorry, I lost the url).

GTA San Andreas Cider/Mac Version:

Goto SanAndreas.app/Contents/Resources/Preferences/Config

Make a backup copy of the file just in case.

open the file with the textedit.app

Find the text:

"AbsoluteMouseSensitivity" = "0"

replace it with

"AbsoluteMouseSensitivity" = "1"

Enjoy the game :thumbsup_anim:

#7
NuMetaler

NuMetaler

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
@ Cideguy: Found the url already?

#8
NuMetaler

NuMetaler

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
BTW, all rooms in my San Andreas are black. anyone got the same problem and knows how to fix it?

#9
NuMetaler

NuMetaler

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
For gamers who know more about sa: always i enter an interior located in the black hell, every texture is black except the arrow at the door and the lighting effects in some rooms on the floor.

#10
dafootballer

dafootballer

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts
you may have an older cidered version of SA theres a few knew ones were the mouse works perfect and texture problems are fixed :)

#11
NuMetaler

NuMetaler

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
What about the keyboard? When i press the space bar, it thiks it's the S key. Where to find the new version without the GTA? I don't want to download the whole game again, because i own it already.

#12
macintosh72

macintosh72

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Does anyone else have the chrome problem in san andreas? If I import any car mods, they come out completly chrome with the reflection ultra high so that the car appears completly silver.

I have re-ported the game myself with my windows copy, but it still comes out the same. So I am wondering if it is a setting in CONFIG that can be adjusted.

Does anyone know?

Thanks

Attached Files



#13
user987654321

user987654321

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

either download my config, or try emulating win XP with pixel and vertex shader version set to 1.3 or 1.4

have you possible managed to fix the mouse centering issue?


where is your config download??

#14
emanuel botelho

emanuel botelho

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Does anyone else have the chrome problem in san andreas? If I import any car mods, they come out completly chrome with the reflection ultra high so that the car appears completly silver.

I have re-ported the game myself with my windows copy, but it still comes out the same. So I am wondering if it is a setting in CONFIG that can be adjusted.

Does anyone know?

Thanks


i have the exact same problem too... was almost determined to give up, as it appears to be something to do with the mods themselves. the reason i say this has to do with the fact that many cars do work fine, others just have minor details showing up the chrome bug. but then again some of the original textures in the game have it too... i really don't know what to do. did you manage to fix it? it really is a pity, i can't install lots of cool european cars (most french and russian/eastern european cars) because of the chrome texture bug.

please, please, drop me a line if you figured this out, or ever come to. i've tried everything i can think of, even stripping down the txd files to compare the data between working and non working cars. there are no obvious differences, at least none that i noticed.

thanks a lot for your time

#15
emanuel botelho

emanuel botelho

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

either download my config, or try emulating win XP with pixel and vertex shader version set to 1.3 or 1.4

have you possible managed to fix the mouse centering issue?


how can i download your config?

i'm having texture issues, as described in my previous post in reply to Macintosh72. are you familiar with this problem? do you think your config can fix this? if so, please, please let me know how to download it.

my port version should be a recent one, the mouse bug was already fixed.

specs:
macbook 13" 2.4Ghz Core 2 Duo, 2GB RAM, 250GB HD, intel GMA X3100 (yeah, the card sucks, but i don't mind playing in low quality and resolution, just wish i could play it on one of xiorxorn's renault 11 ;))

appreciate all the help i can get!

#16
ben21684

ben21684

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
hello

has anybody fixed the problem with the chrome texture? I have tried a lot but nothing works. there is a fix for windows but i cant use it for the cider port.

#17
blreichert12

blreichert12

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I'm new to InsanelyMac, but I was experiencing the same missing people clitch. The solution that worked for me involved first finding what I believe was "VertexShaders= 'N.'" Changing the "N" (No) to a "Y" (Yes) seems to solve the problem and seems to make people show up as they should. Changing specific numerical values, as another poster has suggested, does not seem necessary. Hope this helps :) . Also, if anyone does not know what line of code I am referring to, reply back and I will clarify.

I've been following everyone's progress on making Windows games work under the Cider template in the other thread for a while, but seeing as no one has posted there in over a month, I figured I'd put my question in a seperate thread -

Anyway, has anyone found a fix yet for the missing people-textures problem in GTA:San Andreas under Cider yet?



#18
Timdphotos

Timdphotos

    InsanelyMac bookPro

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male

Does anyone else have the chrome problem in san andreas? If I import any car mods, they come out completly chrome with the reflection ultra high so that the car appears completly silver.

I have re-ported the game myself with my windows copy, but it still comes out the same. So I am wondering if it is a setting in CONFIG that can be adjusted.

Does anyone know?

Thanks

you might have typed the chrome cheat in t he past, my friends have done it and they
can't get it back

#19
ben21684

ben21684

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
what is the chrome cheat? Where can I turn on Shaders?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy