Jump to content

Remove Read-Only Files


  • Please log in to reply
7 replies to this topic

#1
GinkoStar

GinkoStar

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,

when i try to remove iwi2100.kext (rm -R /System/Library/Extensions/iwi2100.kext) i get the following error: "Read-only file system" and so i cant delete them.

Could you help me pls?

Thank You

#2
sarahbau

sarahbau

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 903 posts
  • Gender:Female
  • Location:Raleigh, NC
You have to be in super user mode to delete that. Simply type "sudo" before that command (in the same line with it), and it will ask your password before it does it. If that still doesn't work, try moving it out of the Extensions folder instead of deleting it. Something like this:

sudo mv /System/Library/Extensions/iwi2100.kext ~/Desktop/

That will move it to your desktop

#3
GinkoStar

GinkoStar

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thank you for the answer!

Unfortunately it doesn't work. I tried doing:

1) sudo rm -R /System/Library/Extensions/iwi2100.kext and
2) sudo mv /System/Library/Extensions/iwi2100.kext ~/Desktop/

but he continue saying "Read-only file system".


I mean:

1) override rw-r--r-- root/wheel for /System....? y

rm: /System/.... Read-only file system.


2) mv: rename /System/... to /var/root/Desktop/: Read-only file system


What can i do? How do i delete this file?

Ty again!

#4
Kaspers

Kaspers

    Pro

  • Members
  • PipPipPipPipPip
  • 315 posts
  • Gender:Male
  • Location:the Netherlands
In finder :whistle:.
Works like a charm here after typing my password in the dialog box which comes up..

#5
GinkoStar

GinkoStar

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

In finder :) .
Works like a charm here after typing my password in the dialog box which comes up..



What?

Sorry, but i dont underrstand you... i'm in boot (-s flag).... ;)


The problem persist... somebody could help me please??

#6
deciti

deciti

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
for those of you stuck on this problem, boot into single user mode and run:

mount -uw /

you can then sudo rm whatever you like.

#7
Dimac

Dimac

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks so much deciti, you saved me a sleepless night!

#8
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil
Once single user mode is done booting, this is on your monitor, right in your face!

It says something like this:

To make modifications to files
mount -uw /

If you missed that, be prepared for more sleepless nights.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy