Jump to content

Atheros AR5007EG, Who can help me?


  • Please log in to reply
96 replies to this topic

#1
Romil

Romil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
I am a fish about Mac OS X, so I wonder if someone can help me with that Atheros AR5007EG.
All I want is to get it work.

#2
Romil

Romil

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
VenID: 168C
DevID: 001C

#3
royideas

royideas

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Romil Hey =) we just know how recognized our atheros AR5006, AR5007 ) but in when see in profiles airport write that network not available )) you can try ) Heres my IO80211 kext which includes. Copy this IO80211Family.kext to /System/Library/Extensions then Permissions fixed and in termimal do it
sudo -s

chmod -R 755 /System/Library/Extensions/IO80211Family.kext

chown -R root:wheel /System/Library/Extensions/IO80211Family.kext

kextcache -k /System/Library/Extensions/


then reboot ) and your airport will be recognized but not working =( kernel panic when connect to your wriless network (
If you have any solution it will be adorable )

#4
ZaiS

ZaiS

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i have the same wifi card on my acer 3693.

what changed in this kext?

#5
royideas

royideas

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
there add new kext atheros and here recognized our adapter ) but when wanna connect to network will be kernel panic nobody don't know why... we are confused...

#6
cabegol

cabegol

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I've tried your kext, my AR5006 got recognized for the first time (and believe me, i've tried many workarounds with no sucess), but, for some reason,
it appears as "airport not configured" and in system preferences/network it shows up as PCI-E Ethernet Controller....weird... Just a report.
Oh, by the way, the system is a Toshiba Satellite a135-s4656 and the wifi card is VEN 168C DEV 001c

#7
ZaiS

ZaiS

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
$ sudo kextload -t AirPortAtheros.kext/kernel extension AirPortAtheros.kext/ has problems:Missing dependencies:{ "com.apple.iokit.IOPCIFamily" ="A valid compatible version of this dependency cannot be found"}Warnings:{"Kext has a kerneldependency prior to version 6.0 and CFBundleVersion does not match executable'sMODULE_VERSION" = true}

any ideas?
is it http://forum.insanel...amp;#entry38453 what i need? May be i just may create a soft link on IONetworkingFamily.kext?
i installed mac from uphuck 10.4.9 v1.3.
and my Network Preferences crashes :)

#8
royideas

royideas

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
no don't have any ideas what to do... i'm tired with this adapter... we don't have suggestion... stupid ar5006... and ar5007... don't wanna work good. so sad... really... without wi-fi laptop not laptop it is like desktop with wires... we need wi-fi but he doesn' work... what to do anybody help us =) THX vry much

#9
ZaiS

ZaiS

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
RoyIdeas you damn right.
Besides I can't force to working my Ethernet card (Broadcom 4401), because Network Preferences crashes ;( (http://forum.insanel...showtopic=54371)

#10
Aces

Aces

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I just registered to let you know that I think there are MAJOR issues with the AR5007EG.

I have a BRAND NEW Aspire 3680 with that card. Went through the "Vista" setup after its very first bootup, and it won't connect.
This problem is NOT exclusive to MAC users.
It can see the wireless router, but will not connect to it.

Just thought you'd like to know.

Aces.

#11
ZaiS

ZaiS

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i loaded this kext, but still no wifi :P .

#12
ZaiS

ZaiS

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Aces, I think that you are mistaken, because my wifi-card works (in vista).

#13
ThePhased

ThePhased

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Yep both my AR5006X and AR50007EG minipci-e work fine in vista..both are no go in OSX still :(

Maybe i could try the broadcom minipci-e, but it seems as though others are having problems with that too.

#14
Aces

Aces

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I thought my experience might have been useful information for you, however it turns out I had to disable Driver Signature Enforcement to let the card work in my Vista setup. That piece of info is really of no use to this thread.

Therefore, since it is not useful, I apologize and shall now bow out of the thread.

Thanks!

Aces.

#15
bemac

bemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
To Aces, The AR5007 is a superb performer in my Acer notebook. I can sit outside in my garden at the very other side of my house and get a good signal with it.
Where the macbook has a usable signal and a powerbook none. It really has surprised me how good a reception it has / wireless link it creates. Must have good antennas too, I guess.


That said, it doesn't work with OS X and I am eager to find a solution for it in x86 with my Acer 5570z

I can't get wifi nor ethernet. JAS 10.4.8 & Uphuck v1.3 :huh: (no sound yet either)

Atheros AR5007EG wireless

Marvell Yukon 88E8038 PCI-E fast ethernet

Realtek High Definition sound

#16
fsck3r

fsck3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
bemac, I saw that you were replying to the other thread from Eskruza, if you use that same audio package he lists but in the customize choose 3 port digital and 6 port, 6port digital...worked for me, still no ethernet or wifi...

#17
bemac

bemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Thank you, for the recommendation fsk3r.

I will have to do some experimenting. Tried what you said, but no dice. But, it gives me some ideas for other combinations.

#18
fsck3r

fsck3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
What you also have to do is change the settings in the system prefences to use the first "Built-in Speakers" option then change it to the same setting in your output tab

-Mick

#19
bemac

bemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Thanks,

As I had to re-install (rather than trying to fix a bad 10.4.10 upgrade) I selected the azalia sound (instead of realtek) with uphuck 1.3 and sound works via speakers, by default! Was greeted with welcome animation with sound, sample video clip works.

No sound over headphones now, but that's no immediate concern to me. I prefer speakers over headphones.

#20
bemac

bemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
According to atheros cz ... there would be linux drivers for the Atheros AR5007 via madwifi
http://www.atheros.cz/

But then madwifi says it is not compatible yet http://madwifi.org/w...ibility/Atheros
but would however be possible with the windows driver.

Found this positive ubuntu user report http://ivangarcia.org/blog/?p=13 ; who links these instructions http://docs.google.c...tvgpkz_46fv8dwf

Chipset: Atheros AR5007EG (rev 01)PCI ID: 168c:001cDownload the windows 32-bit drivers from here. [ ftp://ftp.work.acer-euro.com/notebook/asp...os_v5_1_1_9.zip ]

Download and install the last version of ndiswrapper [ http://sourceforge.n...?group_id=93482 ] (it works from 1.45 version)Installation [ http://ndiswrapper.s...d,installation/ ]

Try to remove the module ath_pci to let ndiswrapper to use the wifi.
"sudo rmmod ath_pci" or "sudo modprobe -r ath_pci"

also try put that module in the blacklist of modprobe to avoid his
loading on the startup:

sudo nano /etc/modprobe.d/blacklist-common

Insert this line:
blacklist ath_pci

Then restart.
When u will boot again.
Load the windows driver it from the uncompress folder:
#ndiswrapper -i net5211.inf
then install to modprobe
#ndiswrapper -m


Maybe an experienced linux user can chime in if this bodes good news?
This is out of my league, and may be impossible to replicate in osx / x86.
Are we stuck waiting till madwifi would support AR5007?
Or till Apple uses that chip in an updated system?

Update: I've been informed that ndiswrapper is a linux only tool:(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy