Jump to content

Marvell Support Effort


  • This topic is locked This topic is locked
222 replies to this topic

#61
other

other

    Other.

  • Retired
  • 929 posts
  • Gender:Male
  • Location:Behind the flower pot
I have to reinstall the kext after every sucessful reboot to keep it working

#62
mortis

mortis

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
in order to prevent reinstalling with every reboot,

a) correct permisions
:excl: delete extensions.mkext and extensions.kextcahche from /system/library/


good luck

if anybody wonders, I "DHCP" and do not PPPoE in my setup......

#63
Viggy

Viggy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Up and running un a Toshiba M45sp351
Marvell is 88E8036
Just extracted the AppleYukon.kext plugin and placed it on my ionetworking family.kext plugijn folder, edited the usual plist.info to add the model, and chowned the whole thing.....

so far so good... gets recognized as a 88e8053

Os is 10.4.3, ( the 099 one not the 11a g or whatever)


mortis i'm a complete newbie in macos...can you explain with more detail what i have to do to make my marvell ethenet card works?

i have downloaded this: [Violation of DMCA]

what i have to do next?

thanks in advance.

#64
tonyl

tonyl

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Oh {censored}, I need a fix for 88E8001 soon. I'm stuck with the integrated NIC in my laptop. It's not fair LOL


You can buy dell 1350 or 1450 mini-pci to get airport Extreme.

#65
mortis

mortis

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts

mortis i'm a complete newbie in macos...can you explain with more detail what i have to do to make my marvell ethenet card works?

i have downloaded this: [Violation of DMCA]

what i have to do next?

thanks in advance.



every kext (kernel extension) is essentially a directory thad contains many files within.

unzip the file you downnloaded
then "right-click" on it and select "show package contents".
You should find a new finder window that has a directory called "Contents"
Open that one, ant the open the "Plugins" directory"
Copy the AppleYukon.kext to your Desktop


Now "right-Click" on AppleYukon.kext, and Show Contents

there should be a file called info.plist

edit that file to include your vendor/ID

personally I do it Using the terminal.app, and pico

then in terminal,
sudo chown -R root:wheel /pathto/AppleYukon.kext
try it with sudo ketload -t AppleYukon.kext

if it works, move it inside your IONetworkingFamily kext:
sudo mv -R AppleYukon.kext /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins

then delete the kextcache

sudo rm -R /System/Library/Extensions.*

and reboot

GIZMO: did you user the -R flag in the chown command?

as in "sudo chown -R root:wheel AppleYukon.kext"

Edited by other, 17 February 2006 - 03:00 AM.


#66
EdFlyer

EdFlyer

    Computer Lackey

  • Members
  • PipPipPip
  • 159 posts
how far are you along in getting your driver to work? I have found that editing the plist doesn't get the driver working for me, instead it causes a kernel panic. So if its possible can you get the wired driver working. Thanks.



Posting from wireless Broadcom 4318 b/g
MAC OS X
Mobile Athlon 64 3700+

Also Booting:
Windows XP Pro 32
Windows XP Pro x64
Windows Vista Beta 1 x64
WIndows 2003 Server 32
Knoppix

#67
Viggy

Viggy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

....


mortis i haven't try this yet but first of all thanks for help me!

i wiil try this now and say something later...

thanks again!

#68
Q-man

Q-man

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
The link for the kexts are not working. Can someone repost a working link?

Thanks.

#69
Cr4z33

Cr4z33

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Location:Italy

The link for the kexts are not working. Can someone repost a working link?

Thanks.

Here we go:
[Violation of DMCA]

#70
WTB Krol Blade

WTB Krol Blade

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Where do I add my vendor ID to that file?

#71
p3n5t3r

p3n5t3r

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
Can anyone tell me how do I look up the device ID in windows. I thought it would be in device manager, but the format in windows seems different than the one in mac os.
How exactly should I add it then?

#72
WTB Krol Blade

WTB Krol Blade

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I have tried this twice, and both times, it screwed up my OS X installation...Can someone please make a more detailed tutorial?

#73
brockpetrie

brockpetrie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
moris you are a beautiful human being.

running beautifully on my gateway with on board marvell yukon 88E8036 ethernet.

thank you again man!


now to get my broadcom wireless 4318 working!

Where do I add my vendor ID to that file?

scroll down the file awhile until you see a tag with a few chunks of text that look like 0x845911AB. there is only one tag with that stuff in it, so you cant miss it. all you do now is put in your own device id + vendor id. for example, my device id is 0x4351 and my vendor id is 0x11AB. so just take the part of the vendor ID after the '0x' and append it onto the end of your device ID. so what i ended up adding to the file was: 0x435111AB

Can anyone tell me how do I look up the device ID in windows. I thought it would be in device manager, but the format in windows seems different than the one in mac os.
How exactly should I add it then?

http://www.pcidatabase.com has a great database of products and their respective device ID's, as well as the ID's of their vendors.

hope that helps you guys!

#74
p3n5t3r

p3n5t3r

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
I just can't load that driver.

I'm using Marvell Yukon EC 88E8053 PCI Express Gigabit Ethernet Controller which is on my asus motherboard.

The correct vendor ID is allready in the info.plist. When I try to load it I get authentication failures. File owner/permissions are incorect.

Please help.

#75
mortis

mortis

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
if you get incorrect owner/permissions, you must chane the ownership of the kext and all its files to root/wheel

sudo chown -R root:wheel AppleYukon.kext

#76
p3n5t3r

p3n5t3r

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
thx, but it still doesn't work.

I get 13IONetworkdata is not compatible with its superclass... and then a link/load error occured for kernel extension appleyukon.kext.

is there anything you left out in the step by step guide?

#77
mortis

mortis

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
which osx are you using?

Are you loading only the AppleYukon.kext or the whole IONetworkingFamily.kext?

#78
p3n5t3r

p3n5t3r

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
I'm using 10.4.1 with the 10.4.3 update where only parts get updated.

I'm loading only AppleYukon.kext. I get the same error no matter if it's already in the IONetworkingfamily.kext or on my desktop.

I'm really clueless, usually I don't have problems following detailed instructions.

#79
p3n5t3r

p3n5t3r

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
I get exactly the same error when I try to load drivers for my Wifi PCI card. Must be somthing wrong with the system I think.

#80
myzar

myzar

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 718 posts

I'm using 10.4.1 with the 10.4.3 update where only parts get updated.

I'm loading only AppleYukon.kext. I get the same error no matter if it's already in the IONetworkingfamily.kext or on my desktop.

I'm really clueless, usually I don't have problems following detailed instructions.



The kext is for 10.4.3 it will never work with 10.4.1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy