Jump to content

Marvell Support Effort


  • This topic is locked This topic is locked
222 replies to this topic

#201
iGrinch

iGrinch

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey guys.

I have Marvell 8001.
I'm a newbie here. Can you tell me what do i have to write in terminal and where do i have to put skge.kext?
Please, help.

Oh yea, dp i have to repair permissions?

#202
UnknownBadger

UnknownBadger

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

UnknownBadger- your permissions are wrong...try running disk utility or do this...


Your right it was the permissions, thanks. Works fantastic now. Great work guys!

#203
autoy

autoy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 302 posts
As musashi said there is still a big bug with this driver, as it freezes with big UDP streams like with torrent clients. Otherwise, it's working well, just don't torrent with it.

Musashi, will you think about fixing this issue later when you have time?

Thanks for your time and efforts :D

#204
helob

helob

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 216 posts

open terminal
sudo -s (password)
cp -R (drag and drop the file and remove the / at the end) /System/Library/Extensions/
reboot

done :) enjoy
go into network pref panel and c the Network adapter

Thanks Cyclonefr for above.
Where can I find Marvell 8001 product ID/Vendor ID?
Where to fill in Info.plist as Product ID and Vendor ID are not in the list?
Tnaks again for your help

#205
SaberSHO

SaberSHO

    InsanelyMac Geek

  • Retired Developers
  • 156 posts
if you have a 8001 you shouldnt have to fill in the product id/vendor id....they are the defaults. anyway...FYI 8001 is pid-4320 vid-11ab.

#206
stiffy

stiffy

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
thanks, it worked perfect on my ASUS P4P800SE (Yukon 8001)

#207
-jordn-

-jordn-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
  • Gender:Male
hey,

i am running 10.4.5, and i was wanting to know if the Marvell 88E1111 PHY Ethernet controller is supported by this driver, and if it is, could somebody PM it to me, as i have searched the forum and left many posts but to no avail.

i have an MSI K8N Neo4-F .


thanks in advance,

jordn.

#208
Eddie Turfboer

Eddie Turfboer

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
It worked for me (on a 88E8001 on a Asus P5P800). Thanks alot :D

#209
Georgiles

Georgiles

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Hollywood
  • Interests:Hackintosh

men of little faith
it's still Monday :dev:

I had little time to sort out the UDP stream issue, but since the driver works fine for normal usage, I think some of you may appreciate to have it anyway

I haven't created a new thread as I really am in a rush now

The source will follow sometime during the week (need to edit a couple of comments and add a "license" header)

Please don't post asking how to install it or edit the .plist to add your vendorid/devid - there's plenty of instruction in this forum - I will not answer

anyway, enough talk, here's the driver
bye



This driver works perfect with Yukon Gigabite on ASUS A8V-DELUXE motherboard. Now i need to do the sound.
Any ideea with this AC97 ACL850? check DxDiag.txt I attached to see my full system specs. GREAT GREAT JOB WITH THE DRIVER. YOU ARE AWESOME!!!

Attached Files



#210
oldschool

oldschool

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Location:Third rock from sun.

This driver works perfect with Yukon Gigabite on ASUS A8V-DELUXE motherboard. Now i need to do the sound.
Any ideea with this AC97 ACL850? check DxDiag.txt I attached to see my full system specs. GREAT GREAT JOB WITH THE DRIVER. YOU ARE AWESOME!!!


Hi!

I have the A8V Deluxe , too.
Theres already a stereo-fix online.
Look the 2 last days in this forum.

Would like to see a more than 2 channel support/driver...

Rgds.

#211
Georgiles

Georgiles

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Hollywood
  • Interests:Hackintosh

Hi!

I have the A8V Deluxe , too.
Theres already a stereo-fix online.
Look the 2 last days in this forum.

Would like to see a more than 2 channel support/driver...

Rgds.


Did you had the same sound hang problems?

I can't find the fix. Would you mind to attach the fix as a zip file to the reply with instal instructions. And thanks A LOT.

#212
oldschool

oldschool

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Location:Third rock from sun.

Did you had the same sound hang problems?

I can't find the fix. Would you mind to attach the fix as a zip file to the reply with instal instructions. And thanks A LOT.


Hi!

No, i got no probs with audio... Have you configure the sound with the midi setup?

Working stereo driver:
http://forum.osx86pr...topic=15555&hl=

How do i install the Yukon 88E8001 driver?
---
Okay got it. The permissions... Works great, but i read about UDP probs.
RTSP uses UDP and works well here.
Havent tested bittorent etc pp
---

Rgds.

#213
Georgiles

Georgiles

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Hollywood
  • Interests:Hackintosh

How do i install the Yukon 88E8001 driver?


ASUS A8V DELUXE Marvell Yukon working.

download driver attached: skge.kext.zip

install instructions:

open terminal
sudo -s (password)
cp -R (drag and drop the file and remove the / at the end) /System/Library/Extensions/
reboot

Thanks to M.Musashi and Bill Gates who made the driver possibile.

Attached Files



#214
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
well
it's good to see ppl happy
I hadn't time to work on it this week and the next is going to be even less likely


georgeanton: microsoft bob?? please remove the file, there's already one attachment one page back

#215
autoy

autoy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 302 posts
Nice to see you back anyway musashi :D

Great driver, good work so far. Please, don't forget about us and please fix the UDP stream problem when you can and have some time left :(

#216
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
autoy: don't worry, I'll work on it - in the meantime, have you tried a different torrent client? the driver fails only under an intense packet stream, which is quite unusual

anyway, the driver attached a page back shouldn't freeze the system anymore; at worst a slow down and should be enough to close the application

#217
autoy

autoy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 302 posts
Ok, I will try this one, I thougth it was the same as the beta.

A bit OT... I like tomato torrent client, what other universal alternatives do you guys recommend?

#218
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
just to clean up a bit after 11pages of thread, here's my new topic with driver and everything
http://forum.osx86pr...showtopic=15700

please keep using this one for anything else not strictly related to the marvell 8001 driver

tnx

#219
RobNyc

RobNyc

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 496 posts
  • Gender:Male
  • Location:NYC
  • Interests:Living Life, Going Out Places, Dancing, Music, Girls, Computers/Technology/Electronics, Philosop...
I'm glad to see this, now I finally can have 100% everything working this was the only thing missing when I first ever used (10.4.3) in January-Feb

#220
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
guys, I'm resuming this old thread to ask you about yukon2 cards

_np complained some time ago that the appleyukon.kext sucks
I don't have a yukon2 card and therefore cannot comment,
but the other day I was having a look at the linux driver and saw that writing a osx driver based on that shouldn't be a problem as it's very very similar to skge and I could easily reuse my framework

before starting coding however, I was wondering if there's an actual need
what doesn't work in the appleyukon?
keep in mind as well that I don't have a yukon2 and I would need at least one alphatester to go through the very initial testing: and that's painful sometimes





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy