Jump to content

Marvell Support Effort


  • This topic is locked This topic is locked
222 replies to this topic

#181
autoy

autoy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 302 posts
Musashi, take your time to fix the bugs, don't be stressed because of that. If we waited for so many months some days more is just nothing.

Good luck.

#182
np_

np_

  • Retired Developers
  • 339 posts
  • Gender:Male

guys, an update

driver is working but a big bug has been spotted (thanks to autoy).
basically it has to do with the transmitter stalling when there's a fast stream of outgoing UDP packets. This happens with some p2p apps, resulting in a system freeze.
It shouldn't be too hard to fix, but it requires time to stress test it (I use netperf for this which is a great little tool)

However work has catched up, and since yesterday unfortunately time is not something that I have aplenty.
If I don't find the time to fix it by Monday evening, I'll release the kext and the source as they are now. This way somebody else could have a look at it a help me speeding up the debugging.

Almost forgot, this driver is not only for the 88e8001 chip; when completed it will support:
+ Marvell 88E8001, Belkin F5D5005, CNet GigaCard, DLink DGE-530T,
+ Linksys EG1032/EG1064, 3Com 3C940/3C940B, SysKonnect SK-9871/9872
these are the card supported by skge in linux.
for yukon2 (88E8021,22,35,...) the linux driver is different (sky2) and currently implemented in appleyukon.kext (alas badly)

on Monday I'll create a new thread with kext and sources
bye
mm



good job !,

good idea also to replace stinky "AppleYukon.kext" with anythink better

:)

thanks

#183
rjtd

rjtd

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
Any news on the new driver?
(hope this is not "pestering")

#184
sam_the_killer

sam_the_killer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 252 posts
  • Location:United States
no new thread till now for marvel 8001.
was it not scheduled to be released today?

#185
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
men of little faith
it's still Monday :blink:

I had little time to sort out the UDP stream issue, but since the driver works fine for normal usage, I think some of you may appreciate to have it anyway

I haven't created a new thread as I really am in a rush now

The source will follow sometime during the week (need to edit a couple of comments and add a "license" header)

Please don't post asking how to install it or edit the .plist to add your vendorid/devid - there's plenty of instruction in this forum - I will not answer

anyway, enough talk, here's the driver


bye

#186
rjtd

rjtd

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
Thank you so much :idea:
I'm writting this now on my Laptop! Great work!

Too early: Oh my, it stopped working :blink: Do you need some output from myself?

#187
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
working great on my P4P800SE

#188
m.musashi

m.musashi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
from terminal, type "dmesg"
post the skgeosx:_______ messages
thanks

#189
myzar

myzar

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 718 posts
thx alot for your time wasted on this driver on pasquetta it works great beside the udp issue thx alot

#190
ChiefWiggum

ChiefWiggum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
:) :star_smile: :star_smile:

Works like a charm on my K8VSE Deluxe (Yukon 8001)!!
Finally can use the internet !!

Many Thanks to
m.musashi, myzar & sj !!

#191
floris

floris

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Magic. An other Yukon 8001 online :)
kudos to m.musashi for this one.
bliss.....

#192
UnknownBadger

UnknownBadger

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Doesnt work for my card:
Van 11AB
Dev 4320

I get on startup "the system extention "/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/ skge.kext" was not installed properly and cannot be used..."
I get the same message afterwards for the AppleYukon.kext too.

Removing the AppleYukon one doesnt do the trick. At one point i did have Built-In ethernet in the networking prefs pane but it said its not plugged in.

typing in sudo dmesg somewhere in the mist there is a line starting with yukonOsx and the cards mac address.

any ideas guys?

#193
npwski

npwski

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Moscow, Russia
Guys, thanks for driver, my Yukon 8001 works good now. :)

#194
SaberSHO

SaberSHO

    InsanelyMac Geek

  • Retired Developers
  • 156 posts
UnknownBadger- your permissions are wrong...try running disk utility or do this:

sudo chmod -R 755 System/Library/Extensions/
sudo chown -R root:wheel System/Library/Extensions/

(the -R is important)

-SaberSHO

#195
Jeb0921

Jeb0921

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Thanks for all your work guys. Running great on my AMD machine with a Marvel Yukon 8139 Chip.

:D

#196
gordo

gordo

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Great ! working with my P4P800-E builtin networking!

#197
Baal

Baal

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Awesome, I've been waiting for this.

#198
os_overload

os_overload

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
i guess ill join the crowd in saying that its an awesome job.
works great with 10.4.5 (myzar) on my p4p800se (which was a replacement for a previous MB of the same model that quit working, so it has a newer bios).

#199
helob

helob

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 218 posts

working great on my P4P800SE

I also have a P4P800SE but still have problem getting skge.kext to work on Yukon 8001. Would apprecaite if you can detail out the steps on installing skge.kext as well as finding the vendorid/devid for Yukon 8001.
Thank you for your help.

#200
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
open terminal
sudo -s (password)
cp -R (drag and drop the file and remove the / at the end) /System/Library/Extensions/
reboot

done :) enjoy
go into network pref panel and c the Network adapter





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy