Jump to content

Time isn't correct between Vista/OSX86 dual boot


  • Please log in to reply
17 replies to this topic

#1
diplomat

diplomat

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
I dual boot between Vista and Mac OS X 10.4.8 (JaS). The time is incorrect when booting back into Vista (4 hours ahead). My Vista installation is up to date (Windows Update) and I only updated iTunes on my OS X 10.4.8 installation (I didn't wanna screw up the system) so I'm pretty sure OS X is messing up the time.

How do I fix it so that the time is always correct between the systems?

TIA

P.S. - i'm in the U.S. east coast new york time zone

#2
Bruce Wang

Bruce Wang

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 366 posts
It's normal, just enable Time Synchronizing via Internet on both Vista and OS X.

Bruce

#3
WGB

WGB

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Look at this http://forum.insanel...showtopic=31198 topic and you find next


The problem with the Windows clock being off is because the hardware clock (the one on your actual motherboard) is being set to "Universal" time, or GMT, when you shut down your MacOS bootup. When you boot Windows, Windows assumes your clock is set to your local timezone because that's what Windows does by default. This explains why the people who set their MacOS clock to GMT got the right time in Windows... If the hardware clock is being set to "GMT," when it's actually the local time, Windows will pick this setting up as local time as it did before.

To fix this, you need to add a key to your Windows system registry to tell Windows that your hardware clock will always be GMT.

*** WARNING: Editing your registry improperly can render your Windows installation inoperable. Proceed VERY carefully. I am not responsible if you mess something up. ***

The short solution for people who know how to edit the registry:
A DWORD key called HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal needs to have the value of "1"

The step-by-step solution is as follows:
1. Boot Windows

2. Click Start --> Run and type regedit. Click OK

3. The Windows Registry Editor should pop up. Navigate within the explorer to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

4. Click on the TimeZoneInformation "folder" from the navigation pane if you haven't already done so.

5. This assumes the correct key doesn't exist. If it does, you will just change the existing key's value: Right click on the white space within the folder (If you don't have a right mouse button, you may need to download a program called applemouse to emulate the "control-click" of the apple 1-button mouse). Select new --> DWORD Value. Title the key "RealTimeIsUniversal" (No quotes). Set the value to "1" (No quotes again). Hexidecimal should be fine.

6. Either reboot and set the clock in MacOS or set the clock in Windows. You should now be able to reboot into either OS and have a correct clock.


Use search I'm sure I see other methods.

Regards.

#4
Danyel

Danyel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
WGB -- Thanks for the tip! It worked my home OSx86 setup, and I'll use with my others at work.

#5
gkr41

gkr41

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Greece
Another method is to set the correct time at Vista. Then boot on to OS X and you'll notice that the time will be wrong. So all you have to do, is to select a different timezone that matches the real time.

(Sorry for my bad english)

#6
macbrush

macbrush

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts

Another method is to set the correct time at Vista. Then boot on to OS X and you'll notice then that the time will be wrong. So all you have to do, is to select a different timezone that matches the real time.

(Sorry for my bad english)


But this method would surely render any software that's depending on timezone setting completely uselss, right?

#7
gkr41

gkr41

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Greece
Yeap. But it is a nice workaround, if you 're not using such programs.
Are there any drawbacks for the registry editing solution?

#8
macbrush

macbrush

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
No, there is no drawbacks in editing registry, provided you do it right, of course.

There are many programmes depend on time setting, apart from the obvious ones, for example, pagination programmes such as Quark Xpress will have problem with linked images on a network environment if timezone is incorrectly set.

#9
zarac

zarac

    The Dude abides

  • Members
  • PipPipPipPipPip
  • 314 posts
  • Gender:Male
  • Location:Zagreb, Croatia
  • Interests:film/video editing and post-production
I had the same problem, time was 2hrs different between my windows and osx.
i tried the adding the "RealTimeIsUniversal" windows registry and it worked, but only for an hour or so. Then it would go back to wrong time, and i'd have to sync it with internet timeserver.
RealTimeIsUniversal routine is very buggy and unsupported in windows.

However, I found a workaround in tips and trick section of wiki which includes editing some mac initialization and shutdown sequences.
Basically, when osx boots this command tells it to move the clock to local time (instead of universal, which is osx default). On shutdown it moves it back, so when you boot back into windows the time will be correct.

Use this little trick to change the clock between local & universal every boot. A couple lines need to be added to the initialization sequence, you'll need root privleges to do this. These files probably don't already exist on your system, so take that under advisement.
First you'll need to add a line to /etc/rc.local:

date `date -u +%m%d%H%M%Y`

Note the use of backticks to tell sh to pass the output from the enclosed command to the outer one.


And to /etc/rc.shutdown.local you'll need to add this:

date -u `date +%m%d%H%M%Y`


This changes it back again.

Be sure your clock is set correctly before your next reboot. Otherwise your clock will be messed up till you correct the time (either on macos or windows). This should keep your windows and macosx clocks in sync from now on.



#10
Danyel

Danyel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
Hi Zarac:

The registry hack for Windows does indeed work. However, I had to set the time in OS X and then check in Windows. If I try setting in Windows first, the time would keep going back to wrong time.

#11
MWhite

MWhite

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
For Windows is quite simple. Set your Time server and make command file with this set of commands:

W32tm /resync

and put this file in "Startup" folder. If you set the time server correct and you are always online, this should do the job when logging in Windows. If you are not online all the time, put command file anywhere on the desktop an run it when you go online. This should work in windows. For Mac I don't know because my OS X86 installation is only for playing around.

#12
zarac

zarac

    The Dude abides

  • Members
  • PipPipPipPipPip
  • 314 posts
  • Gender:Male
  • Location:Zagreb, Croatia
  • Interests:film/video editing and post-production
thanx for the info Danyel.
i guess i changed the clock in windows, not osx.
but since the way i decsribed works perfectly for me, i'll stick to it.
heard of some people having BSODs as a result of windows registry patch (although i seriously doubt it).

#13
Danyel

Danyel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
Hi Zarac:

Your solution on the Mac and mwhite's solution for Windows sounds like the best way to keep time synchronized on both fronts. :)

--danyel

#14
idividebyzero

idividebyzero

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 374 posts
I did the registry thing in Vista and it totally jacked up the time like Zarac said. It works for about an hour then chooses its own time that doesnt fit any time zone. And even if you changed the time zone it would change the time again. It was impossible to get it to stay normal. I totally do not recommend it on Vista.

#15
diplomat

diplomat

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
i'd rather do a equivalent registry hack for Mac OS X, since it plays stepchild to my Vista installation

i even installed a NTP server on my Ubuntu box (my Vista/Mac OS X86 box doesn't have Internet) and though it sets the correct time when initially poppin in it's addy, it doesn't automatically correct it for Mac nor Vista when they boot up (I guess it the NTP clients are on a weekly schedule or something).

i have the same issue with my MacBook when Boot Camp'n Windows XP.

this time issue blows hard.

#16
Annoid

Annoid

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
I'm a MAC noob, using Kalyway 10.5.1, on a tri-boot setup (XP, Vista, OS X) and am having this time issue as well.
Being comfortable with Unix, I tried the rc.local / rc.shutdown.local method outlined here: http://wiki.osx86pro...iversal_for_RTC

The commands do indeed do what's required if you run them at the command line, but adding the files to /etc causes the system to hang on shutdown. Apparently, there's more to it then just adding the files & expecting init to catch them. Even adding the standard shell script markers such as !#/bin/sh and so forth, setting the file to be executable didn't resolve this hanging issue.

A quick bit of research leads me to believe that you can auto-execute scripts, but I don't have time right now to figure it out. might be a week or more before I can dig into it.

Another thought.. this silly thing seems to borrow very heavily from BSD unix. How much you wanna bet you can change the zoneinfo files, or lie to the damned thing in some other way to get it to behave?

I won't have time to experiment with it for a while, but If I do figure something out, I'll post it here. For now, I just turned ntp (automatic time sync) off with the apple control panel, and told it it was in GMT.

#17
Naruto Uzumaki

Naruto Uzumaki

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
just follow what Bruce said. Just sycnhronize the time on both installs over the internet and bam your done. best of luck. ~Naruto Uzumaki~

#18
Gerardo11

Gerardo11

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I am first time visiting this nice forum, my freinds are alwasys asking me for the good recourses to read out and now I am gonna suggest them this nice one





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy