Jump to content

RME HDSP MacOSX (x86) drivers released


  • Please log in to reply
147 replies to this topic

#101
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime
http://www.rme-audio...dspe_x86_263.gz

Mac OS X Intel (10.4.8 or up) driver for HDSPe MADI, AES, RayDAT, AIO, MADIface, Multiface, Digiface, RPM. See readme.txt for important notes!

Readme.txt:

RME Intelligent Audio Solutions

Hammerfall DSPe Series

Driver for Mac OS X Intel 10.4.8 and up

Notes on driver version 2.63

1. New in Version 2.63

- Support for HDSPe Multiface, Digiface, RPM added.

Attention!
Before using the HDSPe driver for the Multiface/Digiface/RPM you have to delete the previous driver (hdsp_173_x86 or below) manually in case it is installed. Move the following files from the Finder into the trash bin:

- /System/Library/Extensions/HammerfallDSP.kext
- /Library/Audio/MIDI Drivers/Hammerfall DSP MIDI.plugin
- Programs/Hammerfall DSP Settings
- Programs/Hammerfall DSP Mixer


New in Version 2.62

- Settings program now based on Cocoa instead of Carbon
- Memory leak problems with Mac OSX 10.5 fixed.
- Bugfix Settings RayDAT: Wrong order of the PrefSyncRef buttons corrected.

New in Version 2.61

- MADIface: MIDI port did not work
- Buttons in MADIface settings dialog did not work.
- Sample rate control in slave mode with double and quad speed frequencies changed.

New in Version 2.60

- Compatibility issues of driver 2.59 with Logic fixed (worked with 2.57)

- TCO-Settings did not work with RayDAT and AIO card.

New in Version 2.59

- Support for HDSPe RayDAT, AES, AIO and MADIface

- Several bugs in TotalMix fixed

- Several new features in TotalMix due to the shared code base with the Windows version (not yet fully finished)

- Completely new routines to use the DDS dialog as efficient as possible

- In Slave mode the input sample rate is reference for CoreAudio. This changes the driver's behaviour compared to earlier versions.

- When using more than one card the driver prevents invalid states (for example different sample rates in Slave mode)


New in Version 2.57

- HDSPe MADI + TCO: MTC MIDI In port did not work.
- TCO Settings: Frequency status did not show the exact value.
- TotalMix: ‘Save all Presets as’ bug fixed
- Performance at low buffer sizes (32 samples) improved

New in Version 2.56

- HDSPe MADI Bugfix: Sample rate in master mode was about 283 ppm too low

New in Version 2.55

- Support for HDSPe MADI + TCO, 128/176.4/192 kHz sample rates added

New in Version 2.54

- Support for HDSPe MADI

An updated manual covering all the new features is available from the RME website as PDF.

2. Installation

Double-click on hdspe_x86_263.gz to expand the archive file to hdspe_x86_263.tar and the folder hdspe_263, which includes the driver file hdspe.mpkg. Installation works automatically by a double-click on the mpkg (meta package) file.

Reboot the computer when installation is done.


3. Features and Limitations

This driver operates in non-interleave mode. It works for example using iTunes, Cubase SX, Nuendo, Live 1.5.2, Peak 3.1, VSamp 3.2.7, Spark (from version 2.6), Logic 5.4 and Reason 2.5.

Via System Preferences / Audio-MIDI Setup the hardware can be configured for the system wide usage. Programs that don't support card or channel selection will use the device selected as Standard-Input and Standard-Output. (Soundstudio, Mplayer, Amplitube etc.).

In the lower part of the window, the audiohardware's capabilities are shown and can be changed in some cases. On the record side no changes are possible. Programs that don't support channel selection will always use channels 1/2, the first stereo pair.

The playback can be configured freely and to any of the available playback channels. This is done via Speaker Setup. Even multichannel playback (Surround, DVD Player) can be set up easily.


Copyright RME 08/2008. All rights reserved. Macintosh, Apple and Mac OS are trademarks or registered trademarks of Apple Corporation. RME and Hammerfall are registered trademarks of RME Germany.



#102
XLR

XLR

    2cores1cpu.mov

  • Donators
  • 859 posts
  • Location:חולון
ZOMG i bought it yesterday and got it working on 10.5.4 in a matter of minutes!
Did the firmware upgrade in Windows first, and then installed it on OSX and it works! :)

#103
arrgrr

arrgrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Do you guys know if the above driver (hdspe_x86_263.gz) works for the hdsp PCI card (not just the PCIe)? Otherwise I will be forced to shell out on a PCIe card for my good old Multiface II :(

AG

#104
kgenjuro

kgenjuro

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Thanx, had distorted sound issues, after patching, sounds cristal clear !!!

THX A LOT :(

#105
Mindripper

Mindripper

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hello, can anyone provide me the 1.71 or hdsp_173_x86 Driver for the HDSP 9652 PCI Card.

The Download at the Manufactures Site isn´t available anymore. :lol:

Thanks a lot for your help.

#106
penarol

penarol

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
Hi

I think is here:

http://www.rme-audio...hdsp_173_x86.gz

Good luck

#107
Mindripper

Mindripper

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Thank You :D Yes of course, I´ve overread it. >>> Stupid me :rolleyes:

It´s working great, now I can work like a professional in Logic 8.02 :angel:

Thank You for your help :D

#108
slyooney

slyooney

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Location:Lost in space

now I can work like a professional


I personally prefer to work like an amateur...

:(

#109
limini

limini

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 213 posts
EOL for the "old" 1.7x OS X drivers according to this post here (sixth one down). I tried the new 2.64 HDSPe one on my old MFace PCI and it was panic time. Had to reboot into safe mode (-x, FYI) to trash the new drivers before I could recover the system and install the old ones.

I don't know if our hero Oxdeadbeef is still around, but I'd be curious to know if the new drivers are hackable. It's foreseeable that PCI just won't work with newer versions of leo.

#110
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime
I was about to try the new drivers with the HDSP PCI (not the PCI-e) version. Thanks for the heads up.

#111
slyooney

slyooney

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Location:Lost in space

EOL for the "old" 1.7x OS X drivers according to this post here (sixth one down). I tried the new 2.64 HDSPe one on my old MFace PCI and it was panic time. Had to reboot into safe mode (-x, FYI) to trash the new drivers before I could recover the system and install the old ones.

I don't know if our hero Oxdeadbeef is still around, but I'd be curious to know if the new drivers are hackable. It's foreseeable that PCI just won't work with newer versions of leo.


Did you remove the old kexts and apps before installing the new ones?
If yes, that's bad... seems they are laying down PCI cards...

And by the way, does the new driver works fine with PCIe cards on a hack ?

#112
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime

Did you remove the old kexts and apps before installing the new ones?
If yes, that's bad... seems they are laying down PCI cards...

And by the way, does the new driver works fine with PCIe cards on a hack ?


My HDSPe (+ MultiFace mkII) works fine with my insanelymac. Apart from the Asus P5E in my signature It has also been tested on Gigabyte P35-DS4, EP35-DS3P and EP45-DS3L with both generations of drivers.

#113
0xdeadbeef

0xdeadbeef

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Location:Svealand

EOL for the "old" 1.7x OS X drivers according to this post here (sixth one down). I tried the new 2.64 HDSPe one on my old MFace PCI and it was panic time. Had to reboot into safe mode (-x, FYI) to trash the new drivers before I could recover the system and install the old ones.

I don't know if our hero Oxdeadbeef is still around, but I'd be curious to know if the new drivers are hackable. It's foreseeable that PCI just won't work with newer versions of leo.




Hmm I'm still around, just don't have much time to play :-)
I still think it's very unlikely that your panic was a bus issue - that is to say PCI vs PCIe, because the bus driver interface to both these busses is identical. any driver written for a PCIe slot should work for an identical card in a PCI slot. However since the RME hardware itself has changed in the new PCIe cards, it's possible that their 2.64 driver could never be made to work with the older cards.

I probably won't have time to look at this before Christmas unfortunately, but I think it might be worth considering upgrading to a PCIe card if you need the new driver. We might get some more mileage before the old driver ceases to work in Leo.
Bad news is my PCMCIA->PCI bridge card is non-functional in 10.5.2+ so I need to fix that first :-)

I hate advancing technology! :-)

#114
limini

limini

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 213 posts

Hmm I'm still around, just don't have much time to play :-)
I still think it's very unlikely that your panic was a bus issue - that is to say PCI vs PCIe, because the bus driver interface to both these busses is identical. any driver written for a PCIe slot should work for an identical card in a PCI slot. However since the RME hardware itself has changed in the new PCIe cards, it's possible that their 2.64 driver could never be made to work with the older cards.

I probably won't have time to look at this before Christmas unfortunately, but I think it might be worth considering upgrading to a PCIe card if you need the new driver. We might get some more mileage before the old driver ceases to work in Leo.
Bad news is my PCMCIA->PCI bridge card is non-functional in 10.5.2+ so I need to fix that first :-)

Hey! Glad to see you're still around, 0x! Sorry I've been buried in work and haven't had a chance to check here and follow up... Yes, according to Matthias's post it's a complete rewrite and only applicable to the "e" series. The standard PCI is being abandoned on the Mac (which was actually never officially supported on the Intels).

And while it currently works, my concern is that Apple will change things at some point that will make the current PCI drivers useless (and Logic will at some point require this newer OS revision). There's no futureproofing with the PCI card. I'm now looking for a pure ADAT only OS X solution for my iHack (piped to my main DAW); probably Firewire, but getting it working seems like such a crap shoot, even on completely legitimate systems!

I hate advancing technology! :-)

I'm sure it's more love/hate :help: What I hate is sideways-moving technology: I'm expected to spend $400 to replace a perfectly good card with another that does the exactly the same thing for me just because they've changed the bus architecture. Now THAT I hate! :help:

Thanks for keeping in touch! Later...

#115
limini

limini

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 213 posts
BTW Cebit: thanks for the HDSPe info. I think I'm going to have to look into one eventually...

#116
wlcr

wlcr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Succesfully got to work RME Hammerfall DSP Multiface (with PCMCIA card) at 10.5.7
I used PCI to PCMCIA adaptor (based on Ricoh chip) and IOPCIFamily by Slice (new 10.5.7 ver)

#117
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime

Succesfully got to work RME Hammerfall DSP Multiface (with PCMCIA card) at 10.5.7
I used PCI to PCMCIA adaptor (based on Ricoh chip) and IOPCIFamily by Slice (new 10.5.7 ver)


Well done !

Tell us about the performance in your daw of choice.

I managed to get it to work on my rusty IBM G41 Thinkpad, but the performance was horrible due to lack of GFX hardware acceleration.

RME roxx !

#118
wlcr

wlcr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I'm using Logic 8, perfomance is great - just like it should be ))) No glitches, or any other sound artifacts, all inputs working (i'm using em to get the sound from my hardware synths to Logic)...

Everything fine except I spent a week to make all this work ))))

#119
Cebit

Cebit

    Bipolar Soup

  • Members
  • PipPipPip
  • 128 posts
  • Gender:Male
  • Location:Larisa, Greece
  • Interests:*nix, Music Production, swimming, watching HD movies, Anime

I'm using Logic 8, perfomance is great - just like it should be ))) No glitches, or any other sound artifacts, all inputs working (i'm using em to get the sound from my hardware synths to Logic)...

Everything fine except I spent a week to make all this work ))))


it's only a fraction of the cost you would have to pay to own a Mac Pro. Plus, you gained experience about the inner workings of the Software/Hardware combination.

Well Done ^ 2 :D

What do you do ?

Are there samples of your music on-line ?

PS. Please consider adding the specs of your system in your signature.

#120
CAPTCHA

CAPTCHA

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
thousand thanks to 0xdeadbeef
my multiface 1 with cardbus works now without distortion :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy