Jump to content

TabletMagic for TabletPCs


  • Please log in to reply
520 replies to this topic

#521
Soup Rice

Soup Rice

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi everyone, im trying to get my Wacom Digitizer built-in on my Thinkpad X60 Tablet (hardware is just pen enable, not touch)

i have OSX Snow Leopard 10.6.8 on it and Tabletmagic is 2.0b20 and it already has the correct string on Apple16x50Serial.kext 

 

Apple16X50Serial.kext's info.plist has the following content:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CFBundleDevelopmentRegion</key>
	<string>English</string>
	<key>CFBundleExecutable</key>
	<string>Apple16X50Serial</string>
	<key>CFBundleIdentifier</key>
	<string>com.apple.driver.Apple16X50Serial</string>
	<key>CFBundleInfoDictionaryVersion</key>
	<string>6.0</string>
	<key>CFBundleName</key>
	<string>Apple16X50Serial</string>
	<key>CFBundlePackageType</key>
	<string>KEXT</string>
	<key>CFBundleShortVersionString</key>
	<string>3.0</string>
	<key>CFBundleSignature</key>
	<string>????</string>
	<key>CFBundleVersion</key>
	<string>3.0</string>
	<key>IOKitPersonalities</key>
	<dict>
		<key>PCI 16X50 Serial Port</key>
		<dict>
			<key>CFBundleIdentifier</key>
			<string>com.apple.driver.Apple16X50Serial</string>
			<key>IOClass</key>
			<string>com_apple_driver_16X50PCI</string>
			<key>IOKitDebug</key>
			<integer>0</integer>
			<key>IONameMatch</key>
			<string>WACF004</string>
			<key>IOPCIClassMatch</key>
			<string>WACF004</string>
			<key>IOProbeScore</key>
			<integer>20000</integer>
			<key>IOProviderClass</key>
			<string>IOPCIPlatformDevice</string>
		</dict>
	</dict>
	<key>OSBundleCompatibleVersion</key>
	<string>1.9</string>
	<key>OSBundleLibraries</key>
	<dict>
		<key>com.apple.iokit.IOPCIFamily</key>
		<string>2.5</string>
		<key>com.apple.iokit.IOSerialFamily</key>
		<string>10.0.2</string>
		<key>com.apple.kpi.iokit</key>
		<string>10.0.0d4</string>
		<key>com.apple.kpi.libkern</key>
		<string>10.0.0d4</string>
		<key>com.apple.kpi.mach</key>
		<string>10.0.0d4</string>
	</dict>
</dict>
</plist>

but detection seems to be flaky, sometimes Tabletmagic detects Serial0 port and the digitizer can be used just fine but on the next boot the serial0 port is gone, and it goes on and on.

(tabletenabler.kext seems to be for the X61 Tablet only, as the result is the same either with the kext or without it)

a hardware failure is ruled out as both windows and linux detect the digitizer correctly on boot and its fully functional on both systems. 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy