Jump to content

The Complete Dell XPS m1210 Installation + Dual Boot Tutorial

- - - - -

  • Please log in to reply
571 replies to this topic

#41
kj24lax

kj24lax

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
After I ran through this guide I have everything working as it said it would (still searching for a webcam solution and not giving up on the wireless card yet). However, when I ran mac update I couldn't boot into OS X (currently triple booting my PC with XP and Fedora as well). I would select Mac OS X but it kept just rebooting. Any ideas on why this is happening or what I can do to fix this (I am scared to do it again...I INSTALLED THIS ABOUT 50 TIMES!!!!)?

#42
seaDonkey

seaDonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Reno, NV

Everytime I reboot, my screen rotates 90 degrees clockwise, I'm glad I can laugh at myself about this, but as a little reminder to others who might be thinking this... don't do it, heh



Try to navigate to system preferences, displays and select "detect displays."

If this doesn't work AND if , you can run the natit uninstall script by entering single user mode (restart, hit f8 before the apple screen, select osx and type -s) and entering the following:

mount -uw /
 rm -fr /System/Library/Extensions/Natit.kext
 rm /System/Library/Extensions.kextcache /System/Library/Extensions.mkext
 reboot

After I ran through this guide I have everything working as it said it would (still searching for a webcam solution and not giving up on the wireless card yet). However, when I ran mac update I couldn't boot into OS X (currently triple booting my PC with XP and Fedora as well). I would select Mac OS X but it kept just rebooting. Any ideas on why this is happening or what I can do to fix this (I am scared to do it again...I INSTALLED THIS ABOUT 50 TIMES!!!!)?


Sorry to hear that your installation is broken. I've always struggled with which updates to get. I've successfully installed the daylight savings update, however, I've read that the java update messed with safari. Also, I've seen patchers that allow you to update with the security updates, but without the patcher, you will damage your install. I've also been holding off on the airport update. I'll look into this and post my findings.

This link should help: http://forum.insanel...o...&hl=patcher

Please let us know if you learn anything.

#43
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I tried both of those Seadonkey, no suck luck... I've already reinstalled, heh.
You're super fast with the replies btw. Speakers are still a no go, but I'm just waiting for the older mifki version to finish downloading. I still have the first headphone jack, so I'll live.

thanks again

#44
dublued

dublued

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
so i guess the only thing left is the card reader and the webcam huh?

wow if those can be worked out, the xps m1210 will be a great off the shelf pc for osx

alfdog, do you want the mifki kernel file? it's only a few megs

#45
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Back again =)

Dublued, I'll let you know soon if I need that file. I think I actually already downloaded it off of his site, 1.7megs I think. I'm at work atm, and I'll have to check on that later.

Unfortunately, I'm a total beginner when it comes to OSx86. Can someone help me understand the "concept" of the "mifki kernel"? I've only been at this for literally a day and a half, I've scoured google/wikipedia trying to learn as much as I can. This is what I understand so far... mifki's kernal is more "original" i.e. less 3rd party, while semtex's is more "compatible" with some of the other pc hardware.

Now, what I have so far are two different JAS iso's.
The SSE2+3 beta2 non patched (what I have currently installed)
and SSE2+3 Patched (just finished downloading last night)

I also have the earlier? SSE3 INTEL ONLY iso downloading, but it's going very slow. Is that the mifki kernal?

Correct me if I'm wrong, but it's my understanding the SSE2+3 iso's already have the "mifki kernal" integrated?

Or do I need to manually add/install/merge the mifki kernal? pre(slipstream) or post install?

If someone can point me in the right direction that would be great, as I'm sure that's the solution to my speaker problem.

---------------------------------------------------------------------------------------------------------------------------

My experience has been great, I never thought I'd enjoy tinkering with OSX so much.

What I've learned so far is:

Always use the left headphone jack, don't mess around with switching jacks, it caused an error with a mp3 file I was playing in iTunes.

Turn off any instances of "sleep" in the power management settings. Also, I think the screensaver or "monitor off" is causing a lock up.

The front volume keys work, but the play, pause, forward, ect. don't. This is very minor issue.

I've installed the Java update, Itunes update, and another one I can't think of, with no problems so far. I didn't install the airport update (didn't think it was necessary) and I'm still waiting on my 1390. I didn't install the 10.4.9 update for intel, as I'm pretty sure this will cause some problems.

Webcam and mic, I don't really use, so no biggie.

SD card reader I can live without. I do have a 2gb SD card I used for my treo 650, but now it's being used mainly for Vista's Readyboost. I just recently got a Patriot 4gb usb stick, and I have to say, that thing has made my OSx86 installs 10 times easier.

The only thing I really wish I could fix is the the sleep issue. If I find anything useful, I'll let you guys know.

Has anyone tried installing the 10.4.9 update? That would be a great idea for a part 2 of this guide, hint hint :rolleyes:

Thanks again, I'm finding this forum/guide to be more fun than the ubuntu forums.

alf

#46
dublued

dublued

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
yea don't bother with the 10.4.9 update

you'll get stuck in a restart loop.

i wanted to format and increase my partiition size anyway so gave that update a try.

before the 10.4.9 update, i had installed all the other updates with not a single problem.

20 gigs is not enough once you start having fun with osx :P

#47
seaDonkey

seaDonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Reno, NV
If it helps, the version that I wrote the guide with has the following md5: A1960475511FFB5ECC7447AC7D71D44C

JaS.10.4.8.SSE3.Intel.Only.iso

It gives you the choice of either kernel via combo updates.

#48
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Thanks Seadonkey, trying to get the right one...

"Jas 10.4.8 Amd Intel Sse2 Sse3" was the one I was using. It has built in natit which is nice, but I can't for the life of me get the speakers working... I even did my own codec dump in linux, to use with the HDA patcher.

#49
dublued

dublued

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
i used the same dvd as you alfdog.

then just booted with the mifki kernel to make the speakers work

saved the hassle of downloading another entire dvd

#50
enishicz

enishicz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Anyone had any luck with the new 10.4.9 update with any of the available methods yet? If so is the built-in webcam working??

#51
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I sent you a pm dublued

#52
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I got my speakers working now thanks to dublued

got mifki kernal, chose at boot with F8, used hda patcher from this guide, and poof I have speakers

has anyone ran the airport update?

#53
kj24lax

kj24lax

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Try to navigate to system preferences, displays and select "detect displays."

If this doesn't work AND if , you can run the natit uninstall script by entering single user mode (restart, hit f8 before the apple screen, select osx and type -s) and entering the following:

mount -uw /
  rm -fr /System/Library/Extensions/Natit.kext
  rm /System/Library/Extensions.kextcache /System/Library/Extensions.mkext
  reboot



Sorry to hear that your installation is broken. I've always struggled with which updates to get. I've successfully installed the daylight savings update, however, I've read that the java update messed with safari. Also, I've seen patchers that allow you to update with the security updates, but without the patcher, you will damage your install. I've also been holding off on the airport update. I'll look into this and post my findings.

This link should help: http://forum.insanel...o...&hl=patcher

Please let us know if you learn anything.



My install is working great now. This guide was extremely helpful. I will definetely check this link out and let you know. Thanks for the assistance.

#54
sipkristal

sipkristal

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I can't get natit working with my xps m1210 =( I've done everything but my display keeps getting set to 800x1280 in OSX. Is there anything I can do?

#55
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
what iso are you using?

#56
seaDonkey

seaDonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Reno, NV

I can't get natit working with my xps m1210 =( I've done everything but my display keeps getting set to 800x1280 in OSX. Is there anything I can do?


I'm assuming that you have the geforce 7400 and not the integrated intel card. If not, don't install natit.

Have you tried the manual natit/titan installation method (as opposed to using the universal installer)? Also, the newer JAS image has the natit installer integrated. If you install that ISO it should work, but I believe you'll have to change the kernel to from semthex's to mifki's make sound work.

#57
sipkristal

sipkristal

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
i'm using the JaS.10.4.8.SSE3.Intel.Only iso. but yea, i'm using the geforce7400 card. can you point me to a tutorial regarding the manual natit/titan installation method. what is the newest JAS image so maybe I could just install the integrated natit installer easier. thank you so much I can't believe how fast a response I got!

#58
seaDonkey

seaDonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Reno, NV

i'm using the JaS.10.4.8.SSE3.Intel.Only iso. but yea, i'm using the geforce7400 card. can you point me to a tutorial regarding the manual natit/titan installation method. what is the newest JAS image so maybe I could just install the integrated natit installer easier. thank you so much I can't believe how fast a response I got!


Ok... to manually install natit (dual monitor support)

Download natit from here (try v0.02 first, if that doesn't work you'll have to try the v0.01)

and follow the instructions here.

Both threads should be very helpful. Please note that I personally used the universal installer and haven't yet tried the manual method, however many have sucessfully done this with the m1210.

#59
guitardood

guitardood

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
I was going to order the dell with the geforce 7400.

Im guessing some people do have it 100% working with osx86 becides the topic OP?

:(

#60
alfdog

alfdog

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Order it with a 1390 wireless card, or get one off of ebay, alot of us have it working just fine except for webcam and sd card reader. Technically the 3945 intel wireless is a "better" card, but the 1390 is compatible "out of the box" with osx.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy