Jump to content

[How to] Boot your real Windows partition with Parallels on Hackintosh


  • Please log in to reply
249 replies to this topic

#241
Rw.

Rw.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
OMFG i finally found the solution to run parallels ons my ''AMD mac'' but I CAN'T CHANGE THE INFO.PLIST FILE!!!! it keeps getting a error sound when I try to save it


PLZ HELP ME :unsure:

#242
falsify

falsify

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

With parallels upgrade (4.0) the configuration file as changed to an xml file... anyone knows how to do it now?


I'm also trying to get it to work with 4.0.

The "Boot Camp Partition" is not selectable when I try and create the parallels virtual machine. The .pvs file is a more complicated XML file like you mentioned, and I'm not exactly sure how to go about editing it to tell it boot off the physical drive where I have XP installed.

I think I could probably figure it out, if someone who has XP installed on physical drive and is able to use it through Parallel's Boot Camp option could send the HDD portion of their config.pvs

#243
scg2009

scg2009

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Boot OSX from ext USB HDD >
Boots into Leopard ok >

Run Parallels as described in post #1 >
Boots ok >
Loads drivers up till agpCPQ.dll >
then fails and says Fatal Error in virtual machine monitor

any ideas?

Posted Image

#244
NSCXP2005

NSCXP2005

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 610 posts
  • Location:Manchester UK
Does anybody know if parallels work on the NC10? I have heard it works on the MSI Wind & Advent 4211.

Please can smebody help me get this to work.

Would I need a specific version?

All the best

NSCXP2005

#245
errandwolfe

errandwolfe

    Usurper of Wilson, King of Prussia

  • Donators
  • 1,429 posts
  • Gender:Male
  • Location:Miami Beach, FL

I'm also trying to get it to work with 4.0.

The "Boot Camp Partition" is not selectable when I try and create the parallels virtual machine. The .pvs file is a more complicated XML file like you mentioned, and I'm not exactly sure how to go about editing it to tell it boot off the physical drive where I have XP installed.

I think I could probably figure it out, if someone who has XP installed on physical drive and is able to use it through Parallel's Boot Camp option could send the HDD portion of their config.pvs


Has there been any progress? I so would love to use a physical install with Parallels 4.

#246
Joel G.

Joel G.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Has there been any progress? I so would love to use a physical install with Parallels 4.


Yes, I'm very interested also. Especially because I'm using apple's wireless bluetooth keyboard and it doesn't work in the bios, so I can't boot into windows without plugging in a usb keybaord. :lol:

#247
fb*

fb*

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Here's the config.pvs from my bootcamp VM on my Macbook running the trial version of Parallels 5 - I have yet to experiment with getting it running on my hackintosh.


[codebox]<?xml version="1.0" encoding="UTF-8"?>
<ParallelsVirtualMachine schemaVersion="1.0" >
<AppVersion>5.0.9308.543312</AppVersion>
<ValidRc>0</ValidRc>
<Identification>
<VmUuid>{e6c49046-e6f6-4444-bbcf-46efd23f6e23}</VmUuid>
<SourceVmUuid>{e6c49046-e6f6-4444-bbcf-46efd23f6e23}</SourceVmUuid>
<VmName>Windows 7</VmName>
<ServerUuid>{a04bbb02-25e5-4e56-b27f-78dab50b73e4}</ServerUuid>
<LastServerUuid></LastServerUuid>
<ServerHost></ServerHost>
<VmFilesLocation>1</VmFilesLocation>
</Identification>
<Security>
<AccessControlList/>
<LockedOperationsList/>
<Owner></Owner>
<IsOwner>0</IsOwner>
<AccessForOthers>0</AccessForOthers>
<LockedSign>0</LockedSign>
</Security>
<Settings>
<General>
<OsType>8</OsType>
<OsNumber>2059</OsNumber>
<IsTemplate>0</IsTemplate>
<CustomProperty></CustomProperty>
<SwapDir></SwapDir>
<VmColor>0</VmColor>
</General>
<Startup>
<AutoStart>0</AutoStart>
<AutoStartDelay>0</AutoStartDelay>
<VmStartLoginMode>0</VmStartLoginMode>
<VmStartAsUser></VmStartAsUser>
<VmStartAsPassword></VmStartAsPassword>
<WindowMode>0</WindowMode>
<LockInFullScreenMode>0</LockInFullScreenMode>
<StartInDetachedWindow>0</StartInDetachedWindow>
<BootingOrder>
<BootDevice>
<Index>0</Index>
<Type>6</Type>
<BootingNumber>0</BootingNumber>
<InUse>1</InUse>
</BootDevice>
<BootDevice>
<Index>0</Index>
<Type>5</Type>
<BootingNumber>1</BootingNumber>
<InUse>1</InUse>
</BootDevice>
<BootDevice>
<Index>0</Index>
<Type>3</Type>
<BootingNumber>2</BootingNumber>
<InUse>1</InUse>
</BootDevice>
<BootDevice>
<Index>0</Index>
<Type>8</Type>
<BootingNumber>3</BootingNumber>
<InUse>1</InUse>
</BootDevice>
</BootingOrder>
<AllowSelectBootDevice>0</AllowSelectBootDevice>
</Startup>
<Shutdown>
<AutoStop>1</AutoStop>
<OnVmWindowClose>2</OnVmWindowClose>
<WindowOnShutdown>0</WindowOnShutdown>
</Shutdown>
<Runtime>
<ForegroundPriority>1</ForegroundPriority>
<BackgroundPriority>1</BackgroundPriority>
<IoPriority>4</IoPriority>
<DiskCachePolicy>1</DiskCachePolicy>
<CloseAppOnShutdown>0</CloseAppOnShutdown>
<ActionOnStop>0</ActionOnStop>
<DockIcon>0</DockIcon>
<OsResolutionInFullScreen>0</OsResolutionInFullScreen>
<FullScreen CornerAction_patch="1" >
<UseAllDisplays>0</UseAllDisplays>
<CornerAction>1</CornerAction>
<CornerAction>0</CornerAction>
<CornerAction>0</CornerAction>
<CornerAction>0</CornerAction>
</FullScreen>
<UndoDisks>0</UndoDisks>
<SafeMode>0</SafeMode>
<SystemFlags></SystemFlags>
<DisableAPIC>0</DisableAPIC>
<OptimizePowerConsumptionMode>0</OptimizePowerConsumptionMode>
<ShowBatteryStatus>1</ShowBatteryStatus>
<Enabled>0</Enabled>
<EnableAdaptiveHypervisor>1</EnableAdaptiveHypervisor>
<UseSMBiosData>0</UseSMBiosData>
<DisableSpeaker>0</DisableSpeaker>
<HideBiosOnStartEnabled>0</HideBiosOnStartEnabled>
<UseDefaultAnswers>0</UseDefaultAnswers>
<CompactHddMask>0</CompactHddMask>
<CompactMode>0</CompactMode>
<DisableWin7Logo>1</DisableWin7Logo>
<OptimizeModifiers>0</OptimizeModifiers>
</Runtime>
<Schedule>
<SchedBasis>0</SchedBasis>
<SchedGranularity>0</SchedGranularity>
<SchedDayOfWeek>0</SchedDayOfWeek>
<SchedDayOfMonth>0</SchedDayOfMonth>
<SchedDay>0</SchedDay>
<SchedWeek>0</SchedWeek>
<SchedMonth>0</SchedMonth>
<SchedStartDate>1752-01-01</SchedStartDate>
<SchedStartTime></SchedStartTime>
<SchedStopDate>1752-01-01</SchedStopDate>
<SchedStopTime></SchedStopTime>
</Schedule>
<RemoteDisplay>
<Mode>0</Mode>
<Password></Password>
<HostName>0.0.0.0</HostName>
<PortNumber>5900</PortNumber>
</RemoteDisplay>
<Tools>
<IsolatedVm>0</IsolatedVm>
<Coherence>
<ShowTaskBar>1</ShowTaskBar>
<ShowTaskBarInCoherence>0</ShowTaskBarInCoherence>
<RelocateTaskBar>0</RelocateTaskBar>
<ExcludeDock>1</ExcludeDock>
<MultiDisplay>1</MultiDisplay>
<GroupAllWindows>0</GroupAllWindows>
<DisableDropShadow>0</DisableDropShadow>
<DoNotMinimizeToDock>0</DoNotMinimizeToDock>
<BringToFront>0</BringToFront>
<AppInDock>0</AppInDock>
<ShowWinSystrayInMacMenu>1</ShowWinSystrayInMacMenu>
<UseBorders>1</UseBorders>
<UseSeamlessMode>0</UseSeamlessMode>
<PauseIdleVM>0</PauseIdleVM>
<DisableAero>0</DisableAero>
</Coherence>
<SharedFolders>
<HostSharing>
<Enabled>0</Enabled>
<ShareAllMacDisks>0</ShareAllMacDisks>
<ShareUserHomeDir>0</ShareUserHomeDir>
<MapSharedFoldersOnLetters>1</MapSharedFoldersOnLetters>
<UserDefinedFoldersEnabled>1</UserDefinedFoldersEnabled>
<SetExecBitForFiles>0</SetExecBitForFiles>
<VirtualLinks>1</VirtualLinks>
</HostSharing>
<GuestSharing>
<Enabled>1</Enabled>
<AutoMount>1</AutoMount>
<EnableSpotlight>0</EnableSpotlight>
</GuestSharing>
</SharedFolders>
<SharedProfile>
<Enabled>0</Enabled>
<UseDesktop>1</UseDesktop>
<UseDocuments>1</UseDocuments>
<UsePictures>1</UsePictures>
<UseMusic>1</UseMusic>
<UseMovies>1</UseMovies>
<UseDownloads>1</UseDownloads>
</SharedProfile>
<SharedApplications>
<FromWinToMac>1</FromWinToMac>
<FromMacToWin>0</FromMacToWin>
<SmartSelect>0</SmartSelect>
<AppInDock>2</AppInDock>
<ShowWindowsAppInDock>0</ShowWindowsAppInDock>
<WebApplications>
<WebBrowser>0</WebBrowser>
<EmailClient>0</EmailClient>
<FtpClient>0</FtpClient>
<Newsgroups>0</Newsgroups>
<Rss>0</Rss>
<RemoteAccess>0</RemoteAccess>
</WebApplications>
</SharedApplications>
<AutoUpdate>
<Enabled>1</Enabled>
</AutoUpdate>
<ClipboardSync>
<Enabled>1</Enabled>
</ClipboardSync>
<DragAndDrop Enabled_patch="1" >
<Enabled>1</Enabled>
</DragAndDrop>
<MouseSync>
<Enabled>1</Enabled>
</MouseSync>
<MouseVtdSync>
<Enabled>1</Enabled>
</MouseVtdSync>
<SmartMouse>
<Enabled>1</Enabled>
</SmartMouse>
<TimeSync>
<Enabled>1</Enabled>
<SyncInterval>60</SyncInterval>
<KeepTimeDiff>0</KeepTimeDiff>
</TimeSync>
<TisDatabase>
<Data></Data>
</TisDatabase>
<Modality>
<Opacity>0.8</Opacity>
<StayOnTop>1</StayOnTop>
<CaptureMouseClicks>1</CaptureMouseClicks>
</Modality>
<SharedVolumes>
<Enabled>1</Enabled>
<UseExternalDisks>1</UseExternalDisks>
<UseDVDs>1</UseDVDs>
<UseConnectedServers>1</UseConnectedServers>
</SharedVolumes>
<Gestures>
<Enabled>1</Enabled>
</Gestures>
<RemoteControl>
<Enabled>1</Enabled>
</RemoteControl>
<NativeLook>
<Enabled>0</Enabled>
</NativeLook>
</Tools>
<Autoprotect>
<Enabled>0</Enabled>
<Period>7200</Period>
<TotalSnapshots>10</TotalSnapshots>
<NotifyBeforeCreation>1</NotifyBeforeCreation>
</Autoprotect>
<AutoCompress>
<Enabled>1</Enabled>
<Period>86400</Period>
<FreeDiskSpaceRatio>50</FreeDiskSpaceRatio>
</AutoCompress>
<GlobalNetwork>
<HostName></HostName>
<DefaultGateway></DefaultGateway>
<OfflineManagementEnabled>0</OfflineManagementEnabled>
</GlobalNetwork>
</Settings>
<Hardware>
<Cpu>
<Number>1</Number>
<Mode>0</Mode>
<AccelerationLevel>2</AccelerationLevel>
<EnableVTxSupport>1</EnableVTxSupport>
<CpuUnits>0</CpuUnits>
<CpuLimit>0</CpuLimit>
</Cpu>
<Chipset>
<Type>1</Type>
</Chipset>
<Clock>
<TimeShift>3600</TimeShift>
</Clock>
<Memory>
<RAM>1024</RAM>
</Memory>
<Video>
<Enabled>1</Enabled>
<VideoMemorySize>128</VideoMemorySize>
<EnableDirectXShaders>1</EnableDirectXShaders>
<ScreenResolutions>
<Enabled>0</Enabled>
</ScreenResolutions>
<Enable3DAcceleration>1</Enable3DAcceleration>
<EnableVSync>1</EnableVSync>
<MaxDisplays>0</MaxDisplays>
</Video>
<Fdd>
<Index>0</Index>
<Enabled>1</Enabled>
<Connected>0</Connected>
<EmulatedType>1</EmulatedType>
<SystemName>floppy.fdd</SystemName>
<UserFriendlyName>floppy.fdd</UserFriendlyName>
<Remote>0</Remote>
<DeviceDescription></DeviceDescription>
</Fdd>
<CdRom>
<Index>0</Index>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>0</EmulatedType>
<SystemName>IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@B/AppleMCP79AHCI/PRT1@1/IOAHCIDevice@0/IOAHCISerialATAPI/IOSCSIPeripheralDeviceNub/IOSCSIPeripheralDeviceType05/IODVDServices</SystemName>
<UserFriendlyName>Default CD/DVD-ROM</UserFriendlyName>
<Remote>0</Remote>
<InterfaceType>0</InterfaceType>
<StackIndex>1</StackIndex>
<Passthrough>1</Passthrough>
<DeviceDescription></DeviceDescription>
</CdRom>
<Hdd>
<Index>0</Index>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>3</EmulatedType>
<SystemName>ST9500325AS (disk0).hdd</SystemName>
<UserFriendlyName>ST9500325AS (disk0)</UserFriendlyName>
<Remote>0</Remote>
<InterfaceType>0</InterfaceType>
<StackIndex>0</StackIndex>
<DiskType>1</DiskType>
<Size>1891655680</Size>
<SizeOnDisk>0</SizeOnDisk>
<Passthrough>0</Passthrough>
<Splitted>0</Splitted>
<DiskVersion>2</DiskVersion>
<Partition>
<SystemName>/dev/disk0s3</SystemName>
</Partition>
<DeviceDescription></DeviceDescription>
</Hdd>
<Parallel>
<Index>0</Index>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>3</EmulatedType>
<SystemName>Default printer</SystemName>
<UserFriendlyName>Default printer</UserFriendlyName>
<Remote>0</Remote>
<DeviceDescription></DeviceDescription>
</Parallel>
<NetworkAdapter>
<Index>0</Index>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>1</EmulatedType>
<SystemName></SystemName>
<UserFriendlyName></UserFriendlyName>
<Remote>0</Remote>
<AdapterNumber>-1</AdapterNumber>
<AdapterName>Default Adapter</AdapterName>
<MAC>001C42990D14</MAC>
<Router>0</Router>
<DHCPUseHostMac>0</DHCPUseHostMac>
<ForceHostMacAddress>0</ForceHostMacAddress>
<VirtualNetworkID></VirtualNetworkID>
<StaticAddress>0</StaticAddress>
<PktFilter>
<PreventPromisc>1</PreventPromisc>
<PreventMacSpoof>1</PreventMacSpoof>
<PreventIpSpoof>1</PreventIpSpoof>
</PktFilter>
<AutoApply>0</AutoApply>
<ConfigureWithDhcp>0</ConfigureWithDhcp>
<DefaultGateway></DefaultGateway>
<DeviceDescription></DeviceDescription>
</NetworkAdapter>
<Sound>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>0</EmulatedType>
<SystemName>Default</SystemName>
<UserFriendlyName></UserFriendlyName>
<Remote>0</Remote>
<Output>Default</Output>
<Mixer>Default</Mixer>
<DeviceDescription></DeviceDescription>
</Sound>
<USB>
<Enabled>1</Enabled>
<Connected>1</Connected>
<EmulatedType>0</EmulatedType>
<SystemName></SystemName>
<UserFriendlyName></UserFriendlyName>
<Remote>0</Remote>
<AutoConnect>0</AutoConnect>
<ConnectReason>0</ConnectReason>
<DeviceDescription></DeviceDescription>
<CACSupportEnabled>0</CACSupportEnabled>
</USB>
</Hardware>
<InstalledSoftware>0</InstalledSoftware>
</ParallelsVirtualMachine>
[/codebox]

#248
Kobukson

Kobukson

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
If anyone has gotten Parallels 5 to work with their physical Windows install on a Hackintosh, please enlighten us ^^ Trying to mess with it myself right now and it seems to be picking the correct partition in the config file, but during the setup when I try to start the VM, it ends up erroring.

#249
uuufo

uuufo

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
same here boot0 error, i had the same in vmware and just had it boot the 7 disc and run a startup repair,,, but parallels goes through a "first time" setup each time you try to run it and it won't boot off the cd... any ideas? Thanks!

#250
ChiguiroChiflado

ChiguiroChiflado

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
Hi there I know this an old Thread but I am trying this and cant make it work properly.
I have been using my hackintosh booting with chameleon either my win7 or snow leopard partition.
I installed parallels 6 on osx and before i knew it it was already running my windows 7 on a window. it gave me a few errors having to do with the MOBOs OCing tools but after closing them it was all good. I installed parallels tools and rebooted with no problem except those mentioned errors. then i was able to use my windows to encode some video while using my mac on other things SWEET!!!

BUT... later i tried to boot my windows via chameleon and got blue screen. I rebooted it and finally worked after an hour of 'windows is trying to solve the problem' windows then was fine.

I decided I would give it another try with parallels from my osx an now i am unable to boot it says there was a fatal error. what to do?

thanks in advance ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy