Jump to content

[How To]Atheros AR5212 based cards, now w/ Leopard


  • Please log in to reply
383 replies to this topic

#381
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 370 posts
  • Gender:Male
  • Location:France

Does this work with Snow???? I'm trying to get mine on it. I already tried the Tiger kext, it recognized the card, but in a offline status, and when you try to switch it on (activate) just happens nothing.



YES !!!!!!!!!!!! for my card : Netgear WPN311 (firmware2.0)

Look My screen grab under 10.6.4 64k

/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros21.kext

Thanks to this AtherosFix.kext this card is working in 32 and 64k
Put AtherosFix.kext in /Extra !

Attached File  OSX_10.6.4_WPN_311.png   29.18KB   192 downloads
Attached File  AtherosFix.kext.zip   4.17KB   204 downloads


Good luck

#382
aculine

aculine

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

YES !!!!!!!!!!!! for my card : Netgear WPN311 (firmware2.0)

Look My screen grab under 10.6.4 64k

/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros21.kext

Thanks to this AtherosFix.kext this card is working in 32 and 64k
Put AtherosFix.kext in /Extra !

Attached File  OSX_10.6.4_WPN_311.png   29.18KB   192 downloads
Attached File  AtherosFix.kext.zip   4.17KB   204 downloads


Good luck


I've tried your kext, but WPA still not work on Leopard 10.5.7 iAtkos v7....

#383
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 370 posts
  • Gender:Male
  • Location:France

I've tried your kext, but WPA still not work on Leopard 10.5.7 iAtkos v7....


Did you look at this ?
http://www.insanelym...t33089-300.html

Obviously some users had to restart 2 times before it was working!


Be shure you have updated kernel cache !

There where some persons who succeded with ralink drivers !
http://www.ralinktec...support.php?s=3

an other method is to edit the infoplist inside /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros21.kext with your card code
(check your kext ! beacause mine is like that !)


I found that your card has a AR2413 chip !
pci.vendor_id : 5772 (0x168c)


http://www.insanelym...amp;pid=1179622

And there could be even a solution with the Airport extreme upgrade from apple !

Let me know if you succeeded !

^_^

#384
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 370 posts
  • Gender:Male
  • Location:France

Did you look at this ?
http://www.insanelym...t33089-300.html

Obviously some users had to restart 2 times before it was working!


Be shure you have updated kernel cache !

There where some persons who succeded with ralink drivers !
http://www.ralinktec...support.php?s=3

an other method is to edit the infoplist inside /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros21.kext with your card code
(check your kext ! beacause mine is like that !)


I found that your card has a AR2413 chip !
pci.vendor_id : 5772 (0x168c)


http://www.insanelym...amp;pid=1179622

And there could be even a solution with the Airport extreme upgrade from apple !

Let me know if you succeeded !

:censored2:


There a others who have succeeded with this chip !!

http://www.insanelym...00#entry1523183

:wacko:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy