Jump to content

LaptopDisplay


  • Please log in to reply
428 replies to this topic

#361
kae

kae

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Has anyone successfully connected an external vga display to their go7600 card ? Its detected when booting, but dissapears right before login screen. I read someone else had the same problem, any solution to this ?

#362
NET

NET

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
  • Location:Underworld
  • Interests:are not interesting for others :)
Ok guys, The Question Is:

HOW PEOPLE WITH GMA900 (i915) can start their laptops without external display?

i have started HP PAvilon 4000 on my friends lappy on build in LCD but next time it started with bluescreen :/

i have got Macbook Pro C2D for my own use :) but his lappy has got a problem.

right now i cant find solution here. so maby we will do some HOWTO ?
short one, from beggening to last fix in kexts for dummy people like me ^_^

#363
MacSimilian

MacSimilian

    V1ll4g3 1d107

  • Members
  • PipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Location:Germany
anyone with a geforce 8600 M GT? and when will it be supported? is it hard to support this card? thx

#364
GremliN

GremliN

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
The card is so new, they haven't just looked at it yet as almost nobody has it yet... Maybe it works, maybe not. If you have it, help the people here to support it by giving information they need.

#365
Azurael

Azurael

    How many Ace Rimmers does it take to change a lightbulb?

  • Members
  • PipPipPipPipPipPipPip
  • 776 posts
  • Gender:Male
No... When will people actually read through the forum before posting here? Aren't there enough threads and posts on this forums asking if G8x cards will work? It won't work 'till Apple use a G8x-based card themselves, and even then there may be issues getting a new-build Apple kext to work with non-EFI cards.

Sorry to rant, but the signal to noise ratio on this forum is getting silly.

#366
MacSimilian

MacSimilian

    V1ll4g3 1d107

  • Members
  • PipPipPipPipPip
  • 310 posts
  • Gender:Male
  • Location:Germany

If you have it, help the people here to support it by giving information they need.

i dont have it now, but i will probably get it in the beginning of june. and then i will report back, with infos and everything needed.

It won't work 'till Apple use a G8x-based card themselves

i have seen on a newssite that the new imac will have a 8xxx card. this would be great...

if not i can at least use it in VESA 3 mode with just 16mb vram. thats better than no OSX at all.

#367
arikstress

arikstress

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:indonesia
Monitor
Windows description......... Generic PnP Monitor
Manufacturer................ LPL

Plug and Play ID............ LPL0000
Serial number............... n/a
EDID data source............ Registry (stored)

Manufacture date............ 2005
EDID revision............... 1.2
Display type and signal..... Digital
Sync input support.......... n/a
Screen size................. 330 x 210 mm (~16")
Power management............ n/a

Color characteristics
Display gamma............... 2.20
Red chromaticity............ Rx 0.590 - Ry 0.344
Green chromaticity.......... Gx 0.323 - Gy 0.534
Blue chromaticity........... Bx 0.156 - By 0.138
White point (default)....... Wx 0.313 - Wy 0.328

Timing characteristics
VESA GTF support............ Not supported
Horizontal scan range....... n/a
Vertical scan range......... n/a
Video bandwidth............. n/a
Extension blocks............ n/a
Timing recommendation #1.... 1280x800 at 60Hz
Modeline................ "1280x800" 71.250 1280 1328 1360 1440 800 802 808 823 -hsync -vsync

Standard timings supported
n/a

Raw EDID base
00: 00 FF FF FF FF FF FF 00 32 0C 00 00 00 00 00 00
10: 00 0F 01 02 80 21 15 78 0A 0F 10 97 58 52 88 28
20: 23 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
30: 01 01 01 01 01 01 D5 1B 00 A0 50 20 17 30 30 20
40: 26 00 21 15 10 00 00 19 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 FE 00 4C
60: 47 50 68 69 6C 69 70 73 4C 43 44 0A 00 00 00 FE
70: 00 4C 50 31 35 34 57 30 31 2D 54 4C 41 32 00 08

Display adapter
Adapter description......... ATI Mobility Radeon X1300
Adapter device ID........... 0x71491002
Display settings............ 1280x800, 32bpp


type of laptop is on my sig

#368
SathanaS

SathanaS

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I'm sorry, but can someone help me with DisplayUtility?
I can't start it on my laptop under uphuck 10.4.9.

Can someone generate proper files for my EDID:
[codebox]00FFFFFF FFFFFF00 06AF7419 00000000 010F0103 80211578 0A85A599 574F8F26 1D505400 00000101 01010101 01010101 01010101 0101EA1A 00805020 10301520 44004BCF 10000018 0000000F 00000000 00000000 00000000 00020000 00FE0041 554F0A20 20202020 20202020 000000FE 00423135 34455730 31205639 200A00CC[/codebox]

I'm trying to get this work on Asus A6J laptop with Radeon x1600 (0x71c5). LCD panel has id AUO1974.
Getting only 1024x768 resolution... :censored2:

#369
Matthew Jason

Matthew Jason

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
Greetings,I still don't get what is this for? I am able to load up the kext. and realised closure of Panel will cause the computer to SLEEP, but I am using SSE2. Therefore, Can't sleep!!! :)Also, Didn't notice anything on the Display prefernce pane. Is there anything that I could do? Does this kext provide dimming too?Please help.Thanks.MatthewBy the way, here are the details of my display and graphic card.Matthew

Attached Files



#370
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
Sathanas, this is for you...

#371
XingFeng

XingFeng

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
vera good tanks

#372
DiMoNd21

DiMoNd21

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hi guys!

I have just installed Mac os x Jas on my hp pavillion zd7000. the installation was ok. But when it comes on the boot screen with the logo of apple it freezes. The sound is ok but it does not show any other picture..it does not continue.. Why is this happenig?

The graphic cars is >Geforce 5600 with 128Mb.

Thank you!

Attached Files



#373
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
what patch/extension did you install for your GFX ? What's your OSX version ?
did you try to boot with -v flag (verbose mode) to see where you're getting stuck ?

#374
Robin Masters

Robin Masters

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi, I have a laptop HP nx9420 with ATI RADEON X1600 Mobilty 256MB. I have't found DisplayUtility. This is my EDID:

00FFFFFF FFFFFF00 320C8821 00000000 000F0103 80251778 0A8EF097 58518D28 24505400 00000101 01010101 01010101 01010101 01019525 A0405184 0C304020 13006FE6 10000019 00000000 00000000 00000000 00000000 00000000 00FE004C 47506869 6C697073 4C43440A 000000FE 004C5031 37315750 342D544C 30310064

I have try to convert with PListEditPro but I don't know if is correct. I have used it with the natit of Diabolik, but work only the external display.
Can you help me with the internal display?

thank's

#375
pauledwards03

pauledwards03

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I have a clevo d900k laptop with an nvidia geforce go 7900 gtx (256 mb), just installed 10.4.10 tubgirl (also have tried jas 10.4.8, same results): I get a black screen when using nvdaresman. i have installed natit, titan, nvinjectgo, laptopdisplay and every combination of these kexts. I have also added my device id to geforce.kext, nvdaresman and nvdanv40hal.kext (device id is 0x0299, vendor 10de ((0x029910de))) attatched is a screenshot of my edid data acquired from nvidia-settings put through a hex editor.

by the way, this happened when i first installed the nvidia proprietary driver in linux, the solution for me then was to add
Option "modevalidation" "novertrefreshcheck"
to the device section of my xorg.conf file.

Attached Files



#376
abel gladstone

abel gladstone

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
What should I do after I download the laptodisplay.kext file onto my dexktop

#377
Carlos Pombo

Carlos Pombo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Porto - Portugal
My Laptop display fails to assume and work with any display calibration or color icc profile.
I'm able to calibrate and output a profile using Spyder2 calibration tool. Happens that none of available profiles works. Changing profiles as no visual changes in display.
It is useless for photographic editing.
Using ATIRadeon9700 and koverge patch I can get CI & QE working, even Q2E with some occasional display refreshment square loses.

Who can help me suggesting what to change or look for? Seems to be something related with the way Graphics establish connection with Laptop display.

Graphics ATI x700 Mobility Radeon 128MB

Tks
Carlos

bellow copy/paste from

About This Mac/More Info/Software/Extensions
----------------------------------------------------------------------------
LaptopDisplay:

Version: 1.0.0d1
Last Modified: 10/2/07 2:44 PM
Get Info String: LaptopDisplay 1.0.0d1, Copyright 2007 Free Computer, Inc.
Location: /System/Library/Extensions/LaptopDisplay.kext
kext Version: 1.0.0d1
Load Address: 0x3507e000
Valid: Yes
Authentic: Yes
Dependencies: Incomplete
Dependency Errors:
com.apple.iokit.IOGraphicsFamily: No valid version of this dependency can be found
com.apple.iokit.IONDRVSupport: No valid version of this dependency can be found
com.apple.iokit.IOPCIFamily: No valid version of this dependency can be found
Integrity: UnknowN
----------------------------------------------------------------------------
Callisto:

Version: 1.0.0d1
Last Modified: 10/2/07 1:04 PM
Location: /System/Library/Extensions/Callisto.kext
kext Version: 1.0.0d1
Load Address: 0x3aa46000
Valid: Yes
Authentic: Yes
Dependencies: Incomplete
Dependency Errors:
com.apple.iokit.IOGraphicsFamily: No valid version of this dependency can be found
com.apple.iokit.IOPCIFamily: No valid version of this dependency can be found
Integrity: Unknown
----------------------------------------------------------------------------
CallistoHAL:

Version: 1.0.0d1
Last Modified: 10/2/07 1:04 PM
Location: /System/Library/Extensions/CallistoHAL.kext
kext Version: 1.0.0d1
Load Address: 0x35082000
Valid: Yes
Authentic: Yes
Dependencies: Incomplete
Dependency Errors:
com.apple.iokit.IOPCIFamily: No valid version of this dependency can be found
Integrity: Unknown
----------------------------------------------------------------------------
IOACPIFamily:

Version: 1.2.0
Last Modified: 7/30/07 6:16 AM
Get Info String: Version 1.2.0, Copyright 2003-2005 Apple Computer, Inc.
Location: /System/Library/Extensions/IOACPIFamily.kext
kext Version: 1.2.0
Load Address: 0x34e81000
Valid: Yes
Authentic: Yes
Dependencies: Satisfied
Integrity: Kext is modified
----------------------------------------------------------------------------
IONDRVSupport:

Version: 1.4.5
Last Modified: 7/30/07 6:16 AM
Get Info String: 1.4.5, Copyright Apple Computer, Inc. 2000-2004
Location: /System/Library/Extensions/IONDRVSupport.kext
kext Version: 1.4.5
Load Address: 0x3a6d2000
Valid: Yes
Authentic: Yes
Dependencies: Incomplete
Dependency Errors:
com.apple.iokit.IOGraphicsFamily: No valid version of this dependency can be found
com.apple.iokit.IOPCIFamily: No valid version of this dependency can be found
com.apple.kpi.iokit: No valid version of this dependency can be found
com.apple.kpi.libkern: No valid version of this dependency can be found
com.apple.kpi.mach: No valid version of this dependency can be found
com.apple.kpi.unsupported: No valid version of this dependency can be found
Integrity: Kext is modified
----------------------------------------------------------------------------
IOGraphicsFamily:

Version: 1.4.4
Last Modified: 10/2/07 2:44 PM
Get Info String: 1.4.4, Copyright Apple Computer, Inc. 2000-2004
Location: /System/Library/Extensions/IOGraphicsFamily.kext
kext Version: 1.4.4
Load Address: 0x3a6b8000
Valid: Yes
Authentic: Yes
Dependencies: Incomplete
Dependency Errors:
com.apple.iokit.IOPCIFamily: No valid version of this dependency can be found
com.apple.kpi.iokit: No valid version of this dependency can be found
com.apple.kpi.libkern: No valid version of this dependency can be found
com.apple.kpi.mach: No valid version of this dependency can be found
com.apple.kpi.unsupported: No valid version of this dependency can be found
Integrity: Kext is modified
----------------------------------------------------------------------------

#378
rednose

rednose

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi, first of all: i'm new here and trying to understand what it's all about.

Ihave a problem with my medion laptop (md95800) with Intel GMA900 GFX.
After the installation the pc boots with an external display,butnotwiththeinternal.
After that i've followed the LaptopDisplay steps, which didn't do anything (maybe i did something wrong??).
Then i've tryedtyping-F platform=X86PC at the boot,whichkindaworked, and got me onto the desktop without backlight (backlight falls out after the blue loading screen).
Same thing happens with the paperclip trick.

So,my backlight doesn't light up on the desktop.

Does anyone know how to fix this?

specs:

Monitor
Windows description......... Generic PnP Monitor
Manufacturer................ LPL
————————————————————————————
Plug and Play ID............ LPL0000
Serial number............... n/a
EDID data source............ Registry (stored)
————————————————————————————
Manufacture date............ 2004
EDID revision............... 1.3
Display type and signal..... Digital
Sync input support.......... n/a
Screen size................. 2550 x 2550 mm (~155") - LOL :D
Power management............ Standby, Suspend, Active off/sleep

Color characteristics
Display gamma............... 3.55
Red chromaticity............ Rx 0.625 - Ry 0.340
Green chromaticity.......... Gx 0.285 - Gy 0.605
Blue chromaticity........... Bx 0.148 - By 0.063
White point (default)....... Wx 0.281 - Wy 0.309

Timing characteristics<BR>VESA GTF support............ Not supported
Horizontal scan range....... n/a
Vertical scan range......... n/a
Video bandwidth............. n/a
Extension blocks............ n/a
Timing recommendation #1.... 1024x768 at 60Hz
Modeline................ "1024x768" 65.000 1024 1048 1184 1344 768 771 777 806 -hsync -vsync

Standard timings supported
640 x480 at60Hz - IBM VGA
800 x600 at60Hz - VESA
1024 x768 at60Hz - LPL
1024 x768 at60Hz - VESA

Raw EDID base
00FFFFFF FFFFFF00 320C0000 00000000 000E0103 80FFFFFF EA0000A0 57499B26 10484F21 08000101 01010101 01010101 01010101 01016419 00404100 26301888 360030E4 10000018 00000000 00000000 00000000 00000000 00000000 00000008

Display adapter
Adapter description......... Mobile Intel(R) 915GM/GMS/910GML Express Chipset Family (Microsoft Corporation - XDDM)
Adapter device ID........... 0x25928086
Display settings............ 1024x768, 32bpp

User/computer information
Registered user name........ wfefwe
Registered organization..... n/a
Network user name........... wfefwe
Network computer name....... wfefwe-PC
Windows version ............ Windows 2000
Windows build .............. 6.00.6000
Installation date .......... 10/8/2007 12:00:00 PM

thnx!

#379
nadirturkman

nadirturkman

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey, I'm new to all this Mac OS.. but i'm eager to learn..
I have a problem with my laptop display.. it works fine with VMWARE but when i boot it native it gets stuck in the grey screen.. but i know the system boots, cause i can shut it down with the key shortcuts..
I wonder if your display driver will work.. but i'm having a bit of trouble figuring out how to use it.. can you give me a help? i'd love to try this out to c if it is the solution to my problem

Btw my laptop is equiped with a ATI Radeon Express 1150

Cheers..

#380
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
hi,
reading this thread, i couldn't understand what it is needed for . May please anyone explain in a couple words what are the 2 files (laptopdisplay) needed for and how can they be used ?
Thanks!
Mal





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy