Jump to content

Intel Wireless driver


  • This topic is locked This topic is locked
3991 replies to this topic

#21
rathalos

rathalos

    i H4XX0R B1LL GaT3s

  • Members
  • PipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Location:Singapore
good question... i'm not sure..... probably this is the time when the more senior ppl in this should step in and help out... haha... i know nuts about programming....

#22
TaterSalad77

TaterSalad77

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
and for all you noobers out that who borked your system installing this and cant get it up and running again, just do the following:

1. boot in single user mode with -s flag
2. type /sbin/mount -uw / at prompt
3. then type rm -R /System/Library/Extentions/iwi2200.kext
4. reboot and you should be back to normal

#23
joachim_vanhove

joachim_vanhove

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Denderbelle, Belgium

and for all you noobers out that who borked your system installing this and cant get it up and running again, just do the following:

1. boot in single user mode with -s flag
2. type /sbin/mount -uw / at prompt
3. then type rm -R /System/Library/Extentions/iwi2200.kext
4. reboot and you should be back to normal


When I will do this the driver is deleted and my Intel 2200 card wont be detected by the system?
But I wont the card to be detected, and at this moment it is, but it isn't working. I can't connect with any network.
Is there a solution for this problem?

Thanx

#24
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
This driver is still an "alpha" type release. No one in the thread reports it to be fully working. Only that the card is recognized but won't connect.

I'm afraid you will need to wait for another release of the driver to hopefully get one that connects.

#25
rathalos

rathalos

    i H4XX0R B1LL GaT3s

  • Members
  • PipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Location:Singapore
i agree with rammjet..... we'll just have to cross our fingers and pray hard that the original writer could work out the details and post a more working version....

#26
rathalos

rathalos

    i H4XX0R B1LL GaT3s

  • Members
  • PipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Location:Singapore
jalavoui, any updates??

#27
jalavoui

jalavoui

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,145 posts
Thanks for answering. Good to see people care about this driver :P

When i started this drive i have found lots of code from people who have tried to make it work.

This release is meant to check some of the linux ported code. I'm using the IO80211Family.kext just to make the device to be detected as an airport card. The IO80211Family functions are to hard to use but i'll keep then to get feedback for now.

I'm currently using the 10.4.4 kernel. When i get Shemtex sources i'll change to 10.4.8


You can help by posting the logs like kinwah.lai did

- I'm uploading a new version that forces a local IP (it should be detected on system preferences).

or

If you want to build it from source:

- Install linux with the kernel source (i used mandriva 2006).
- Get the Ext2FS.pkg to allow access to the linux partition from mac os x86 (mount ro mode).
- get the Linux project sources (ieee80211, ipw2200-1.2.0 and the ipw-2.3 firmware).
- install the sources and ipw2200-1.2.0 on your root folder.
- The iwi2200.kext should build fine on xcode 2.4.1
- post new releases in this forum



Testing alpha versions might crash mac os x86 but it is for a good purpose :P

Thank you all

Attached Files



#28
eranj

eranj

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
  • Location:Israel
1st I want to say I appreciate your efforts!
2nd, I would like to add that it will be easiser to test, if there'll be an uninstall script for the worst (or expected) case scenario
Thanks again!

#29
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
Just for a little friendly competition and as some motivation to the other developer, I have a kext that (hopefully) will load the firmware.

Please post a log of it (hopefully) loading and who's kext you used (bikedude880 or jalavoui). Thanks.

EDIT: File removed... see next post.

#30
kinwah.lai

kinwah.lai

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
thanks bikedude880 , i will try it now

i got this error when i try to load the kext by bikedude880

darren-lais-computer:/Users/darrenlai root# kextload -t /System/Library/Extensions/iwi2200.kext
kextload: extension /System/Library/Extensions/iwi2200.kext appears to be valid
kextload: notice: extension /System/Library/Extensions/iwi2200.kext has debug properties set
kld(): Undefined symbols:
__ZN14darwin_iwi22009notifIntrEP9iwi_notif
kextload: kld_load_from_memory() failed for module /System/Library/Extensions/iwi2200.kext/Contents/MacOS/iwi2200
kextload: a link/load error occured for kernel extension /System/Library/Extensions/iwi2200.kext
load failed for extension /System/Library/Extensions/iwi2200.kext
(run kextload with -t for diagnostic output)

i will try to restart the machine now.
will update you guys later

Edited by kinwah.lai, 31 December 2006 - 01:10 AM.


#31
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
I made a little mistake and left some debugging features on. This one has them disabled.

EDIT: Same error as before.

#32
kinwah.lai

kinwah.lai

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

I made a little mistake and left some debugging features on. This one has them disabled.

i've try to load this kext but still got the same error and i'm running on 10.4.8 ( 8.4.1 kernel )

darren-lais-computer:/Users/darrenlai root# kextload -t /System/Library/Extensions/iwi2200.kext
kextload: extension /System/Library/Extensions/iwi2200.kext appears to be valid
kextload: notice: extension /System/Library/Extensions/iwi2200.kext has debug properties set
kld(): Undefined symbols:
__ZN14darwin_iwi22009notifIntrEP9iwi_notif

kextload: kld_load_from_memory() failed for module /System/Library/Extensions/iwi2200.kext/Contents/MacOS/iwi2200
kextload: a link/load error occured for kernel extension /System/Library/Extensions/iwi2200.kext
load failed for extension /System/Library/Extensions/iwi2200.kext
(run kextload with -t for diagnostic output)

Edited by kinwah.lai, 31 December 2006 - 01:46 AM.


#33
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
I just don't understand why it keeps giving that error message... until I can get jalavoui's source to compile, I can't go any further.

#34
Kiko

Kiko

    You Dont Understand Me

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,889 posts
  • Gender:Female
  • Location:United States Of Israel
Great work, so you are able to load the firmware correctly?

#35
rathalos

rathalos

    i H4XX0R B1LL GaT3s

  • Members
  • PipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Location:Singapore
bikedude880, i am getting the same error message as kinwah.lai.....

#36
poplars

poplars

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Location:somewhere within this fabricated reality.
  • Interests:Apple related stuff. Computers in general. Guitar and music, electronics, psychology and relat...
dang dude, if you get that working man I'll straight up come back to OSX86.

I have a 2915ABG, I heard that the 2915, 2200, 3945 are all around the same chipsets so they shouldn't be too hard to get ported to work for all of them if you get the driver to initially work in the first place.

my advice to you, don't give up. I've seen too many people in the past give up and it's just really lame, there's so much sourcecode flying around from people who attempted it in the first place, so please do try and thank you for your efforts.

Edited by poplars, 31 December 2006 - 11:04 PM.


#37
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France

Im working on a 3945abg kext at the moment so it will be interesting to get my hands on the code when i get back home.

how far r u in ur 3945 dev dave? :) id like to test it when it is suppose to work thanx again!

#38
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
Well, I wish I were able to compile these sources, but I keep getting an error... 47 to be exact.
Attached File  errors.tiff   450.91KB   307 downloads

EDIT: Got past the errors, but I don't feel good about the way I did it.

#39
poplars

poplars

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Location:somewhere within this fabricated reality.
  • Interests:Apple related stuff. Computers in general. Guitar and music, electronics, psychology and relat...
any updates on this?

#40
rathalos

rathalos

    i H4XX0R B1LL GaT3s

  • Members
  • PipPipPipPipPipPip
  • 457 posts
  • Gender:Male
  • Location:Singapore
yea, been waiting for updates.... :(

but from what i see from the image you posted, could it be that the 802.11 framework that you compiled with is incompatible with the intel driver???





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy