Jump to content

[Guide] Dell XPS 15 9560 - High Sierra 10.13.2

- - - - - dell xps 9560 hackintosh Zirconiumirish High Sierra

Best Answer narvs, 17 February 2018 - 02:54 PM

Hi all, I'm fairly new to the Hackintosh scene and I'm still finding my bearings on how to make it all work out. 

I've been doing some reading specially Rehabman & KNNSpeed guides and been learning a bunch of new things! I've ended up checking out this guide - Major kudos to Zsparrow0 for putting it together.

 

I've been failing to get the installer to boot, I'm sure I'm missing something. I've followed the guide and I'm still stuck as acboop1000.

 

 

Hey sorry about the late response I never got notifications about a reply. Yeah I have everything up and running now except for my headphone jack, I just updated the kexts that came in the efi download above because it might have had to do with the fact im installing 13.3 instead of 13.2? Oh well. working fine now.

 

I'm wondering if 10.13.3 is the cause (the guide mentions 10.13.2), how were you able to solve this?

 

I've tried updating the kexts on the link you mentioned as well as updating apfs.efi but the installer boot still fails.

Is this guide incompatible with 13.3 installations or is there any files I'm missing? 
Is there any place I could download 13.2 from? Unfortunately, I can only get the most recent update from the appstore.

[DELL XPS 9560 - 4K - Samsung P981 512gb]

Cheers and thanks for the amazing work.

EDIT: Solved - Followed all the steps from scratch, this time with the 10.13.2 version, installer booted successfully.
 

Go to the full post


  • Please log in to reply
31 replies to this topic

#21
Zsparrow0

Zsparrow0

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male

Like with 10.12 I can't seem to get HDMI audio working... did anyone else have any luck?

 

Hi make sure that you have the latest FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext.

 

See the rehabman bitbucket repo for download


I did the same, but are you able to update to 10.13.3?

The ones who did a clean install apparently were able to, but I'm stuck at 10.13.1 and I upgraded from 10.12 (the update downloads and restarts but I get a bunch of errors when it's upgrading so it reverts)

 

I'm actually in 10.13.2 did'nt do the update to 10.13.3 because I get panic maybe need to wait for kext update.

But 10.13.1 to 10.13.2 should work smoother.

 

Check one by one your kext to see if you have the latest version if not replace theme, rebuild the cache and do the direct update.


Hey, I’m having issues booting into the installer. In verbose mode it loads really quick and ends in what looks like a panic. I attached a picture to my post. Can you try and help me out? Thanks

 

Restart the tutorial and follow it step by step.

Everything should work fine.

 

If you have a kernel panic it means that you missed one boot option or you have a conflict between kext.

Check this and retry



#22
tg4m

tg4m

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hi make sure that you have the latest FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext.

 

See the rehabman bitbucket repo for download


 

I'm actually in 10.13.2 did'nt do the update to 10.13.3 because I get panic maybe need to wait for kext update.

But 10.13.1 to 10.13.2 should work smoother.

 

Check one by one your kext to see if you have the latest version if not replace theme, rebuild the cache and do the direct update.

 

Hi, I got the latest FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext (I had to get the newest FakePCIID_Broadcom_WiFi.kext for the wifi to work), used KextWizard to install/repair permissions/rebuild cache/etc. and put it in my EFI clover folder as well but the HDMI audio still isn't working. Is yours working? A lot of people had trouble getting it to work for 10.12

 

& I guess I'll wait for the kext update for 10.13 as well.. it seems like this user has already gotten it though https://github.com/g...560-High-Sierra



#23
antomaug97

antomaug97

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
I new to hackintosh scene, sorry for the dumb question. Is this tutorial for upgrading a hackintosh to its latest version or to do a fresh install?

#24
Zsparrow0

Zsparrow0

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male

I new to hackintosh scene, sorry for the dumb question. Is this tutorial for upgrading a hackintosh to its latest version or to do a fresh install?

 

Hi Antomaug and welcome in the Hackintosh Scene lol.

I made this guide only for fresh install.

 

The direct upgrade is not possible from 10.12 to 10.13 because they made changes in the system files.

 

Let me know if you have any questions



#25
Aschne23

Aschne23

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I successfully upgraded from 10.12 to 10.13 without loosing any data, configs or programs.

At 4) Installation don't format your ssd and select your previous installation as destination.
Follow all other steps as described.

 

Did it 3 Weeks ago.
No problems with the system so far.



#26
wmchris

wmchris

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 288 posts

Hi Antomaug and welcome in the Hackintosh Scene lol.

I made this guide only for fresh install.

 

The direct upgrade is not possible from 10.12 to 10.13 because they made changes in the system files.

 

Let me know if you have any questions

can confirm: direct update is no problem at all. even with transition to APFS....



#27
tg4m

tg4m

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

I new to hackintosh scene, sorry for the dumb question. Is this tutorial for upgrading a hackintosh to its latest version or to do a fresh install?

 

I upgraded from 10.12 to 10.13 and my only issues so far are being unable to update to 10.13.3 without a kernel panic and HDMI audio not working and sleep not working (it restarts the computer after a while)



#28
acdop1000

acdop1000

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Did you manage to solve this? I'm still on the fence and don't know to try this tutorial or not :)

Hey sorry about the late response I never got notifications about a reply. Yeah I have everything up and running now except for my headphone jack, I just updated the kexts that came in the efi download above because it might have had to do with the fact im installing 13.3 instead of 13.2? Oh well. working fine now.



#29
narvs

narvs

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Best Answer

Hi all, I'm fairly new to the Hackintosh scene and I'm still finding my bearings on how to make it all work out. 

I've been doing some reading specially Rehabman & KNNSpeed guides and been learning a bunch of new things! I've ended up checking out this guide - Major kudos to Zsparrow0 for putting it together.

 

I've been failing to get the installer to boot, I'm sure I'm missing something. I've followed the guide and I'm still stuck as acboop1000.

 

 

Hey sorry about the late response I never got notifications about a reply. Yeah I have everything up and running now except for my headphone jack, I just updated the kexts that came in the efi download above because it might have had to do with the fact im installing 13.3 instead of 13.2? Oh well. working fine now.

 

I'm wondering if 10.13.3 is the cause (the guide mentions 10.13.2), how were you able to solve this?

 

I've tried updating the kexts on the link you mentioned as well as updating apfs.efi but the installer boot still fails.

Is this guide incompatible with 13.3 installations or is there any files I'm missing? 
Is there any place I could download 13.2 from? Unfortunately, I can only get the most recent update from the appstore.

[DELL XPS 9560 - 4K - Samsung P981 512gb]

Cheers and thanks for the amazing work.

EDIT: Solved - Followed all the steps from scratch, this time with the 10.13.2 version, installer booted successfully.
 



#30
blayze®

blayze®

    InsanelyMac Geek

  • Donators
  • 126 posts
  • Gender:Male

I just wanna know if anybody can boot into 10.13.4 beta with graphic acceleration (with xps 9560 4k). I can with 10.13.3, not 10.13.4.



#31
narvs

narvs

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I managed to boot the installer and format the SSD through disk utility (APFS), set it to install then after the first reboot I select "boot macOS install from drive", it gets to the installation screen and then after a few minutes of no progress on the install, the laptop suddenly reboots.

 

When clover boots again I have a third boot option "boot from recovery". I've been going around this but couldn't yet install the OS.

I´ve tried:

- boot from the Preboot also but the same problem occurs,

- Boot from recovery - starts booting but reboots shortly after

- Format the SSD to Mac-OS Journaled, get a bit more progress on the install but still crashes the same way.

I'm now wondering what other options I could try, does anyone been through a similar scenario? Any ideas on how to get around it would be much appreciated.

[My disk : Samsung P981 512gb] 

 



#32
Zsparrow0

Zsparrow0

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male

I managed to boot the installer and format the SSD through disk utility (APFS), set it to install then after the first reboot I select "boot macOS install from drive", it gets to the installation screen and then after a few minutes of no progress on the install, the laptop suddenly reboots.

 

When clover boots again I have a third boot option "boot from recovery". I've been going around this but couldn't yet install the OS.

I´ve tried:

- boot from the Preboot also but the same problem occurs,

- Boot from recovery - starts booting but reboots shortly after

- Format the SSD to Mac-OS Journaled, get a bit more progress on the install but still crashes the same way.

I'm now wondering what other options I could try, does anyone been through a similar scenario? Any ideas on how to get around it would be much appreciated.

[My disk : Samsung P981 512gb] 

 

As said in the guide during the first installation screen your computer will reboot sudently you have to make sure to PRESS F12 to boot from your usb drive (As clover is not yet installed) and then you have to boot in PREBOOT mode. and the installation should continue for about 10 minutes.

 

If it reboot always make sur you press F12 and use Preboot or Boot from "" NEVER RECOVERY (during the installation process)

 

Let me know


I just wanna know if anybody can boot into 10.13.4 beta with graphic acceleration (with xps 9560 4k). I can with 10.13.3, not 10.13.4.

 

I did the update the crash as well, I don't know where it come from need to update the kext I think..







Also tagged with one or more of these keywords: dell, xps 9560, hackintosh, Zirconiumirish, High Sierra


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy