Jump to content

[HELP] Can't install AMD Radeon HD 7700 Series on High Sierra

help amd radeon hd 7700 series high Sierra error resolution kexts

  • Please log in to reply
71 replies to this topic

#21
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

P.S

 

The app is NVRAM/Kextcache Cleanup .......

oh! ok , thanks. Gonna try it out. 


P.S

 

The app is NVRAM/Kextcache Cleanup .......


Nope, the second link on the last line

I've opened it and clicked Cleanup, that's all?

EDIT: I've just seen on the top bar the program working , I'll wait. :D



#22
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

Yup, that's pretty much it, It will delete the nvram, the kextcache and the prelinkedkernel and once it's done you'll be asked to reboot.



#23
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Yup, that's pretty much it, It will delete the nvram, the kextcache and the prelinkedkernel and once it's done you'll be asked to reboot.


Hi, unfortunately it didn’t work. What can we do?

#24
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

Hi, unfortunately it didn’t work. What can we do?

Try this folder.

Since WhateverGreen didn't work we are going to use the second solution. Replace the Clover on your USB disk with this one.

Attached Files



#25
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Hi, unfortunately it didn’t work. What can we do?

Try this folder.
Since WhateverGreen didn't work we are going to use the second solution. Replace the Clover on your USB disk with this one.

I’m not in home now, in about 20 minutes I’ll be back. :)

#26
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

Well I hope the second folder solves the problem. Let me know how it works. We will continue later.



#27
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Well I hope the second folder solves the problem. Let me know how it works. We will continue later.


I’ve just tried it, and when I try to boot this black screen appears. The text appears and disappears. :(

Attached Files



#28
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

I’ve just tried it, and when I try to boot this black screen appears. The text appears and disappears. :(

 

Try this

Attached Files



#29
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Try this


Gonna try that.

Try this


Still can’t boot , the same as the other Clover, that text appearing and disappearing. Also I could read a “can’t load amd...kext”

Try this

I have recorded the boot sequence , let’s see if you see any error there

https://drive.google...RGXlO4T2_Qs36Ms

#30
Gigamaxx

Gigamaxx

    InsanelyMac Legend

  • Donators
  • 1,103 posts
  • Gender:Male

I used this on a i5 3XXX series laptop worked great try this I modded a little for ATI.

 

Attached File  EFI.zip   2.67MB   3 downloads



#31
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Try this

 

 

I used this on a i5 3XXX series laptop worked great try this I modded a little for ATI.

 

attachicon.gifEFI.zip

 

None of them activated my graphics card. cyberdevs , let's see if we can try more things and Gigamaxx, that Clover folder booted , but still doesn't recognizes my graphics card.



#32
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

Tell me the exact model of your GPU.



#33
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Tell me the exact model of your GPU.

well I have just seen that I have the "twin" of the 7700 series, I actually have the ASUS r7 250x. I got this card https://www.asus.com...rds/R7250X2GD5/, but only with 1GB 



#34
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

There are 3 GPUs with the same device ID as yours Radeon HD 7770/8760/R7 250X.

 

Did you ever try to use another version of macOS before High Sierra?


One last question do you have IGPU/IGFX enabled in BIOS?



#35
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

There are 3 GPUs with the same device ID as yours Radeon HD 7770/8760/R7 250X.
 
Did you ever try to use another version of macOS before High Sierra?
One last question do you have IGPU/IGFX enabled in BIOS?

A couple of years ago I tried to install Yosemite but I had a non-compatible keyboard so I went back to Windows. In BIOS I have “Init Display First” set in Auto.

#36
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

Disable IGPU in BIOS and use the clover folder I posted here.

 

Getting High Sierra to boot with two GPUs is bit more complicated. Try with iGPU/iGFX set to disable and your AMD GPU set as primary in BIOS and see how it goes.



#37
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

Disable IGPU in BIOS and use the clover folder I posted here.
 
Getting High Sierra to boot with two GPUs is bit more complicated. Try with iGPU/iGFX set to disable and your AMD GPU set as primary in BIOS and see how it goes.

Gonna try it :)

#38
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male

P.S

 

Use GPUz in windows to make sure that you have the R7 250X with the device id 683D, if you have the R7 250 (non X) you might be out fo luck.

 

https://www.techpowe...hpowerup-gpu-z/



#39
zafirofx

zafirofx

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Spain

P.S
 
Use GPUz in windows to make sure that you have the R7 250X with the device id 683D, if you have the R7 250 (non X) you might be out fo luck.
 
https://www.techpowe...hpowerup-gpu-z/

I’ve tried to boot from the Clover2 folder and nothing. I had set as primary graphics my gpu
and deactivated the intel integrated graphics. Gonna make a partition for Windows, here I have a usb ready to install it.

#40
cyberdevs

cyberdevs

    InsanelyMacaholic

  • Donators
  • 2,768 posts
  • Gender:Male
You don’t have to install windows

Just use the first clover folder to boot into macos without the amd GPU support. Use dpcimanager and gather the device id form there


Sent from my iPhone using Tapatalk





Also tagged with one or more of these keywords: help, amd radeon hd 7700 series, high Sierra, error, resolution, kexts


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy