Jump to content

Atheros AR5005(G)


  • Please log in to reply
344 replies to this topic

#101
ktrain

ktrain

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
For those of you with Atheros chip 168c,0013:

Mine worked great first reboot after following the guide, however, on subsequent reboots, no wireless netrworks were found.

After much experimentation, I find that by adding a couple lines to /etc/rc/shutdown/local I was good to go even after restarts and sleep. Here are the lines I added:

sudo rm /System/Library/Caches/com.apple.kernelcaches/*
sudo rm /System/Library/Extensions.kextcache
sudo rm /System/Library/Extensions.mkext

Hope this helps others with Airport issues after restarts!

#102
royideas

royideas

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
maybe it helps for atheros AR5006Eg? who can test this method )?

#103
supernovafan

supernovafan

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts

EDIT!: By taping pin 20 on my Dell replacement card, I now have wifi in OSX!



Wow! How did you ever figure that out? It's working for me thanks!!!

#104
royideas

royideas

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
supernovafan what wi-fi adapter do you have?

#105
cportella

cportella

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

first of all sorry for my english.
im running mac osx 10.4.8 my wireless card from dlink mode wua-2340
this is what is show in USB About this mac

USB WLAN Device:

Version: 0.01
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: Atheros Communications Inc
Product ID: 0x3a08
Serial Number: 1.0
Vendor ID: 0x07d1


What do i have to do to get wireless connected. please help me


Hello, have you discovered how to install your wireless adapter??
I have the same problem, but in a 10.3 osx.

Thanks

#106
CodyH

CodyH

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I'm sure that their is already an answer to my problem somwere on this board but I cant seem to get my Atheros AR5005(G) Card to work I have treid both method sugsed in this post and no luck I have a Aspire 3680 and the JAS 10.4.8 instlation. I can give more info if it is needed and any help would be aprecated. Thanks

#107
jannol

jannol

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Yesterday I got it working very well.
My puter is Acer Travelmate 2480
with AR5005

I installed 10.4.8 and then 10.4.9 update

Open Term
Then remove the Extensions.mkext and .kextcache, make sure you repair permissions so they are correct.
(You can do that from the disk utility if you like.)

Reboot
Open term and check if there is both AirPortAtheros.kext and AirPortAtheros5424.kext. If so remove the first one.
Happend to find out this is not actually needed, instead if this file is created simply go edit
/Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
to using
<key>IOInterfaceUnit</key>
<integer>1</integer>

0 on the first and 1 on the second. It seems like if any new kext runs after this these posted changes it adds the new kext and also add a new block instance in NetworkInterfaces.plist. Ask if I do not make any sense?!!??!?! :-P

then sudo nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros5424.kext/Contents/Info.plist

and change it to look like (using your own values)
<string>pci104c,0039</string>
<string>pci168c,1a</string>
I found my values from booting ubuntu dapper in live mode inside the devices list or whats it called.

Then once again
Remove the Extensions.mkext and .kextcache, make sure you repair permissions so they are correct.

Reboot and open Network, check if Built in is activated (meaning not grayed out, leave it enabled) if so, all is good and there's one last step.

nano /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and change
<key>IOInterfaceUnit</key>
<integer>0</integer>
to
<key>IOInterfaceUnit</key>
<integer>1</integer>
reboot and open Network and it should tell you it found the airport card.

DO NOT RUN ANY AIRPORT UPDATES, It will brake dependencies.If you have an Airport Extreme Base Station, use its cd to install Airport Utility BEFORE you install the 10.4.9 update. (I hope you all know you can't install 10.4.9 from Software Update.) Use the different channels to grab it. :-P

After that it worked flawless for me every boot, fully wpa/wpa2.
AND I sold it today with os x installed and bought a Blackbook, nothing todo with this, it just happend today, I have got my eye on macs for long now. Just saying cause I can't check or test anything on it nomore.

#108
EAMC

EAMC

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hello,

i have a AR5006X... i thing so... now i have some questions.
How can i have a look to the id's and wich do i need?

The Second question is, how i can get work my wireless card... i tried like on the first page shown by matt-(...)... but i didn't...

Thanks to everbody!

#109
andytof47

andytof47

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
I am using the Uphuck 1.2 dvd and would like to ask what I need to do to make my SMC atheros chipset NIC work? I tried the method on page one but it didn't work unfortunately........ Perhaps the files that are attached are not for this version ----- I did notice a couple of posts up a post about an upgrade from 10.4.8 to 10.4.9 but it looks really complicated......

Does anyone have an update (simple) for 10.4.9? I really need my Internet (spose since there are alot of people using the Uphuck version this would be handy for others if anyone really kind ;) would care to explain...... and post the kext files that are needed for 10.4.9)


Cheers all I really appreciate the help

#110
Rmix

Rmix

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
Anybody have IO80211Family.kext from 10.4.5 already Patch with
drwxr-xr-x 3 root wheel 102 Feb 2 2006 AirPortAtheros5424.kext
drwxr-xr-x 3 root wheel 102 Feb 2 2006 AppleAirPortBrcm4311.kext

This use to work for my Atheros 5005G MiniPCI when I had 10.4.6 and when I updated to 10.4.8
I keep tryng but it won't apper me like that. And I forgot to Back it up .

I do Matt Tutorial but I end up with Airport Extreme card Off, and when I go to System Preference/Network It doesn't. Also my ethernet stop Working

#111
Thor

Thor

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

Without a bios hack i'm unable to use any other mini pci-e cards. Since no one has had sucess with the 5006eg i must look into a viable USB or a PC card solution.

EDIT!: By taping pin 20 on my Dell replacement card, I now have wifi in OSX!


Hi can you please give us more info on this hack.
What type of card are you using.
Is it mini pci or mini pc express?
Wher can we find out what this pin does?

Perhaps this will be a hope for my Dell 1500 n pci express that makes my laptop not going though post.


Thanks

#112
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i

EDIT!: By taping pin 20 on my Dell replacement card, I now have wifi in OSX!

ghw9132, can you conjure up a picture to show us which pin is #20? What kind of tape did you use? I really would not know how to tape a 1 mm pin .. :thumbsdown_anim:

#113
Rmix

Rmix

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
After a lot of research and lot of reading I manage to fix it with all the Updates.

I made a Tutorial for it:
http://forum.insanel...showtopic=57316

#114
Jingu

Jingu

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Thanks Rmix for the very thourough tutorial.

I just managed to get my Atheros AR5005GS Mini-PCI Express working (Vendor 168c, device 1c). Up until now, Mini-Pci Express Atheros cards could not work at all.

I managed to get mine working just a few minutes ago before I saw your tutorial. I downloaded the latest Airport update and used the IO80211Family kext from the Koolkal 10.4.10 combo update. I am running Uphuck 10.4.9 though. I did not have to edit any kexts, but had to repair permissions on IO80211Family with chown and chmod.

In your tutorial, is deleting the AirportAtheros kext really necessary? mine is still there and everything has been working flawlessly with my WPA newtwork, even after several reboots.

#115
bemac

bemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Rmix,

Excellent tutorial.

Could that work for Atheros 5007 - AR5007EG ?

Or would be an absolute no go?

#116
ghw9132

ghw9132

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts

ghw9132, can you conjure up a picture to show us which pin is #20? What kind of tape did you use? I really would not know how to tape a 1 mm pin .. ;)

A few of the pins were labeled so I just counted from there to determine which pin was pin 20. I used scotch tape, placed a piece across many pins and cut out the one pin with an exacto knife and removed the excess with tweezers.
In response to a few other questions, I purchased a dell truemobile 1490 PCI-E card but it would not work due to a wifi kill switch that only worked with the original card. Pin 20 on mini PCI-E works like pin 13? on mini PCI cards and by taping over it the kill switch is effectively disconnected.

I am pretty sure this will not help if you have a hp/compaq laptop that will not post with a replacement wifi card. The only way I have read to fix those is to edit the computer's bios to change ven/dev IDs (very risky IMO) or to edit the flash on the replacement WIFI card to match the ven/dev IDs of the original card which would prevent the card from working in windows.

BTW, on another thread it is mentioned that an update "Koolkal 10.4.10 combo update v.2" supports the AR5006EG and apparently some others.

#117
tkman

tkman

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
ghw9132, did you have to do anything after taping pin 20. or was it just a matter of tape, install, turn on osx?

#118
Unknown101

Unknown101

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
Hey guys everything was successful, but if I shutdown or reboot the computer the next time I boot up the airport card is not detected again and I have to enter the code every time is there any fix for this problem

#119
Guest: the unit_*

Guest: the unit_*
  • Guests
does this work on the dlink dwlg520 card it uses a atheros chipset i beleave mine is chipset b3

<h2 id="DWL-G520">DWL-G520 </h2> Chipset:AR5212 (b/g) Chipset:DWL-G520 v.B3 AR 2414A-00 (b/g) Chipset:DWL-G520+ v.A3 Texas Instruments URL:http://www.dlink.com/products/?pid=12 URL:http://www.dlink.com...reless/dwlg520/ URL:http://tsd.dlink.com...ocuSno=BCLHCCED Interface:Native PCI interface. Antenna Connector:No connector, but ~0.1m of cable. Antenna Connector:B3/4.11:External connector and aerial, no cable. Antenna Connector:Dipole with detachable reverse SMA connector. Device Information:PCI ID 168c:0013 (rev 01) Notes:B2/3.1.6:Master mode tested and verified as working Notes:B3/4.20: Working in master mode, bridged to eth0, with hostapd for WPA2 - No problems once setup. Works also with Debian Sarge (stable, 2.6.16 kernel) in hostap (master) mode. 11Mbps, 54Mbps, and 108Mbps all tested and working in Debian Sarge. Notes:B4/4.30: Works under Ubuntu 6.06 with WPA. Shows up in lpsci output as "Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)". According to D-Link support the chipset of rev. B4 is AR2414 Notes:B4/4.31: Master mode tested and verified as working. Works with Debian Etch (stable) with 2.6.21.5 kernel. Shows up lspci output as "Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)".

#120
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

I have an Atheros AR5007EG in my Acer Aspire 3680-2633 Laptop, I have not been able to get it to work at all. It has the vendor ID of 168c, and device ID of 1c. I'm trying to use it on a 10.4.8 Jas install, and have also tried using the 10.4.5 kexts. Can someone help me out? Thanks



I'm using same card also. My Atheros AR5007EG is using AR5BXB63 chipset. Yours?
I still unable to find the cure. Right now I'm using usb wireless device, LevelOne WNC-0301USB.

Acer Aspire 3684NWXMi





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy