Jump to content

Aiuto Post Installazione Mac OS Sierra HP 15-N249 sl


  • Please log in to reply
64 replies to this topic

#21
foskvs

foskvs

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,812 posts
  • Gender:Male
  • Location:Italy

Sì, esistono kext, ma funzionano solo con kext non patchati. Rileggi attentamente:

Qui trovi una guida su come scaricare Sierra -> https://support.appl.../it-it/HT208202

Qui trovi una guida su come installarlo -> http://www.insanelym...01x-clover-usb/



#22
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao ho provato a re installare il sistema selezionando la partizione su cui risiedeva usano o la guida da te fornita, ma non sembra essere cambiato niente. inoltre, per far partire il setup ho dovuto lo stesso usare il config.plist dal setup precedente, dato che era configurato per usare direttamente la mia GPU interna. sto sbagliando qualcosa?



#23
foskvs

foskvs

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,812 posts
  • Gender:Male
  • Location:Italy

Quindi niente audio? Altro che non funziona?

Allaga la nuova EFI e un Hack_Info. Vediamo se AppleHDA è a posto.



#24
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Allora ti Allego per primo l'hack info aggiornato 

 

https://drive.google...iew?usp=sharing

 

e poi il nuovo EFI che ho usato

 

https://drive.google...iew?usp=sharing



#25
MARZILLO

MARZILLO

    InsanelyMacaholic

  • Donators
  • 2,628 posts
  • Gender:Male
  • Location:Roma

fai cosi...

elimina hdaenabler da s\l\e

 

ricrea la cache con il seguente comando da terminale

 

sudo touch /System/Library/Extensions && sudo kextcache -u /

 

riavvia e prova la efi allegata se puoi da usb....prova l'audio...se non funziona puoi provare i layout aprendo il config alla voce devices\audio e aggiungendo i numeri consigliati 

3, 4, 13, 27, 28, 29, 86

 

uno alla volta seguiti da un riavvio...
 

 

applehda in s\l\e deve essere originale


elimina anche questo per adesso da s\l\e

 

FakePCIID_Intel_HDMI_Audio.kext

Attached Files



#26
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao, 

innanzitutto ho provato il tuo EFI, e mi mandava il pc in kernel panic, sto dopo mi sono ricordato che non avevo un Kext AppleHDA Clean e ho reinstallato il sistema includendo  vari Kext che avrei installato dopo, cioè ethernet, ps2, capi battery manager e fakepciid senza l'hdmi audio (cioè fakepciid e intelhdgraphics). successivamente ho provato a testare il tuo metodo di mettere uno alla volta i numeri che mi hai dato in Clover Configurator. però, ancora niente eccetto un messaggio durante il boot cha mi sembrava un' pò sospetto:

Unexpected session: 100000 by id:  -1 requested by: 33

o comunque qualcosa del genere, mentre prima quando non avevo il Kext applealc nella chiavetta,durante il boot mi diceva che c'era una "Sound assertion" in AppleHDAController nelle linee 424 e 569.

 

gli errori qui sopra possono essere correlati al mio problema o non c'entrano niente?



#27
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Ma hai un DSDT patchato? Senza quello tante cose non funzionano a dovere, batteria per esempio.



#28
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

sfortunatamente non lo so. nel caso che non lo sia sapresti aiutarmi a patcharlo?



#29
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Comincia con estrarlo, alla GUI di Clover premi alcune volte F4 e attendi almeno una 30ina di secondi prima di fare il Boot, poi monta la EFI e controlla che la cartella EFI/CLOVER/ACPI/origin sia popolata,  se è vuota devi ripetere l'operazione, infine già che ci sei posta la EFI zippata (togli la cartella Apple al suo interno se presente, così si risparmia spazio)



#30
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao, Ecco qui il pacchetto EFI con la cartella origin per la verifica

 

https://drive.google...iew?usp=sharing



#31
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Non installare kext in S/L/E eventualmente si installano in L/E, per cui cancella 

ACPIBatteryManager.kext

CodecCommander.kext

FakePCIID.kext

FakePCIID_Intel_HDMI_Audio.kext
FakePCIID_Intel_HD_Graphics.kext
HDAEnabler.kext
poi apri terminale e ricostruisci la cache con il comando:
 
sudo kextcache -i /
 
fai copia incolla e dai enter, digita la password quando richiesto e di nuovo enter (non vedrai apparire niente mentre la digiti, è giusto così) e riavvia. Per il momento non ti funzionerà niente.


#32
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Dò per scontato che hai fatto quanto ti ho detto sopra, altrimenti non procedere.

sostituisci il config con quello allegato, metti DSDT.aml e SSDT-Disable_DGPU.aml in EFI/CLOVER/ACPI/patched (non in ACPI/origin mi raccomando). Riavvia e controlla un pò tutto.

La ethernet dovrebbe funzionare, collega il laptop via cavo e rifai DPCIManager, prima di prendere gli screenshots clicca su Update seder e Update ID.

Per prendere screenshots usa i comandi tastiera:

tenendo premuti contemporaneamente Maiusc+Cmd premi su 4 e poi Barra Spaziatrice, sposta il puntatore sulla finestra che vuoi salvare e fai click. Lo screenshot si salva automaticamente sul desktop.

Attached Files



#33
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao, non riuscendo a trovare i Kext che mi avevi elencato nel post precedente ho deciso di re installare il sistema e re installare i kext necessari per far funzionare tastiera, touchpad e scheda video in Library/Extensions e ho provato a metterei file patchati nella EFI della mia chiavetta nella cartella patched ma niente da fare, l'audio non va ancora e la batteria non viene ancora mostrata.

 

EDIT : Scusa mi sono dimenticato di darti gli screenshot di dpcmimanager

 

https://drive.google...iew?usp=sharing

 

https://drive.google...iew?usp=sharing

 

https://drive.google...iew?usp=sharing

 

Queste sono tutte e tre le schede del programma



#34
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male
I kext che ti servivano erano già tutti nella efi, se stai usando l’ultima che mi hai passato. In questo modo li avresti solo replicati. Come hai installato i kext in L/E, dimmi esattamente come hai fatto.

#35
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
I kext li ho reinstallato con EasyKextpro. Solo che adesso sto di nuovo reinstallando il sistema, dato che nel periodo in cui stavi esaminando i dati del post precedente era uscito un aggiornamento. L'avevo fatto e poi la macchina si è bloccata. Inoltre, mentre stavo rilanciando il setup mi sono accorto che durante la fase di boot diceva lo stesso che c'erano delle sound assertion in applehdacontroller. Se hai bisogno di qualche informazione in più, quando finisco di reinstallare tutto ti recupererò tutto ciò che richiedi.

#36
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Non mettere i kext in L/E lascia tutto nella EFI



#37
Spinoni31

Spinoni31

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

Ciao, ho provato a re installare il sistema con i Kext esclusivamente nella partizione EFI è adesso sia la batteria che l'audio interno vanno alla perfezione, le uniche cose che adesso mi mancherebbero per riuscire a rendere l'hackintosh funzionale al 100% sarebbe di risolvere il problema dei tasti funzione sulla tastiera ( infatti i tasti per la luminosità dello schermo non vanno), l'audio sulla hdmi (ho provato a mettere il Kext fakepciid_intel_HDMI_Audio ma niente) e il touchpad (il tocco per il click non funziona).



#38
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male
Il tocco per il click lo devi abilitare da preferenze di sistema/ trackpad, per i tasti bisogna fare un Debug, domani ti preparo l’occorrente. Hdmi lo vediamo per ultimo.

#39
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

- Sostituisci il DSDT con quello allegato

- Installa ACPIDebug.kext in L/E con la App che usi di solito e riavvia.
- Controlla che il kext appena installato venga caricato da terminale.
 
kextstat | grep -i acpidebug
 
Se tutto a posto continuare, altrimenti, bisogna risolvere il problema.
Apri console e assicurati che sia selezionato in "Dispositivi" il "Tuo Mac"; nel campo cerca scrivi acpidebug e dai Enter:
 
scherm35.png
 
Ora premi uno alla volta i tasti Luminosità - e Luminosità + (di solito F2 e F3). Devi ottenere un risultato simile a questo:
 
scherm34.png
 
Posta i tuoi valori _Qxx:

Attached Files



#40
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,964 posts
  • Gender:Male

Dimenticavo, fai uno ioreg con il Monitor/TV collegato al laptop. (e togli i Fakepciid)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy