Jump to content

High Sierra su HP elitebook 2570p


  • Please log in to reply
38 replies to this topic

#1
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Buonasera forum, oggi ho installato osx 10.13.0 sul notebook in oggetto sul quale girava molto bene osx 10.12.6.

Sulla chiavetta usb ho semplicemente incollato la EFI funzionante di Sierra ma al riavvio su High non funziona l'audio, wifi e touchpad.

allego schermata dpcimanager e cartella CloverAttached File  Schermata 2017-12-05 alle 09.27.35.png   115.31KB   0 downloadsAttached File  Schermata 2017-12-05 alle 09.27.57.png   227.79KB   0 downloadsAttached File  CLOVER.zip   6.17MB   3 downloads



#2
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Ho lo stesso portatile e tutto funziona alla grande, ho notato da parte tua l'uso di kext estranei e molti obsoleti.

ACPIBacklight.kext--> non funziona più da un pezzo

ApplePS2SmartTouchPad.kext--> come mai usi questo quando basta VoodooPS2Controller.kext??? Facile che vadano addirittura in conflitto

CodecCommander.kext--> mai usato.

IOath3kfrmwr.kext--> neanche questo

USBInjectAll.kext-- nemmeno.

Cancella i kext che hai in other e metti quelli che ti allego in 10.13

Nel config hai abilitato generate P/C states, disabilitali visto che stai usando SSDT, e disabilita anche quel Drop OEM DSM.

SMBIOS sarebbe stato più corretto è MacBookPro9.2, comunque se non hi problemi tieni quello che hai.

Attached Files



#3
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

grazie Jolly per la risposta ,anche io pensavo che alcuni kext potessero entrare in conflitto ma me li porto dietro da El Capitan e fino a Sierra non mi hanno creato problemi. ora provo a ringiovanire il tutto con i tuoi e posto il risultato. grazie mille



#4
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Attento al discorso SMBIOS, se il tuo funziona mantienilo, altrimenti potresti avere problemi di Log



#5
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

ho svuotato la cartella others e messo la tua 10.13. modificato smbios a 9.2 e tolto le spunte nel config come mi hai suggerito . ora funziona tutto ciò che non andava ma il sistema non vede più la videocamera che prima era riconosciuta.   comunque molto bene cosi. grazie ancora



#6
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Prima di tutto ricostruisci la cache da terminale:

 

sudo kextcache -i /

 

e riavvia

 

se ancora non va la videocamera prova a rimettere usbinjectall  

 

Toglimi una curiosità, ma prima ti funzionava il bluetooth?



#7
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

il bluetooth era visto nelle preferenze di sistema ma sinceramente non l'ho mai usato....



#8
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Quanta ram hai ? E vai nel bios e controlla la versione che hai



#9
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

ho solo 4gb di ram ma nel fine settimana mi procuro un'altro banco. dopo aver ricostruito la cache in merito alla videocamera non e cambiato nulla. ora ricarico la usbinjectall e riavvio così controllo la versione del bios



#10
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Attenzione con l'aggiunta della ram, qualche volta và liscia, ma di solito bisogna estrarre nuovamente il DSDT e ripatcharlo



#11
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

bios 68ISB ver.F40 .

speriamo che aggiungere ram non crei problemi altrimenti dovrò rompere di nuovo per il dsdt...



#12
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Quello si rifà. La webcam ora va?



#13
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

yes serviva proprio quel kext  adesso non mi resta che testare tutto con calma ma direi che va tutto benone, grazie a te. 



#14
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Se puoi mi fai uno ioreg sia con che senza usbinjectall?



#15
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male
Altra cosa, il bios che hai è datato, un aggiornamento non sarebbe male. L’ultima versione è la F66 di aprile 2017. Avvisa se pensi di farlo perché bisogna sicuramente rifare il dsdt. Dovresti anche provare se riesci a fare il boot senza.

#16
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

scusa se rispondo solo ora ma ieri sera ho dovuto staccare di botto... oggi sono tutto il giorno fuori ma stasera penso di poter fare ciò che mi chiedi. Riguardo l'aggiornamento del bios se non è indispensabile sono restio a farlo per cui ,almeno per ora, lascerei quello che c'è.



#17
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Non è indispensabile, te l'ho fatto notare perchè hai detto che sei intenzionato ad aumentare la memoria ed è possibile che tocchi rifare il DSDT, per cui eventualmente si prendevano due piccioni con una fava. 

Comunque prova a fare il boot senza il DSDT, basta selezionare un nome diverso alla gui di di Clover in "Opzioni"


Mi dovresti dire anche se lo hai mai collegato ad un Monitor/TV via Display Port



#18
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Attached File  e’s MacBook Pro con.zip   2.42MB   1 downloadsAttached File  e’s MacBook Pro senza.zip   2.37MB   1 downloadsmai collegato a monitor esterni.

 


non ho ben capito come bootare senza dsdt escludendolo dalla gui di Clover



#19
Jolly

Jolly

    InsanelyMac V.I.P.

  • Local Moderators
  • 9,966 posts
  • Gender:Male

Purtroppo mi dà file corrotto. Rifai la procedura con questo ioregistry

Attached Files



#20
erm1893

erm1893

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Attached File  e’s MacBook Pro con.zip   546.25KB   2 downloadsAttached File  e’s MacBook Pro senza.zip   541.27KB   1 downloadsecco


ah, ho aggiunto provvisoriamente un banco ram da 1gb che avevo e lo ha riconosciuto senza problemi per cui spero non ci siano neanche aggiungendo 4gb







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy