Jump to content

GTX965m on Notebook (Optimus is disabled)


  • Please log in to reply
4 replies to this topic

#1
TECH_ATTACK

TECH_ATTACK

    InsanelyMac Geek

  • Donators
  • 145 posts
  • Gender:Male
  • Location:Germany

I use a Lenovo P51 as mobile Device with Mac OS X Sierra 13.1. Intel P630 (HD630 Version of the Xeon) is working well. I can disable the iGPU in Bios, so when i boot to OS X the Nvidia Card, that is also installed, is recognized correct. (Vendor 10de etc). But if i install the Webdriver i see that GM100HAL is loaded and registered but Screen stays black (only the text from -v boot is displayed). Is there any way to get an accelerated Desktop? I think i did disable optimus in bios with disabling iGPU, so is there a way to get it full working? (I guess its a EDID or Framebuffer Problem, because Card is recognized full... because GM100HAL is loaded and registered).

 

Would be nice to get help.

 

Greets 



#2
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 14,226 posts
  • Gender:Male
  • Location:Toscana

you can try -->      Download NvidiaGraphicsFixup_1.2.1.kext.zip                with Lilu.kext



#3
TECH_ATTACK

TECH_ATTACK

    InsanelyMac Geek

  • Donators
  • 145 posts
  • Gender:Male
  • Location:Germany

Same Result. So is Optimus disabled in my Case? How can I find out whats the reason of not working?



#4
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,457 posts
  • Gender:Male
  • Location:Moscow

I have notebook Dell Latitude E6400 with IntelHD4000 and HVS5200M. If I disabled Optimus in BIOS then the Intel graphics became off and it boots only with Nvidia graphics. As in your case.

First time I got only black screen  but then I understand that it depends on Board-ID. Even though I set MacBook I have to set Board-ID from iMac14,2 because it uses Nvidia graphics.

Second condition is NVCAP. It is connectors map for driver output.

I set this one

		<key>NVCAP</key>
		<string>0501000000000100060000000000000f00000000</string>

Try the same or look for  other digits.

Third you may need to inject ROM. Get it with Clover F6 function and insert into /EFI/CLOVER/ROM.

LoadVBios=YES

May be you need to inject EDID. In some cases it needed. 



#5
TECH_ATTACK

TECH_ATTACK

    InsanelyMac Geek

  • Donators
  • 145 posts
  • Gender:Male
  • Location:Germany

Ok, thx for the info. So I can hope I can get an accelerated Desktop with Nvidia. 

Is it possible to share your config.plist file? And how can I find other NVCAP?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy