Jump to content

Disk Utility não reconhece HD


Best Answer NelsonF, 13 November 2017 - 12:29 AM

Pelo que vi vc está instalando numa placa-mãe lga775 c/ HDD, correto? Pela minha experiência c/a LGA775, mesmo que no HD vc já tenha instalado o Sierra, e agora está tentando instalar o HS, e, por alguma razão o instalador do HS refuga a instalação e aparece essa tela borrada. Vc precisa de um HD sem problemas, que eu não sei dizer qual problema é esse que faz o instalador parar nessa tela borrada. O que posso afirmar é que para em “steel waiting for root device”. Tbm tenho um pc c/ lga 775 e tive que usar vários HDs para concluir a instalação(6 para ser exato). C vc tiver outro(s) HDD(s), recomendo utilizá-lo(s) até que consiga prosseguir c/a instalação. Outra informação, nas lga775 o instalador do HS não reconhece SSD. Pra instalar em SSD, só c/ clonagem! Boa sorte!

vc certamente precisa do patch AHCI pro HighSierra

<dict>				<key>Comment</key>				<string>fix IO error for 10.13, credit SunKi</string>				<key>MatchOS</key>				<string>10.13.x</string>				<key>Disabled</key>				<false/>				<key>Name</key>				<string>AppleAHCIPort</string>				<key>Find</key>				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>				<key>Replace</key>				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>			</dict>			<dict>				<key>Comment</key>				<string>fix hotplug for 10.13, credit SunKi</string>				<key>MatchOS</key>				<string>10.13.x</string>				<key>Disabled</key>				<false/>				<key>Name</key>				<string>AppleAHCIPort</string>				<key>Find</key>				<data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>				<key>Replace</key>				<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>			</dict>
MaLdOn, esse patch é pra aplicar em que parte do config.plist?kernel and kext patch? RTvariables? Go to the full post


  • Please log in to reply
13 replies to this topic

#1
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...
Boa tarde!

Eu tentei instalar o High Sierra em um HD de 160gb, mas quando início o instalador, aparece uma mensagem de que está criando uma partição APFS em uma tela preta.

Depois me é mostrada a tela do Clover e a escolha do instalador. Mas após carregar “aquela logo “ da maçã, a tela fica branca por alguns segundos e a logo da maçã é carregada novamente.

Após este processo eu seleciono o Disk Utility e só aparece o meu pendrive de instalação de 16gb é uma partição chamada instalação base de 2gb. O meu há não é reconhecido. Porém ao instalar o Sierra o meu HD é reconhecido normalmente.

Eu procurei no Google e não achei solução é por isso vim aqui pedir ajuda a vocês .

#2
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

Esta usando o driver apfs.efi na pasta correta?

 

Lembrando que o instalador irá converter automaticamente em SSDs, mas em HDDs terá de fazer isso manualmente.



#3
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,031 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

vc certamente precisa do patch AHCI pro HighSierra

<dict>
				<key>Comment</key>
				<string>fix IO error for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
				<key>Replace</key>
				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>fix hotplug for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>
				<key>Replace</key>
				<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>
			</dict>


#4
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...

 

vc certamente precisa do patch AHCI pro HighSierra

<dict>
				<key>Comment</key>
				<string>fix IO error for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
				<key>Replace</key>
				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>fix hotplug for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>
				<key>Replace</key>
				<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>
			</dict>

Onde eu colo este texto ? No caso eu colei na config.plist do EFI do Instalador, mas ainda sim o meu hd não foi reconhecido. :(  Segue a imagem do disk Utility na hora da instalação em anexo.

 


Esta usando o driver apfs.efi na pasta correta?

 

Lembrando que o instalador irá converter automaticamente em SSDs, mas em HDDs terá de fazer isso manualmente.

Onde este drive se localiza ? 


Como o meu pc é antigo e eu, ao usar um program que cria pendrive bootável, optei por usar legacy boot, o meu arquivo apfs.efi está na pasta drivers64.



#5
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

Coloca o patch que o Maldon falou no seu config.plist > KernelAndKextPatches > KextsToPatch



#6
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...

Coloca o patch que o Maldon falou no seu config.plist > KernelAndKextPatches > KextsToPatch


Eu substitui o texto da minha config.plist pelo texto do Maldonado no local onde voc falou.

Porém depois de formatar o hd e iniciar a instalação, a primeira etapa durou apenas 3 minutos. Mas na hora de reiniciar e concluir a instalação eu apertei em hfs é simplesmente deu aquela tela com círculo branco cortado. Rsrs

Você sabe o que poderia ser ?

Eu desativei os gráficos da Nvidia ....

Conforme falei eu formatei o jé em hfs+.

#7
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

Dá boot com -v, e veja onde está parando.



#8
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...

Dá boot com -v, e veja onde está parando.

Desculpe-me pela demora.

Parou com a seguinte frase: Apple USB Host Resources assumindo sucessful Wake Units 10 sleepunits 0 e com outra frase AHCI queue manager set PowerShare 0x8593b417ecf83c9 Attached File  E22BF849-ADDB-4A81-B08B-6A143294F14F.jpeg   172.62KB   0 downloadsAttached File  E22BF849-ADDB-4A81-B08B-6A143294F14F.jpeg   172.62KB   0 downloads

#9
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

Você está usando algum DSDT/SSDT modificado? Ou algum patch na seção ACPI?



#10
NelsonF

NelsonF

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Male
  • Location:Nagano Province - Japan
  • Interests:Movies and of corse Hackintoshes.

Best Answer

Pelo que vi vc está instalando numa placa-mãe lga775 c/ HDD, correto? Pela minha experiência c/a LGA775, mesmo que no HD vc já tenha instalado o Sierra, e agora está tentando instalar o HS, e, por alguma razão o instalador do HS refuga a instalação e aparece essa tela borrada. Vc precisa de um HD sem problemas, que eu não sei dizer qual problema é esse que faz o instalador parar nessa tela borrada. O que posso afirmar é que para em “steel waiting for root device”. Tbm tenho um pc c/ lga 775 e tive que usar vários HDs para concluir a instalação(6 para ser exato). C vc tiver outro(s) HDD(s), recomendo utilizá-lo(s) até que consiga prosseguir c/a instalação. Outra informação, nas lga775 o instalador do HS não reconhece SSD. Pra instalar em SSD, só c/ clonagem! Boa sorte!

vc certamente precisa do patch AHCI pro HighSierra

<dict>				<key>Comment</key>				<string>fix IO error for 10.13, credit SunKi</string>				<key>MatchOS</key>				<string>10.13.x</string>				<key>Disabled</key>				<false/>				<key>Name</key>				<string>AppleAHCIPort</string>				<key>Find</key>				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>				<key>Replace</key>				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>			</dict>			<dict>				<key>Comment</key>				<string>fix hotplug for 10.13, credit SunKi</string>				<key>MatchOS</key>				<string>10.13.x</string>				<key>Disabled</key>				<false/>				<key>Name</key>				<string>AppleAHCIPort</string>				<key>Find</key>				<data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>				<key>Replace</key>				<data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>			</dict>
MaLdOn, esse patch é pra aplicar em que parte do config.plist?kernel and kext patch? RTvariables?

#11
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...
Não estou usando Dsdt e nenhum outro patch.

Sobre a dica do rapaz ela fez todo o sentido, pois eu peguei um hd defeituoso de 500gb e ele fez todo o procedimento correto, mas no próprio instalador já dizia que não iniciaria por defeito. No hd de 160gb não houve aquele tempo de instalação normal de sempre.

Eu vou criar um pendrive do Sierra primeiro para depois instalar o High no meu hd de 500gb principal. Aí dou a resposta.

Eu quero só testar porque o Sierra tá estável e já teve até atualização de segurança e, portanto, acredito ser melhor para o dia a dia.

#12
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...

Eu quero agradecer à todos pela ajuda! 

O problema estava no meu HD e no criador de pendrive bootável. Felizmente ambos forma solucionados (usei hd compatível) e o desenvolvedor do aplicativo disponibilizou uma atualização. 

p.s.: achei a instalação extremamente chata (muitas reinicializações) e demorada! rsrs. Achei até que a instalação não tinha dado certo .... srsr



#13
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

p.s.: achei a instalação extremamente chata (muitas reinicializações) e demorada! rsrs. Achei até que a instalação não tinha dado certo .... srsr

É por esse e outros motivos que ainda estou no El Cap  :P



#14
manoteiba

manoteiba

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Vespasiano - Minas Gerais - Brazil
  • Interests:Interesso por Sistemas Operacionais e Etc...

É por esse e outros motivos que ainda estou no El Cap  :P

KKKKK Já vi que 'bobo é nós' iniciantes em querer novidades srsr. Mas brincadeiras à parte, o Sierra tá muito estável além de ter recursos que valem a pena a troca.

Infelizmente eu fui muito cabaço em atualizar o meu iPhone para o iOS 11.1 ... srsrs Por isso,  se eu quiser ter uma experiência legal de sinergia entre iOS e macOS terei que ficar com o High Sierra definitivamente por causa dos aplicativos principais. 







3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy