Jump to content

os x not showing in bootable usb/clover !


  • Please log in to reply
8 replies to this topic

#1
uvghost

uvghost

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 6 posts

Hello Everyone , I am new to MAc OS thing ,,,dont have any working Mac based machine, So I will use my pc for making bootable mac installer...

 

here what i did , I downloaded Mac OS high sierra from somewhere , then after little bit google i came here and used "BDU_v2.1.2016.020b"

 

So First I extracted hfs from .dmg

then used option "format disk" it formatted usb in 2 partition after finished i click on second partition and used option "restore partiotn" and selected that hfs file created by me earlier .

 

THEN i use this guide for making my botable to work with CPU (link) and used his another guide for proper settings in BIOS (LINK1)(LINK2) as i own Asus Board !!

 

now when i boot..it didn't shows mac os x installer in clover(see attachment pic)....

 

 

Please HELP ME!!!

Attached Files



#2
Morpheus NS

Morpheus NS

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Novi Sad, Serbia

Do you have HFSPlus.efi in Clover's EFI/EFI/Clover/drivers64UEFI (or drivers64 if you have BIOS)? It seems to me that your Clover is installed properly on USB but it doesn't see HFS partition on USB... it needs a driver for that.

 

Attached File  HFSPlus.efi.zip   14.91KB   1 downloads



#3
uvghost

uvghost

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 6 posts

Do you have HFSPlus.efi in Clover's EFI/EFI/Clover/drivers64UEFI (or drivers64 if you have BIOS)? It seems to me that your Clover is installed properly on USB but it doesn't see HFS partition on USB... it needs a driver for that.

 

attachicon.gifHFSPlus.efi.zip

hi , thanks for reply !! do i also ned to rename it to "HFSPlus-64.efi" ? as every driver in "drivers64UEFI" folder name like that ...



#4
Morpheus NS

Morpheus NS

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Novi Sad, Serbia

There's no need, it works fine without renaming. Just remove VBoxHFS-64.efi if you have it in the same folder.



#5
uvghost

uvghost

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 6 posts

There's no need, it works fine without renaming. Just remove VBoxHFS-64.efi if you have it in the same folder.

no luck for me..can you share your efi folder...which working and can see hfs partition...

 

edit: what the use of "EFI\CLOVER\drivers-Off\drivers64UEFI" ?



#6
Morpheus NS

Morpheus NS

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Novi Sad, Serbia

Here you go: https://www.sendspace.com/file/k92tc6

 

Use it only as an example of what you need to have. It won't work on your machine because it is made for High Sierra and my motherboard is different (among other things).

 

Basically:

- you need FakeSMC.kext and (possibly) NullCPUPowerManagement.kext in Clover/kexts/10.12

- you also need your ethernet kext and maybe USBInjectAll.kext in the same folder

- you need to replace VBoxHFS-64.efi with HFSPlus.efi

- you need OsxAptioFix2Drv-64.efi (or OsxAptioFixDrv-64.efi, but I always use v2)

- you need to edit your config.plist and add FakeCPUID for your CPU, it looks like this:

<key>KernelAndKextPatches</key>
    <dict>
        <key>FakeCPUID</key>
        <string>0x0506E3</string>

You should be able to reach the installer using these files and settings.

 

EDIT: drivers-Off? I have never seen anything like that. I guess those are inactive/disabled drivers (simply because of the name). 

 

You can also see my clover installation screen:

 

Attached File  Screen Shot 2017-10-21 at 1.57.35 PM.png   140.94KB   0 downloads

 

Perhaps you should try reinstalling clover on your USB with these settings just to be sure.


EDIT2: When you reach clover screen (the one from your screenshot, with disks), press O on your keyboard, go to "Binaries Patching" and UNCHECK AppleIntelCPUPowerManagement Patch, CHECK Kernel PM Patch and AppleRTC Patch.

 

IF you did everything right with BootDiskUtility (I have really never used it, so I cannot help with that), these two posts should get you going.

 

EDIT3: Make sure that your BooterConfig and CSRActiveConfig look like this in config.plist:

<key>RtVariables</key>
    <dict>
        <key>BooterConfig</key>
        <string>0x28</string>
        <key>CsrActiveConfig</key>
        <string>0x67</string>
    </dict>


#7
uvghost

uvghost

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 6 posts

 

btw i am also trying to install "high Sierra" v 10.13 ..first i am thinking maybe the BDU not ready for sierra ? ..

 

I also got "apfs.efi" in your driver folder which is missing if we use bdu .... and one more thing..how you made bootable usb ? 



#8
Morpheus NS

Morpheus NS

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Novi Sad, Serbia

I guess it's not ready since the latest version I found is 2.1.2016... I created my USB from Sierra with createinstallmedia method. I was never comfortable with creating USB on Windows. The last time I had to use Windows for that, I made a virtual machine and used pre-made .vmdk image of macOS Sierra, then created USB installer from this virtual machine.

 

apfs.efi is needed if you want to use Apple'snew file system, if you want to stay with HFS+ you are good to go with only HFSPlus.efi.



#9
uvghost

uvghost

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 6 posts

 I made a virtual machine and used pre-made .vmdk image of macOS Sierra, then created USB installer from this virtual machine.

 

 

 

hi , I also downloaded "macOS High Sierra Final by Tec*sview*r" but in vmware it reboot after apple logo loaded around 10% ....will try other thing you mention in PM and report you back..







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy