Jump to content

Clover deshabilita teclado y mouse al ingresar a linux mint 18

- - - - - linux mint clover teclado mouse raton

  • Please log in to reply
4 replies to this topic

#1
goncen

goncen

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Hola.

acabo de instalar linux mint 18 en una particion parte en un cuarto disco duro.

Tengo windows 19 en un disco, sierra y una particion de resccate de sierra en otro, un disco dedicado a datos y documentos y el cuarto esta dividido en dos la primera particion para juegos y la segunda instale linux.

 

clover me detecta la particion de linux sin problemas paero cuando ingreso a ella atravez de clover el teclado y el raton no responder, como si estuvieran desconectados.

 

prove arracar directamente desde el disco duro donde el grub2 en vez del clover y detecta el teclado y el raton, asi que la instalacion de linux esta bien.

 

tambien trate desde el clover configurator añadir un par de entradas personalizadas en el GUI por medio de legacy (esta en mbr la instalacion de linux) pero no aparacen dichas entradas personalizadas

dejo la imagen de el clover configurator

 

ZgEPWSA.png

 

y tambien mi config.plist

para saber que estoy haciendo mal

Attached Files



#2
Maniac10

Maniac10

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,978 posts
  • Gender:Not Telling

para saber porque no funcionan tus custom legacy necesitas ver un boot.log. Sube uno y te cuento que falla.

 

Por lo del teclado y mouse, has probado activando/desactivando el "FixOwnership"? No mencionas que motherboard usas, pero quizás no tienes activado el Legacy USB en la bios?



#3
goncen

goncen

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

para saber porque no funcionan tus custom legacy necesitas ver un boot.log. Sube uno y te cuento que falla.

 

Por lo del teclado y mouse, has probado activando/desactivando el "FixOwnership"? No mencionas que motherboard usas, pero quizás no tienes activado el Legacy USB en la bios?

la motherboard es una ASRock H61M-VG3

esta activado el FixOwnership

añadi el bootlog



#4
goncen

goncen

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

olvide el bootlog

0:100  0:100  MemLog inited, TSC freq: 3092976680
0:100  0:000  LegacyRegion2: Chipset/proc: 0x01008086
0:100  0:000   Next Generation Core processors (PAM 0x80-0x86)
0:100  0:000   Test PAM1=(0x41=90, 0x5a=00, 0x81=11, 0x91=00) at chipset 01008086
0:100  0:000  , Install = Success
0:110  0:010  BiosVideoDriverBindingStart!
0:110  0:000  BiosVideoCheckForVbe
0:110  0:000  EdidOverride not found
0:159  0:049   Edid1-
0:209  0:049   Edid0-
0:246  0:037     0 640x480 attr=3BF - ok, 640x480, working, highest, pref=0
0:247  0:001     1 800x600 attr=3BF - ok, 800x600, working, highest, pref=1
0:248  0:001     2 1024x768 attr=3BF - ok, 1024x768, working, highest, pref=2
0:249  0:001     3 1280x1024 attr=3BF - ok
0:257  0:007     4 1600x1200 attr=3BF - ok
0:257  0:000  BV new mode: 2 1024x768
0:434  0:176   SetMode pref 2 (2) = Success
2:594  2:160  
2:594  0:000  Now is 19.10.2017,  14:49:56 (GMT)
2:594  0:000  Starting Clover revision: 4061 on CLOVER EFI
2:594  0:000  Build with: [Args: -D NO_GRUB_DRIVERS_EMBEDDED | -D NO_GRUB_DRIVERS_EMBEDDED -D USE_LOW_EBDA -a X64 -b RELEASE -t XCODE5 -n 5 | OS: 10.12.4 | XCODE: 8.2.1]
2:594  0:000  SelfDevicePath=PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)\HD(1,GPT,39F6FC28-738E-43FB-8F27-6101C307CA4E,0x28,0x64000) @DD401798
2:594  0:000  SelfDirPath = \EFI\CLOVER
2:594  0:000  === [ Get Smbios ] ========================================
2:594  0:000  Type 16 Index = 0
2:594  0:000  Total Memory Slots Count = 2
2:594  0:000  Type 17 Index = 0
2:594  0:000  SmbiosTable.Type17->Speed = 1067MHz
2:594  0:000  SmbiosTable.Type17->Size = 4096MB
2:594  0:000  SmbiosTable.Type17->Bank/Device = BANK 0 ChannelA-DIMM0
2:594  0:000  SmbiosTable.Type17->Vendor = 04CB
2:594  0:000  SmbiosTable.Type17->SerialNumber = 00007E21
2:594  0:000  SmbiosTable.Type17->PartNumber =                   
2:594  0:000  Type 17 Index = 1
2:594  0:000  SmbiosTable.Type17->Speed = 1067MHz
2:594  0:000  SmbiosTable.Type17->Size = 4096MB
2:594  0:000  SmbiosTable.Type17->Bank/Device = BANK 2 ChannelB-DIMM0
2:594  0:000  SmbiosTable.Type17->Vendor = 0000
2:594  0:000  SmbiosTable.Type17->SerialNumber = 00000000
2:594  0:000  SmbiosTable.Type17->PartNumber = RUD304GD1333C915
2:594  0:000  Boot status=0
2:594  0:000  Running on: 'To Be Filled By O.E.M.' with board 'H61M-VG3'
2:594  0:000  === [ GetCPUProperties ] ==================================
2:594  0:000  CPU Vendor = 756E6547 Model=206A7
2:594  0:000   The CPU supported SSE4.1
2:594  0:000  The CPU not supported turbo
2:594  0:000  BrandString = Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz
2:594  0:000  MSR 0xE2 before patch 1E008400
2:594  0:000  MSR 0xE2 is locked, PM patches will be turned on
2:594  0:000  MSR 0xCE              00001000_60011F00
2:594  0:000  MSR 0x1A0             00850089
2:594  0:000  corrected FLEX_RATIO = 0
2:594  0:000  MSR 0x1B0             00000000
2:594  0:000  FSBFrequency = 100 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz
2:594  0:000  MaxDiv/MinDiv: 31.0/16
2:594  0:000  Turbo: 31/31/31/31
2:594  0:000  Features: 0xBFEBFBFF
2:594  0:000  Threads: 4
2:594  0:000  Cores: 2
2:594  0:000  FSB: 25 MHz
2:594  0:000  CPU: 3100 MHz
2:594  0:000  TSC: 3100 MHz
2:594  0:000  PIS: 100 MHz
2:594  0:000  === [ GetDevices ] ========================================
2:594  0:000  PCI (00|00:00.00) : 8086 0100 class=060000
2:594  0:000  PCI (00|00:01.00) : 8086 0101 class=060400
2:594  0:000  PCI (00|01:00.00) : 10DE 0FC8 class=030000
2:594  0:000   - GFX: Model=Gigabyte GeForce GT 740 family E7 (Nvidia)
2:594  0:000  PCI (00|01:00.01) : 10DE 0E1B class=040300
2:594  0:000   - HDMI Audio: 
2:595  0:000  PCI (00|00:16.00) : 8086 1C3A class=078000
2:595  0:000  PCI (00|00:1A.00) : 8086 1C2D class=0C0320
2:595  0:000  PCI (00|00:1B.00) : 8086 1C20 class=040300
2:595  0:000  PCI (00|00:1C.00) : 8086 1C10 class=060400
2:595  0:000  PCI (00|00:1C.03) : 8086 1C16 class=060400
2:595  0:000  PCI (00|03:00.00) : 10EC 8168 class=020000
2:595  0:000   - LAN: 0 Vendor=Realtek
2:595  0:000  PCI (00|00:1D.00) : 8086 1C26 class=0C0320
2:595  0:000  PCI (00|00:1F.00) : 8086 1C5C class=060100
2:595  0:000  PCI (00|00:1F.02) : 8086 1C02 class=010601
2:595  0:000  PCI (00|00:1F.03) : 8086 1C22 class=0C0500
2:595  0:000  === [ GetDefaultSettings ] ================================
2:595  0:000  Clover load options size = 0 bytes
2:611  0:016  EFI\CLOVER\config.plist loaded: Success
2:611  0:000  === [ GetListOfThemes ] ===================================
2:613  0:001  - [00]: BGM
2:634  0:021  - [01]: bootcamp
2:642  0:007  - [02]: embedded
2:642  0:000  - [02]: metal
2:651  0:008  - [03]: random
2:651  0:000  - [03]: BGM256
2:670  0:019  === [ Found config plists ] ===============================
2:670  0:000  - config.plist
2:670  0:000  === [ GetEarlyUserSettings ] ==============================
2:670  0:000  timeout set to 5
2:670  0:000  Custom boot CUSTOM_BOOT_DISABLED (0x0)
2:670  0:000  Default theme: bootcamp
2:670  0:000  === [ LoadDrivers ] =======================================
2:674  0:004  Loading AppleImageCodec-64.efi  status=Success
2:674  0:000  Loading AppleKeyAggregator-64.efi  status=Success
2:675  0:000  Loading AppleUITheme-64.efi  status=Success
2:675  0:000  Loading FirmwareVolume-64.efi  status=Success
2:675  0:000  Loading FSInject-64.efi  status=Success
2:675  0:000  Loading GrubEXFAT-64.efi  status=Success
2:675  0:000   - driver needs connecting
2:675  0:000  Loading GrubISO9660-64.efi  status=Success
2:676  0:000   - driver needs connecting
2:676  0:000  Loading GrubNTFS-64.efi  status=Success
2:677  0:000   - driver needs connecting
2:677  0:000  Loading GrubUDF-64.efi  status=Success
2:677  0:000   - driver needs connecting
2:677  0:000  Loading NvmExpressDxe-64.efi  status=Success
2:677  0:000   - driver needs connecting
2:677  0:000  Loading Ps2MouseDxe-64.efi  status=Success
2:677  0:000   - driver needs connecting
2:677  0:000  Loading SMCHelper-64.efi  status=Success
2:677  0:000  Loading UsbMouseDxe-64.efi  status=Success
2:678  0:000   - driver needs connecting
2:678  0:000  Loading VBoxExt2-64.efi  status=Success
2:678  0:000   - driver needs connecting
2:678  0:000  Loading VBoxExt4-64.efi  status=Success
2:678  0:000   - driver needs connecting
2:678  0:000  Loading VBoxIso9600-64.efi  status=Success
2:678  0:000   - driver needs connecting
2:678  0:000  Loading XhciDxe-64.efi  status=Success
2:678  0:000   - driver needs connecting
2:678  0:000  11 drivers needs connecting ...
2:678  0:000  PlatformDriverOverrideProtocol->GetDriver overriden
2:988  0:309  === [ InitScreen ] ========================================
2:988  0:000  SetScreenResolution: 1280x1024 - setting Mode 3
2:988  0:000  BV new mode: 3 1280x1024
3:210  0:222  Video mode change to mode #3: Success
3:268  0:057  Console modes reported: 4, available modes:
3:268  0:000   - [01]: 80x25
3:268  0:000   - [02]: 80x50
3:268  0:000   - [03]: 100x31
3:268  0:000   - [04]: 160x53 (current mode)
3:268  0:000  SetScreenResolution: 1280x1024 - already set
3:268  0:000  reinit: self device path=PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)\HD(1,GPT,39F6FC28-738E-43FB-8F27-6101C307CA4E,0x28,0x64000)
3:268  0:000  Using embedded font: Success
3:269  0:000  === [ GetMacAddress ] =====================================
3:269  0:000   get legacy LAN MAC, 1 card found
3:269  0:000  Legacy MAC address of LAN #0= D0:50:99:28:50:E8:
3:269  0:000  === [ ScanSPD ] ===========================================
3:270  0:000  SMBus device : 8086 1C22 class=0C0500 status=Success
3:270  0:000  SMBus CmdReg: 0x3
3:270  0:000  Scanning SMBus [8086:1C22], mmio: 0xF7105004, ioport: 0xF000, hostc: 0x1
3:270  0:000  Slots to scan [8]...
3:270  0:000  SPD[0]: Type 11 @0x50
3:288  0:018  DDR speed 1333MHz
3:288  0:000  Slot: 0 Type 24 4096MB 1333MHz Vendor=A-DATA Technology PartNo= SerialNo=00000000070E0201
3:289  0:000  SPD[2]: Type 11 @0x52
3:306  0:017  DDR speed 1333MHz
3:306  0:000  Slot: 2 Type 24 4096MB 1333MHz Vendor=NoName PartNo=RUD304GD1333C915 SerialNo=0000000000000000
3:307  0:000  === [ GetAcpiTablesList ] =================================
3:310  0:003  Get Acpi Tables List from RSDT:
3:310  0:000   - [00]: FACP  A M I len=132
3:310  0:000   - [01]: APIC  A M I len=114
3:310  0:000   - [02]: FPDT  A M I len=68
3:310  0:000   - [03]: MCFG  A M I len=60
3:310  0:000   - [04]: SSDT  AoacTabl len=2017
3:310  0:000   - [05]: AAFT  OEMAAFT  len=234
3:310  0:000   - [06]: HPET  A M I len=56
3:310  0:000   - [07]: SSDT  SataTabl len=877
3:310  0:000   - [08]: SSDT  CpuPm len=2706
3:310  0:000   - [09]: BGRT  A M I len=56
3:310  0:000  Calibrated TSC frequency =3092976680 =3092MHz
3:310  0:000  === [ GetUserSettings ] ===================================
3:310  0:000  USB FixOwnership: yes
3:310  0:000  Dropping 3 tables:
3:310  0:000   - [00]: Drop table  signature="SSDT" (54445353) table-id="CpuPm" (0000006D50757043)
3:310  0:000           - set table: 54445353,       6D50757043 to drop: yes
3:310  0:000   - [01]: Drop table  signature="DMAR" (52414D44)
3:310  0:000           - set table: 52414D44,                0 to drop: no
3:310  0:000   - [02]: Drop table  signature="SSDT" (54445353) table-id="Cpu0Ist" (0074734930757043)
3:310  0:000           - set table: 54445353,   74734930757043 to drop: no
3:310  0:000   - final DSDT Fix mask=1FE6F9D7
3:310  0:000  ChassisType: 0xD
3:311  0:000  === [ ScanVolumes ] =======================================
3:311  0:000  Found 17 volumes with blockIO
3:311  0:000  - [00]: Volume: PcieRoot(0x0)\Pci(0x1A,0x0)\USB(0x0,0x0)\USB(0x0,0x0)
3:311  0:000          USB volume
3:311  0:000          USB volume
3:311  0:000  - [01]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)
3:311  0:000          Result of bootcode detection: bootable Linux (grub,linux)
3:311  0:000  - [02]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0)
3:311  0:000  - [03]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)
3:311  0:000          Result of bootcode detection: bootable unknown (legacy)
3:311  0:000  - [04]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)
3:311  0:000          Result of bootcode detection: bootable Linux (grub,linux)
3:311  0:000  - [05]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,MBR,0x35AF6430,0x800,0xFA000)
3:331  0:019          Result of bootcode detection: bootable Windows (vista,win)
3:332  0:001  - [06]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,MBR,0x35AF6430,0xFA800,0x30B5B9F1)
3:333  0:000          Result of bootcode detection: bootable Windows (vista,win)
3:333  0:000  - [07]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,MBR,0x35AF6430,0x30C56800,0xE9800)
3:333  0:000          Result of bootcode detection: bootable Windows (vista,win)
3:334  0:000  - [08]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(4,MBR,0x35AF6430,0x30D40800,0x9644800)
3:334  0:000          Result of bootcode detection: bootable Windows (vista,win)
3:335  0:000  - [09]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0)\HD(1,GPT,915604C4-53A6-4794-A048-598EC9595BCE,0x800,0x4A857800)
3:335  0:000          Result of bootcode detection: bootable unknown (legacy)
3:417  0:082  - [10]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)\HD(1,GPT,39F6FC28-738E-43FB-8F27-6101C307CA4E,0x28,0x64000)
3:417  0:000          Result of bootcode detection: bootable Clover (clover)
3:418  0:000          This is SelfVolume !!
3:418  0:000  - [11]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)\HD(2,GPT,3CB878E6-FCE6-4AA3-AEE2-673172642655,0x64800,0x19876FC8)
3:425  0:007  - [12]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x4,0x0,0x0)\HD(3,GPT,9EEE2DDB-9D9B-4BC6-A0F5-5F7918F36700,0x1991B7C8,0x386A180)
3:425  0:000  - [13]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(1,MBR,0x953C6B80,0x1F47FE,0xBB5C8802)
3:425  0:000          Result of bootcode detection: bootable unknown (legacy)
3:425  0:000  - [14]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(2,MBR,0x953C6B80,0xBB7BD000,0x2D292000)
3:425  0:000          Result of bootcode detection: bootable Linux (grub,linux)
3:425  0:000  - [15]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(3,MBR,0x953C6B80,0xE8A4F000,0x3B9800)
3:425  0:000  - [16]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(1,MBR,0x953C6B80,0x1F47FE,0xBB5C8802)\HD(1,MBR,0x00000000,0x1F4800,0xBB5C8800)
3:426  0:000          Result of bootcode detection: bootable unknown (legacy)
3:736  0:310  PutNvramPlistToRtVars: nvram.plist not found
3:736  0:000  === [ InitTheme ] =========================================
3:736  0:000  Using theme 'bootcamp' (EFI\CLOVER\themes\bootcamp)
3:736  0:000  Warning! Character width 9 should be even!
3:736  0:000  Loading font from ThemeDir: Error
3:737  0:000  Choosing theme bootcamp
3:737  0:000  after NVRAM boot-args=dart=0 npci=0x2000 kext-dev-mode=1 rootless=0
3:737  0:000  === [ Dump SMC keys from NVRAM ] ==========================
3:737  0:000  found AppleSMC protocol
3:737  0:000  === [ ScanLoader ] ========================================
3:737  0:000  - [05]: 'Reservado para el sistema'
3:803  0:065  - [06]: 'Windows'
3:832  0:028  - [07]: ''
3:882  0:049  - [08]: 'backwin'
3:930  0:048  - [09]: 'Ismael'
6:814  2:883  - [10]: 'EFI'
6:837  0:023  - [11]: 'MacOsX'
6:884  0:046          AddLoaderEntry for Volume Name=MacOsX
6:911  0:027      Check if volume Is Hibernated:
6:911  0:000      Check sleep image 'by signature':
6:957  0:046      using default sleep image name = \private\var\vm\sleepimage
6:986  0:028      sleepimage not found -> Not Found
6:986  0:000      hibernated: no - sign
6:993  0:007  - [12]: 'Sierra'
7:037  0:043          AddLoaderEntry for Volume Name=Sierra
7:061  0:024      Check if volume Is Hibernated:
7:061  0:000      Check sleep image 'by signature':
7:104  0:042      using default sleep image name = \private\var\vm\sleepimage
7:113  0:008      sleepimage not found -> Not Found
7:113  0:000      hibernated: no - sign
7:119  0:006  - [14]: 'Linux'
7:125  0:005  - [16]: 'Ismael2'
7:578  0:453  === [ AddCustomLegacy ] ===================================
7:578  0:000  Custom legacy 0 skipped because it is hidden.
7:578  0:000  Custom legacy 1 skipped because it is hidden.
7:578  0:000  Scanning legacy ...
7:578  0:000   1: 'Whole Disc Boot' (grub,linux) hidden
7:578  0:000   4: 'Whole Disc Boot' (grub,linux) hidden
7:578  0:000   5: 'Reservado para el sistema' (vista,win) add legacy
7:579  0:000   added 'Boot Windows from Reservado para el sistema' OSType=2 Icon=vista,win
7:579  0:000   6: 'Windows' (vista,win) add legacy
7:579  0:000   added 'Boot Windows from Windows' OSType=2 Icon=vista,win
7:579  0:000   7: '' (vista,win) add legacy
7:580  0:000   added 'Boot Windows from ' OSType=2 Icon=vista,win
7:580  0:000   8: 'backwin' (vista,win) add legacy
7:580  0:000   added 'Boot Windows from backwin' OSType=2 Icon=vista,win
7:580  0:000  10: 'EFI' (clover) add legacy
7:581  0:000   added 'Boot Clover from EFI' OSType=3 Icon=clover
7:581  0:000  14: 'Linux' (grub,linux) add legacy
7:582  0:000   added 'Boot Linux from Linux' OSType=0 Icon=grub,linux
7:582  0:000  === [ AddCustomTool ] =====================================
7:583  0:000  === [ GetEfiBootDeviceFromNvram ] =========================
7:583  0:000  Default boot entry not found
7:583  0:000  DefaultIndex=-1 and MainMenu.EntryCount=12
7:734  0:151  GUI ready
15:245  7:510  BootVariable of the entry is empty
15:245  0:000  === [ StartLoader ] =======================================
15:245  0:000  Finally: Bus=99773kHz CPU=3093MHz
15:245  0:000  Loading boot.efi  status=Success
15:357  0:111  GetOSVersion: 10.12.6 (16G29)
15:357  0:000  CSR_CFG: CSR_ALLOW_UNTRUSTED_KEXTS | CSR_ALLOW_UNRESTRICTED_FS | CSR_ALLOW_TASK_FOR_PID | CSR_ALLOW_UNRESTRICTED_DTRACE | CSR_ALLOW_UNRESTRICTED_NVRAM
15:357  0:000  === [ PatchSmbios ] =======================================
15:357  0:000  insert table 9 for dev 0:0
15:357  0:000  insert table 9 for dev 0:1
15:357  0:000  insert table 9 for dev 0:0
15:357  0:000  Detected alternating SMBIOS channel banks
15:357  0:000  Channels: 2
15:357  0:000  Interleave: 0 2 1 3 4 6 5 7 8 10 9 11 12 14 13 15 16 18 17 19 20 22 21 23
15:357  0:000  SMBIOS Type 17 Index = 0 => 0 0:
15:357  0:000  BANK 0 DIMM0 1333MHz 4096MB
15:357  0:000  SMBIOS Type 17 Index = 1 => 1 2:
15:357  0:000  BANK 1 DIMM0 1333MHz 4096MB
15:357  0:000  mTotalSystemMemory = 8192
15:357  0:000  NumberOfMemoryDevices = 2
15:357  0:000  Type20[0]->End = 0x3FFFFF, Type17[0] = 0x1000
15:357  0:000  Type20[1]->End = 0x7FFFFF, Type17[1] = 0x3000
15:357  0:000  Table 131 is present, CPUType=31
15:357  0:000  Change to: 903
15:357  0:000  === [ PatchACPI ] =========================================
15:357  0:000  RSDT 0xDE93D028
15:357  0:000  FADT from RSDT: 0xDE93D100
15:357  0:000  XSDT 0xDE93D078
15:357  0:000  FADT from XSDT: 0xDE946388
15:357  0:000  Xsdt reallocation done
15:357  0:000  old FADT length=10C
15:357  0:000  Found OperationRegion(GNVS, SystemMemory, DE948E18, ...)
15:357  0:000  Found OperationRegion(S4NV, SystemMemory, DE94AE98, ...)
15:357  0:000  Found OperationRegion(MCHT, SystemMemory, FED10000, ...)
15:357  0:000  Found OperationRegion(RCRB, SystemMemory, FED1C000, ...)
15:357  0:000  Found OperationRegion(CPSB, SystemMemory, DE824E18, ...)
15:357  0:000  Found OperationRegion(TMMB, SystemMemory, FED40000, ...)
15:357  0:000  Found OperationRegion(TVID, SystemMemory, FED40F00, ...)
15:357  0:000  Found OperationRegion(TPMR, SystemMemory, FED40000, ...)
15:357  0:000  Apply DsdtFixMask=0x1FE6F9D7
15:357  0:000     drop _DSM mask=0x0000
15:357  0:000  === [ FixBiosDsdt ] =======================================
15:357  0:000  VideoCard devID=0xFC810DE
15:357  0:000  DisplayADR1[0] = 0x10000, DisplayADR2[0] = 0x0
15:357  0:000  USBADR[0] = 0x1A0000 and PCIe = 0xFFFE
15:358  0:000  USBADR[1] = 0x1D0000 and PCIe = 0xFFFE
15:358  0:000  first CPU found at 6F69 offset 6F6C
15:358  0:000  score candidate at 6F65
15:358  0:000  score inserted in acpi_cpu_score _PR_
15:358  0:000  Found ACPI CPU: CPU0 | CPU1 | CPU2 | CPU3 | CPU4 | CPU5 | CPU6 | CPU7 , within the score: _PR_
15:358  0:000  Found PCIROOTUID = 0
15:358  0:000  Start RTC Fix
15:358  0:000  found RTC Length not match, Maybe will case CMOS reset will patch it.
15:358  0:000  found RTC had IRQNoFlag will move -3 bytes
15:358  0:000  ...len=9239
15:358  0:000  new size written to 2568 shift=0 len=9239
15:358  0:000  len after correct outers 9239
15:358  0:000  Start TMR Fix
15:358  0:000  Start PIC Fix
15:358  0:000  PIC size=A5 at 240C
15:358  0:000  found CRS at 2420 size 8D
15:358  0:000  found PIC had IRQNoFlag will move -3 bytes
15:358  0:000  Fix Device PIC size -3
15:358  0:000  Start HPET Fix
15:359  0:000  Start Display0 Fix
15:359  0:000  Found internal video device FFFF@3971, unusable
15:359  0:000  Creating Method(_DSM) for 10DE card
15:359  0:000  patch Display #0 of Vendor=0x10DE
15:359  0:000  Start NetWork Fix
15:359  0:000  have no Network device while NetworkADR2=0
15:359  0:000  NetworkADR1=1C0003 NetworkADR2=0
15:359  0:000  network DSM created, size=78
15:359  0:000  Start SBUS Fix PCI=12F8 len=9239
15:359  0:000  device (SBUS) found at 4D64
15:359  0:000  SBUS code size fix = 0x0000005D
15:359  0:000  patch HDEF in DSDT 
15:359  0:000  Start HDA Fix
15:359  0:000  found HDA device NAME(_ADR,0x001B0000) And Name is HDEF
15:359  0:000  NewName HDEF already present, renaming impossibble
15:360  0:000  Start HDMI7 Fix
15:360  0:000  have no HDMI device while HDMIADR2=1
15:360  0:000  HDMIADR1=10000 HDMIADR2=1
15:360  0:000    with default properties
15:360  0:000  Start USB Fix
15:360  0:000  USB bridge[1A0000] at 43F2, size = 3A0
15:360  0:000   found slave _DSM, skip
15:361  0:000  USB bridge[1D0000] at 3EB6, size = 53A
15:361  0:000   found slave _DSM, skip
15:361  0:000  Start _WAK Return Fix
15:361  0:000  _WAK Method find return data, don't need to patch.
15:361  0:000  return len=935E
15:361  0:000   deleting device CRT_
15:361  0:000   deleting device DVI_
15:361  0:000   deleting device SPKR
15:361  0:000   deleting device ECP_
15:361  0:000   deleting device LPT_
15:362  0:000   deleting device FDC0
15:362  0:000   deleting device ECP1
15:362  0:000   deleting device LPT1
15:362  0:000  Start PNLF Fix
15:362  0:000  found PWRB at 3BEB
15:362  0:000  Start _S3D Fix
15:363  0:000    indirect name=SRCB
15:363  0:000  Start ADP1 fix
15:363  0:000  no device(AC) exists
15:363  0:000  Start Darwin Fix
15:363  0:000  Name _OSI present at 0x78B, renaming to OOSI
15:363  0:000  Name _OSI present at 0x792, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7AE, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7CC, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7E8, renaming to OOSI
15:363  0:000  Name _OSI present at 0x804, renaming to OOSI
15:363  0:000  Name _OSI present at 0x1A5A, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7A2D, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7A34, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7A50, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7A70, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7A90, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7AAE, renaming to OOSI
15:363  0:000  Name _OSI present at 0x7ACA, renaming to OOSI
15:363  0:000  Start SHUTDOWN Fix len=9433
15:363  0:000  === [ ACPIDropTables ] ====================================
15:363  0:000  Drop tables from Xsdt, SIGN=SSDT TableID=CpuPm Length=2706
15:363  0:000   Xsdt has tables count=10
15:363  0:000   Table: SSDT  CpuPm  2706 dropped
15:363  0:000  === [ PatchAllSSDT ] ======================================
15:363  0:000  Patch table: SSDT  AoacTabl len=0x7E1
15:363  0:000  Patch table: SSDT  SataTabl len=0x36D
15:363  0:000  Drop tables from Xsdt, SIGN=XXXX TableID= Length=0
15:363  0:000   Xsdt has tables count=9
15:363  0:000  CPUBase=0 and ApicCPUBase=1 ApicCPUNum=4
15:363  0:000  Maximum control=0x1F
15:363  0:000  P-States: min 0x10, max 0x1F
15:363  0:000  SSDT with CPU P-States generated successfully
15:363  0:000  SSDT with CPU C-States generated successfully
15:363  0:000  === [ RestSetup macOS ] ===================================
15:363  0:000  EdidDiscovered size=0
15:363  0:000  NVidia GFX injection not set
15:363  0:000   detected codec: 10EC:0662
15:363  0:000  stringlength = 1504
15:363  0:000  CurrentMode: Width=1280 Height=1024
15:363  0:000  Beginning FSInjection
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: DD401498
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: DD401498
15:386  0:022  Use origin smbios table type 1 guid.
15:386  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
15:386  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.12
15:387  0:000    Extra kext: EFI\CLOVER\kexts\10.12\AppleHDADisabler.kext
15:387  0:000    Extra kext: EFI\CLOVER\kexts\10.12\FakeSMC.kext
15:391  0:003    Extra kext: EFI\CLOVER\kexts\10.12\IOAHCIBlockStorageInjector.kext
15:391  0:000    Extra kext: EFI\CLOVER\kexts\10.12\RealtekRTL8111.kext
15:404  0:012    Extra kext: EFI\CLOVER\kexts\10.12\VoodooHDA.kext
15:408  0:004  SetStartupDiskVolume:
15:408  0:000    * Volume: 'MacOsX'
15:408  0:000    * LoaderPath: '<null string>'
15:408  0:000    * DevPath: MacOsX
15:408  0:000    * GUID = 3CB878E6-FCE6-4AA3-AEE2-673172642655
15:408  0:000    * efi-boot-device: <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>3CB878E6-FCE6-4AA3-AEE2-673172642655</string></dict></dict></dict></array>
15:408  0:000  Custom boot is disabled



#5
Maniac10

Maniac10

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,978 posts
  • Gender:Not Telling

Hola goncen, tus entradas no funcionan porque esta mal el identificador de volumen de cada una. Debes usar el GUID, path o nombre adecuado para que lo pueda tomar Clover. El bootlog al final no sirve de mucho porque tus entradas custom están ocultas así que Clover las pasa de largo sin verificarlas :|:

7:578  0:453  === [ AddCustomLegacy ] ===================================
7:578  0:000  Custom legacy 0 skipped because it is hidden.
7:578  0:000  Custom legacy 1 skipped because it is hidden.

En tu custom legacy "Linux2" usas como identificador de volumen solamente "Linux", que da como resultado el ocultamiento de toda entrada que se llame Linux:

7:578  0:000   1: 'Whole Disc Boot' (grub,linux) hidden
7:578  0:000   4: 'Whole Disc Boot' (grub,linux) hidden

Y en "Linux1" usas "HD(1,MBR)" que supongo Clover ignora por estar incompleta ya que así apunta a toda partición n°1 de todo disco MBR. Debes poner el identificador completo, por ej: HD(1,MBR,0x35AF6430,0x800,0xFA000), quizá incluso funcione solo con HD(1,MBR,0x35AF6430).

 

 

Adivinando un poco, la entrada Linux1 parece apuntar al disco [01] que tiene 4 particiones:

3:311  0:000  - [01]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)
3:311  0:000          Result of bootcode detection: bootable Linux (grub,linux)

3:311  0:000  - [05]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(1,MBR,0x35AF6430,0x800,0xFA000)
3:331  0:019          Result of bootcode detection: bootable Windows (vista,win)
3:332  0:001  - [06]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(2,MBR,0x35AF6430,0xFA800,0x30B5B9F1)
3:333  0:000          Result of bootcode detection: bootable Windows (vista,win)
3:333  0:000  - [07]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(3,MBR,0x35AF6430,0x30C56800,0xE9800)
3:333  0:000          Result of bootcode detection: bootable Windows (vista,win)
3:334  0:000  - [08]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x0,0x0,0x0)\HD(4,MBR,0x35AF6430,0x30D40800,0x9644800)
3:334  0:000          Result of bootcode detection: bootable Windows (vista,win)

Este disco aparentemente tiene un loader de Linux en el MBR pero Clover lee las 4 particiones como de Windows¿?¿?. Si puedes hacer un reporte de discos de DarwinDumper te lo agradecería, con estos datos solos no se a que partición apuntar.

 

 

La entrada Linux2 asumo corresponde al disco [04] con 3 particiones (y una cuarta extraña con 2 identificadores, será una extendida?):

3:311  0:000  - [04]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)
3:311  0:000          Result of bootcode detection: bootable Linux (grub,linux)

3:425  0:000  - [13]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(1,MBR,0x953C6B80,0x1F47FE,0xBB5C8802)
3:425  0:000          Result of bootcode detection: bootable unknown (legacy)
3:425  0:000  - [14]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(2,MBR,0x953C6B80,0xBB7BD000,0x2D292000)
3:425  0:000          Result of bootcode detection: bootable Linux (grub,linux)
3:425  0:000  - [15]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(3,MBR,0x953C6B80,0xE8A4F000,0x3B9800)
3:425  0:000  - [16]: Volume: PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x5,0x0,0x0)\HD(1,MBR,0x953C6B80,0x1F47FE,0xBB5C8802)\HD(1,MBR,0x00000000,0x1F4800,0xBB5C8800)
3:426  0:000          Result of bootcode detection: bootable unknown (legacy)

Clover la detecta y añade automáticamente con el nombre "Boot Linux from Linux":

7:578  0:000  Scanning legacy ...
7:581  0:000  14: 'Linux' (grub,linux) add legacy
7:582  0:000   added 'Boot Linux from Linux' OSType=0 Icon=grub,linux

Quizá Clover añade la partición incorrecta y debería ser la 13 en lugar de la 14? No reconozco las particiones de Linux con este reporte solo. Esta entrada funciona? Al menos carga Grub?

 

 

Bueno, este es un análisis medio superficial, espero tu reporte de discos para ser mas específico.








1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy