Jump to content

AppleHDA Solution - Work in progress


  • This topic is locked This topic is locked
4109 replies to this topic

#161
nikjenikje

nikjenikje

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

I'll take a look. What kernel are you using?


im using semthex 10.4.8

#162
skippyretard

skippyretard

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
  • Gender:Male
  • Location:South Carolina
nikje, try this

<Link Removed> See post 174

#163
R3TR0

R3TR0

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
some bugs.
main mix (itunes play) goes to line-in (input indicator)

update: line-in (like mic-in too) don't work for me, only ugly noise from input
alc882 / ich7 /asus p5wd2 prem

Attached Files



#164
Renard45

Renard45

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 277 posts
some bugs for me too with the lastest ACL882 HAD v0.4b

no mic i can see the input indicators but no sound :D

#165
eightballbill

eightballbill

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
I can't reach the chat (xchat says it doesn't exist :-( )
anyway: Here is the linux dump in .txt

Attached Files



#166
R3TR0

R3TR0

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
maybe this may help?
Linux Source Code for ALC audio codec
This Source Code is from www.alsa-project.org

ftp://202.65.194.18/pc/audio/realtek-linu...k-4.05b.tar.bz2

sory, if useless

#167
mismamente

mismamente

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Skippyretard, you're the man!!
I have my ALC888 whith mic in! sound out ok, but also works mic, using the rear jack, not the front jack.
It's the only I've tried at the moment, but for me, it's a great step to have mic!!
(My mobo is the asrock 775dual-vsta)

#168
alicheusz

alicheusz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 316 posts
  • Gender:Male

check my post above, one has my kext and the other has my codec dump.

if you post your codec dump here I can help you make a kext for your board.

Can you edit your kext to math ALC880?

I post Linux dump earlier, I have ALC861 But is show everywhere as ALC880 I think that ALC880 will work for most ALC861 and all ALC880
http://forum.insanel...t...ost&id=6105

I try edit Info plist to math ICH6 and ALC880 with no luck

http://forum.insanel...o...;p=239343

I search binary with hex editor for 10ec0882 and 283904130 don't find nothing

I try compare Your kext with Turgas but this was to much for me, even binary part has different size, In your Info.plist files I see loots of entry that don't show earlier and I have no Idea what they do and why they are there

#169
slawek

slawek

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
want enable playback via analog out how to do this ? I have M/B conroexfire ALC888 (10ec_0888)

#170
Rene204

Rene204

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Germany

want enable playback via analog out how to do this ? I have M/B conroexfire ALC888 (10ec_0888)


Hi, sorry, had to go from IRC... but have a look to Post Nr. 165

Skippyretard have made a special Version for ALC888.
Download and install, in most cases, it should be working....

Rene

#171
skippyretard

skippyretard

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
  • Gender:Male
  • Location:South Carolina
the ALC888 kext above is for VIA chipset mobo's. someone will need to change the hdacontroller id and alcinject id to match ich7 or whatever.... that's the easy part. it is only setup for speaker out on rear green port and mic on rear pink port. I'm leaving town for 3 weeks and don't know if I'll have internet access. I'll add more if I can.... If not, then good luck and see you soon!

*EDIT* ok, here is ALC888 package. default will install for Intel ICH6, ICH7 or ICH8, custom install has option for VIA HDA install. DO NOT INSTALL BOTH. only one or the other....

now, I'm reeeaaaallllly leaving this time. bye.....


<KEXT REMOVED>

Edited by skippyretard, 22 December 2006 - 05:37 AM.


#172
eightballbill

eightballbill

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Great guide Taruga! I'm going to get this done by myself, i won't bother you anymore, thanks! :thumbsdown_anim:

#173
tokra128

tokra128

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
  • Gender:Male
well, common, nos sigmatel try so far ?

#174
biffyman53142

biffyman53142

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hey skippy,

I couldn't get the ALC883 version to work on my system. I tried installing it standalone, installing the package at the top of the thread, deleting AppleHDA and putting the 883 AppleHDA in its place and neither of them worked at all. I got no recognition that my computer had any inputs or outputs in System Preferences, but the ktexts did load correctly when doing a kextload on them. Also, nothing in the dmesg output.

I have attached the codec dump from my machine below. I hope you can help me :compress:

Thanks.

Attached Files



#175
schale01

schale01

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

Linux codec dumps helps me a lot to understand why things dont work on some cases.
You can use a live cd distro like Knoppix and then look inside /proc/asound
Somewhere there, will be a file named codec#0, do: cat codec#0 > /tmp/alc882d.txt
This will create a txt file with what I need in /tmp directory, then send it to me.


I will try to post a codec dump of the sigmatel 9223 after I download above liveCD.
Thanks for all your hard work!!!

#176
saGat

saGat

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
thanks for your great work !!!!!! :censored2:

i have now fully working osx on my new machine :]

EDIT

hmm :/

there is acually one problem, after installing patch my mouse have only left click :/ no scroll no additional buttons i don't know whats is going on. i have razer pro mouse with installed drivers any ideas ?

EDIT 2 ;D nevemind

repair permission + restart :]

#177
asapreta

asapreta

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 755 posts
Till version 0.2 the AppleAzaliaAudio.kext should be removed manually. Why this can't be done by the installer?

#178
tivimac

tivimac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Gender:Male
  • Location:Dominican Republic
TARUGA and others :idea:

this is an actual ALC880 Codec dump made with UBUNTU LIVE CD from my machine... Asus MOBO P5GD1-VM (Intel 915/ICH6 based). Hope that this help with the futher development of the ALC880 HDA KEXT.

Thanks.

Attached Files



#179
miscz

miscz

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Here's ALC660/861 codec dump (I'm not sure, in some places it's 660, other make me think it's 861). Hope this helps.

Attached Files



#180
sim71

sim71

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 305 posts
  • Gender:Male
  • Location:Florence
Hello to all!
I have a problem with my CMI9880 nothing audio! :)
Someone can help me!?

Thanks to all!

p.s.
i'm using 10.4.7 kernel 8.4.1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy