Jump to content

AppleHDA Solution - Work in progress


  • This topic is locked This topic is locked
4109 replies to this topic

#1061
adenoski

adenoski

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Reporting in.. firstly, much thanks to Taruga for all the work! :)

I used Ubuntu Dapper 6.06 as a LiveCD and got the codec#0 dump for my DELL XPS M1210.. bios reported the audio chipset as Sigmatel 9220, but the codec (attached below) dump found Sigmatel STAC 9221 A1. I used the 1.11 Patcher, watched it carefully, and it did everything.. no errors were reported from the patcher.

Rebooted the system, but unfortunately, no sound from any of the jacks nor the speakers on the laptop :star_smile:. Going back to the old AppleHDA.kext file that previously worked brought back sound again (but only on the first output jack). Still no sound coming from the speakers on the laptop.

I'll give the 1.12 patcher a try later and report back.



Attached File  sigmatel9221.txt   4.03KB   162 downloads

#1062
NemesisSheep

NemesisSheep

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Sitting right behind you...
Happy Day of Victory!!!

SigmeTel 9227 works. (STAC9227 codec) I used the 1.12 patcher and a codec dump acquired from Ubuntu 6.10 Live, patched using mifki kernel, reboot and now have audio.

Attached File  Input_shot.jpg   131.53KB   272 downloads

Attached File  Output_shot.jpg   104.16KB   174 downloads

Back Mic: 6 23 18 14
Speaker : 13 2

This was all that was detected when I ran the patcher.

I can adjust volume, but when I go below 40% it becomes completely in-audible, almost like the actual 0% sound is at 41% on the meter.

But that will get fixed eventually I assume. I'm just happy for sound.

Here is my codec dump to be added to the repository: Attached File  STAC9227_83847618.txt   5.48KB   812 downloads

#1063
pehy

pehy

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
So my Sony vaio SZ3 have sound now. :)
Thanks to Taruga.
I've a triple boot Windows/OSX/Linux.
I used v1.12 patcher and a codec dump acquired from Mandriva 2007.0 (core0)
Codec is stac7661.

- Microphone....Not tested.
- Headphones...Must be activated in System Pref/Sound/Output

Attached File  SonyVaioSZ3XPcodec0.txt   3.58KB   87 downloads

Edited by pehy, 06 February 2007 - 07:12 AM.


#1064
Zulu.Walker

Zulu.Walker

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
  • Interests:Film/TV Post-Production<br />Independent Films<br />Music<br />Literatur...
I was about to get a knoppix live cd when a friend of mine popped by with a openSUSE LiveDVD, finally got my codec dump. I was under the impression that I was doing everything right when the dumps I tried had a different subsytem and revision id, and weren't properly applied. Sorry Taruga :P I now see that the app responds accordingly by displaying the name of the dump it was fed with.

Anyway, now that I have my dump, I want to make multichannel work. Is it possible with the ALC883? Aggregate Devices under Audio MIDI Setup only shows Line-Out, Line-In and Mic enabled, how did you get 4 (or more) output channels? Edit the dump?

Attached File  Picture_2.png   32.92KB   89 downloads

My ultimate goal is 6 channels of discrete audio, if that's not possible maybe you can tell me now so I'd stop hoping? Or is it only by replacing my Audigy2 ZS with an M-Audio Revolution 7.1 will this be achieved? :rolleyes:

Oh and again, thanks for the v1.12 patcher! :D

ALC883 Codec Dump from GA-965P-S3 rev.1.0 (F8 BIOS):
Attached File  codec2.card0.txt   8.53KB   40 downloads

Edited by Zulu.Walker, 06 February 2007 - 07:27 AM.


#1065
Sazpaimon

Sazpaimon

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
Tried 1.12, still getting no sound with ALC883. Is there anything special I need to do with my kexts before doing this?

#1066
caracols

caracols

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
Vendor Id: 0x10ec0888
Subsystem Id: 0x18491e01
Revision Id: 0x100001

Patcher v.1.12, Devices shown but input or output not working.

#1067
claudio77

claudio77

    InsanelyMac Protégé

  • Validating
  • Pip
  • 7 posts
sorry, but v1.12 doesn't work with ad1986a yet. :rolleyes:

#1068
drimzy

drimzy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
why os x don't permit to drag and drop a file into applehdapatcher?

#1069
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom
ALC861 still not supported

One more patcher! We should start paying the man!

Keep up the fantastic work.

(I've tried v1.12... the patch works smoothly, but still there are no input or output devices in System Preferences :thumbsup_anim:... pity)

jjduro

#1070
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
ive tried to dump AC97 ADI1985 soundmax but there is only /proc/asound/ac97#0 and it doesnt want to "cat" a directory
does it has something to do with the fact ADI1985 cannot be handle by AppleHDA?
so if i compile the codec97#0 to a dump it gives me another text form, without the same information as the one i had with my sigmatel 9225...
thanx!

Edited by cyclonefr, 06 February 2007 - 10:52 AM.


#1071
kuntz

kuntz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
I have just dumped my AbitAT8's ALC882 codec (attached to this post) with the last patcher (1.2) audio work only in analog mode no spdif. The problem is if I change output option in audio config from analog to digital and after i change in analog the audio don't work again...

Very great job!!

Attached Files


Edited by kuntz, 06 February 2007 - 10:50 AM.


#1072
pRoFeSSiOnAl

pRoFeSSiOnAl

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
Hello Taruga :-) ...

with 1.12 I get this, but no sound:

Attached File  Bild.png   48.8KB   77 downloads

Christian :-) www.samoticha.com

#1073
solu

solu

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
AppleHDA Patcher - 2006/2007 Taruga v1.12			

* Patching AppleHDA.kext to 0x11d41981				Done
* Checking AppleHDA for patch						Done
0001f2c4	cmpl	$0x11d41981,%eax
000203d0	cmpl	$0x11d41981,%eax
* Checking for SPDIF Out 							Not Detected
* Checking for SPDIF In							  Not Detected
* Creating AppleHDA configs
* Using the following nodes in pathmap

	Speaker  : 5 17 3

* Copying new config to destination					Done

This one doesn't work yet, shows empty control panel, gives no sound, mute LED is always on

#1074
drimzy

drimzy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Fantastic! great king taruga!! my sony vaio now have a sound on internal speaker!

thanks !!

#1075
sap

sap

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
sorry, but v1.1x(1.10-1.12) doesn't work with ad1986a yet.

i`m use this dump http://psykopat.free...ADI/AD1986a.txt

patch show me this info

AppleHDA Patcher - 2006/2007 Taruga v1.12

* Patching AppleHDA.kext to 0x11d41986 Done
* Checking AppleHDA for patch Done
0001f2c4 cmpl $0x11d41986,%eax
000203d0 cmpl $0x11d41986,%eax
* Checking for SPDIF Out Detected
* Checking for SPDIF In Not Detected
* Creating AppleHDA configs
* Using the following nodes in pathmap

Speaker : 27 11 7 3
Spdif Out: 37 2

* Copying new config to destination Done
* Repairing Permissions
Started verify/repair permissions on disk disk0s1 MacHD
Determining correct file permissions.
The privileges have been verified or repaired on the selected volume
Verify/repair finished permissions on disk disk0s1 MacHD
* Deleting Extensions Cache Done

#1076
claudio77

claudio77

    InsanelyMac Protégé

  • Validating
  • Pip
  • 7 posts
me too. same as SAP.

#1077
BondDotCom

BondDotCom

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

BondDotCom
How did you switch to daemonES kernel.
I keep getting a kernel panic.

I followed the advice of someone earlier in this thread.
1. Google "daemonES kernel" and download it (1MB compressed, 4MB uncompressed)
2. Extract it to your root directory (I renamed it, too)
3. Restart and hit F8 immeditately to change boot options
4. At the boot prompt, type the name of it

It should load using that kernel instead of what you normally use. To check, open a terminal window and type "uname -a" (without the quotes).

To make it the default kernel, modify your com.apple.boot.plist file and change "mach_kernel" to whatever you named the daemonES one.

#1078
eightballbill

eightballbill

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
When will cmedia 9880 be supported? Just to know... :)

#1079
chuuey

chuuey

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
Keep it up! Unfortunately it crashes when trying to patch AD1988 on Semthex Kernel for some reason;;

#1080
NHJ

NHJ

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts

Keep it up! Unfortunately it crashes when trying to patch AD1988 on Semthex Kernel for some reason;;


the reason is that you need to switch to another kernel for the patch sequence





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy