Jump to content

AppleHDA Solution - Work in progress


  • This topic is locked This topic is locked
4109 replies to this topic

#41
David7586

David7586

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts

Hm, have tested just now with my ALC882, Mic-In is working fine (stereo!)... have recorded and can play the recording fine.

Here it is working...

Rene

(You can try to use your iPod-Headphone as an Mic, must set up the recording volume to max...)



The asus P5w DH has the alc882M codec as opposed to yours which has the alc882. i wonder what the difference is between the 2.

#42
flatlyna

flatlyna

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Awesome work guys, it works well on my Abit AW9D (ALC882).

Line Out - on rear green jack. Volume didn't work initially from menubar control or keys (I have an Apple Pro keyboard). Volume adjusted ok in sound control panel and that seems to have enabled menubar and keyboard now.

Digital Out - TOSLINK connector. Works perfectly, no system level control (expected). Volume in iTunes and apps works fine. Apple DVD player sends Dolby Digital to receiver once digital out selected in prefs. :thumbsdown_anim:

Internal Microphone - on rear pink jack. Appears ok, haven't done a recording but I get meter readings tapping on mic.

There is a listing for Internal Microphone as a built-in output. No audio comes out of any remaining jacks.

#43
Ezhoon

Ezhoon

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 281 posts
  • Gender:Male
I've tried on Asus P5LD2 mobo with alc882.

Sound out works perfectly, although mic in input didn't work
I tried couple of mic lying around but, those mic could be defective
I have to test more about this mic-in

It seems output quality of sound is a bit better using this AppleHDA.kext.
It produces a bit clearer sound, I think. :)

Big thanks goes to Taruga and the gang, great work guys :)

Btw, is there any chance this kext could possibly work on alc260?

#44
Doosje

Doosje

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Can anyone report success on a laptop with ALC882 ?

#45
General_Cartman

General_Cartman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Location:The Confederacah! (Melbourne, Victoria, Australia)
On my alc882m on the N4L-VM DH mainboard which has a i945GM chipset, The kext installed, however i didn't get sound on any output on the rear even no matter what output was selected.

#46
Menno

Menno

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

I've tried on Asus P5LD2 mobo with alc882.

Sound out works perfectly, although mic in input didn't work
I tried couple of mic lying around but, those mic could be defective
I have to test more about this mic-in

It seems output quality of sound is a bit better using this AppleHDA.kext.
It produces a bit clearer sound, I think. :D

Big thanks goes to Taruga and the gang, great work guys :P

Btw, is there any chance this kext could possibly work on alc260?


It isn't what you think. It's just true :D
My sound is way better than Azalia (I have 2 professional speakers of very high value :P)

Success with output @ Asus P5LD2-V motherboard (alc882)
I can use the volume buttons also, but I am on a apple keyboard so it should work anyway. I don't have a mic to test though :(

#47
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal
Curious... I didnt noticed that sound was better. Ive been working late at night, so thats why I didnt noticed. Im glad to hear feedback, btw, i also have an Apple keyboard and volume control with keyboard isnt working, thats why Ive put it on the next things to do.

#48
Menno

Menno

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

Curious... I didnt noticed that sound was better. Ive been working late at night, so thats why I didnt noticed. Im glad to hear feedback, btw, i also have an Apple keyboard and volume control with keyboard isnt working, thats why Ive put it on the next things to do.


Well it dind't worked on the first instance, but after going to sound > output, changing the volume there they suddenly worked :P

#49
bonald

bonald

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
i have alc861. it works with azelia and device id from alc882*(didn't work with device id from 861).

tried this kext didn't work. How can I make it work for alc861?

#50
The Baron

The Baron

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 652 posts
I tried the installer and got the iternal microphone, Line out & Digital out on my sys pref. Still using Line out (I too noticed a sound improvement, maybe I imagined it :-) )

Next I'll test spdif, got to do a bit of tidying up first,

Cheers, and good luck.

#51
erikk

erikk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 199 posts
tested with vitaly kernel 8.8.1 on asrock conroe2dvi board and it doesnt work... :P but good work.
alcinject seems to load... but i dont get an available soundcard overall.

#52
asapreta

asapreta

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 755 posts
In my P5WD2 Premium I only got ALERT sounds, other sounds (Itunes, etc.) doesn't work.

Mic didn't work either, even in the front ports (configured as AC'97).

Are you getting errors on boot about Azalia? Go to Terminal and type: sudo dmesg
Look for errors. If you do see errors, you might need to fix the permissions on Azalia. Go to Terminal and type:

cd /System/Library/Extensions
sudo chown -R root:wheel AppleAzaliaAudio.kext
sudo chmod -R 755 AppleAzaliaAudio.kext
diskutil repairpermissions /
cd /System/Library
sudo rm -rf Extensions.mkext Extensions.kextcache

Then reboot.


Did you try it?

#53
iMcen

iMcen

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 139 posts
  • Location:Sweden
I tried on my ALC850, but I still only get Line out. I am willing to test more releases in the future.

#54
asapreta

asapreta

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 755 posts
Taruga helped me and now I have full output sound.
By default the OUTPUT device was not selected.

Thanks.

#55
alicheusz

alicheusz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 316 posts
  • Gender:Male

i have alc861. it works with azelia and device id from alc882*(didn't work with device id from 861).

tried this kext didn't work. How can I make it work for alc861?

I also try with 861 but don't work for me too.

I try few setup mix with device id I change it from 882 to 880 (Azlilia has 880 and it worked with 861)

change in all kext PCIMatch to match ICH 6


<key>IOPCIPrimaryMatch</key>
<string>0x27D88086</string>

to

<key>IOPCIPrimaryMatch</key>
<string>0x26688086</string>

maybe 861 use some different layout id :construction:

#56
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal
alicheusz, if you want to test with other than alc882, you have to hex edit AppleHDA binary, because its locked with 10ec0882 (codec id 283904130)

#57
Sniperfox

Sniperfox

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 403 posts
  • Gender:Male
  • Location:France
i have too realtek al 861 but itunes, qucikt time, ect don't work..

on the dvd of Myzar (10.4.5) it was very good !

its possible for recup audio on the dvd myzar??

sorry for myn english

#58
Sniperfox

Sniperfox

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 403 posts
  • Gender:Male
  • Location:France
have you got a patch for realtek alc861?

#59
plas

plas

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

alicheusz, if you want to test with other than alc882, you have to hex edit AppleHDA binary, because its locked with 10ec0882 (codec id 283904130)



Any chance you could tell us where this change needs to happen within the binary.
Or should i just search for 10ec0882

I really would like to get sound working with alc861 ive tried ever method so far with other kexts (Azalia) with no luck.

#60
shmk

shmk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
Works for me but I have the same mother board. Cheers





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy