Jump to content

AppleHDA Solution - Work in progress


  • This topic is locked This topic is locked
4109 replies to this topic

#21
plas

plas

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

i've got a alc861 on 10.4.8 it's working with AppleAzelia. I am interested in having a AppleHDA working.



Interesting ive had no luck getting alc861 working.
When editing the info.plists I can get it to appear as an audio output device on my laptop but no sound from the ports or the speakers.

Can pm how you did it or send a copy of your .kext

#22
bonald

bonald

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
i took the kext and instructions from this post.
http://forum.insanel...?showtopic=8864

Works good for me. System profiler doesn't show any sound card but I have output!

#23
plas

plas

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
Think i may have tried that kext, but i will try again.
Are you using a laptop or a desktop ?
If a laptop is the sound coming out of the speakers or a port ?

Edit: That doesnt work.

#24
bonald

bonald

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
check to see if the kext is loaded at startup. mine won't load anymore now at startup.

kextload /system/library/extensions/appleazelia.kext

it should say kext already loaded

i am using a laptop. sound from speaker.

#25
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male

check to see if the kext is loaded at startup. mine won't load anymore now at startup.

kextload /system/library/extensions/appleazelia.kext (should be AppleAzaliaAudio.kext)

Are you getting errors on boot about Azalia? Go to Terminal and type: sudo dmesg
Look for errors. If you do see errors, you might need to fix the permissions on Azalia. Go to Terminal and type:

cd /System/Library/Extensions
sudo chown -R root:wheel AppleAzaliaAudio.kext
sudo chmod -R 755 AppleAzaliaAudio.kext
diskutil repairpermissions /
cd /System/Library
sudo rm -rf Extensions.mkext Extensions.kextcache

Then reboot.

#26
bonald

bonald

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
yeah that fixed it. I got azelia working on my alc861.
What is weird is that it only works with device id from alc882!

I tried AppleHDA thing but it failed. AppleHDA is loading fine but no sound, and it doesn't show up in sysprofiler.

#27
fingerr

fingerr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
  • Gender:Male
  • Location:Poland

Lol lol lol :censored2: :shock: :) Ive just made the impossible... Ive got sound coming out from my mic !!!!

And it really plays ! Didnt know it was possible :D


Taruga, where are you?

Tell us please something more how did you get this working? Man, pleaaaaase....

#28
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal
Me and TheMaxx32000 are testing the driver right now, more news on the next days.
Volume control, line out, mic seems to work, need more work fore line in and multi speaker config and unfortunatetly cant test spdif because I dont have it. This was tested with an asus p5ld2-vm alc882, but hope to get it working with others too. Just need more time ....

#29
Rene204

Rene204

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Germany

Me and TheMaxx32000 are testing the driver right now, more news on the next days.
Volume control, line out, mic seems to work, need more work fore line in and multi speaker config and unfortunatetly cant test spdif because I dont have it. This was tested with an asus p5ld2-vm alc882, but hope to get it working with others too. Just need more time ....


Hi, that are great News....

If you are interest in further Testing, please give us a Link, so i can Test with Spdif and 5.1 Sound too.

Rene

#30
eightballbill

eightballbill

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
I'd like to know if your driver is an hackedd version of the applehda.kext or a ported driver (as written on the natit website) of the ALSA hda driver.
Can it be used on other codecs such as cmedia?
Just to know what you're working on.

#31
The Baron

The Baron

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 652 posts
Looking forward to testing this out, atm I'm on 2 channel analogue, asus P5WD2 Premium - would love to have 5.1

Good luck Taruga & the Maxx...

#32
sg

sg

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 738 posts
  • Gender:Male
hey taruga, this is SG from irc, just reporting my experiences with your new kexts...

-sound-out works just fine, i can modify the volume
-sound is coming out of the green jack
-sound-in via my microphone on pink jack (or any other) isnt working
-input level is getting something when i increase the volume, but nothing is being recorded
-when i plug/unplug from the pink jack, my recording software does detect an increase or drop of some kind for a bit (only on the pink jack, so something is working)

system details:

-10.8.4
-latest semthex beta5 kernel
-asus p5w-dh deluxe motherboard
-Realtek ALC882M High Definition Audio 8-channel CODEC (from asus site/manual)

#33
Rene204

Rene204

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts
  • Gender:Male
  • Location:Germany

-sound-in via my microphone on pink jack (or any other) isnt working
-input level is getting something when i increase the volume, but nothing is being recorded
-when i plug/unplug from the pink jack, my recording software does detect an increase or drop of some kind for a bit (only on the pink jack, so something is working)


Hm, have tested just now with my ALC882, Mic-In is working fine (stereo!)... have recorded and can play the recording fine.

Here it is working...

Rene

(You can try to use your iPod-Headphone as an Mic, must set up the recording volume to max...)

#34
Doosje

Doosje

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Can someone share the new kext with us so we can try and betatest also ?
I'dd love to have some sound on my laptop's ALC882

#35
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal
Just look at post #1 :angel:

#36
ldti

ldti

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Mic In is not working on p5wd2 premium

#37
Doosje

Doosje

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Whoops ... totally missed it .. gonna try now .. thanks


Update:
I've removed azalia, Extensions.*
Then i installed the pkg and i looked very promising after a reboot.
however no sound on any port :angel:
Also the mic doesn't have any sound .. (only internal is shown.)

There all there but "Line in" has no output control/volume
Headphones has the output control/volume but no sound...
Digital out has the same as "line in"

Line in .. must be line out :-)

#38
slipttees

slipttees

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 343 posts
  • Gender:Male
  • Location:Iguatu-CE, Brazil
Sound Devices
-------------
Description: SoundMAX HD Audio O
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: HDAUDIO\FUNC_01&VEN_11D4&DEV_1986&SUBSYS_1043818F&REV_1005
Manufacturer ID: 65535
Product ID: 65535
Type: WDM
Driver Name: ADIHdAud.sys
Driver Version: 5.10.0001.4151 (English)
Driver Attributes: Final Retail
WHQL Logo'd: No
Date and Size: 10/5/2005 06:21:10, 141312 bytes
Other Files:
Driver Provider: AnalogDevices
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 100, 192000
Static/Strm HW Mix Bufs: 33, 32
Static/Strm HW 3D Bufs: 33, 32
HW Memory: 0
Voice Management: Yes
EAX 2.0 Listen/Src: Yes, Yes
I3DL2 Listen/Src: Yes, Yes
Sensaura ZoomFX: Yes
Registry: OK
Sound Test Result: The tests were cancelled before completing.

---------------------
Sound Capture Devices
---------------------
Description: SoundMAX HD Audio I
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: ADIHdAud.sys
Driver Version: 5.10.0001.4151 (English)
Driver Attributes: Final Retail
Date and Size: 10/5/2005 06:21:10, 141312 bytes
Cap Flags: 0x41
Format Flags: 0xCCC


I'm use mac OS X 10.4.8 by Lord JaS

#39
tokra128

tokra128

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 292 posts
  • Gender:Male
Nice find - I wonder if sigmatel guys (like me) will be left behind, or the project will evolve in something like natit ? It will be fantastic !

#40
asapreta

asapreta

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 755 posts
Will try on my rig later.
Good work.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy