Jump to content

AppleHDA Solution - Work in progress


  • This topic is locked This topic is locked
4109 replies to this topic

#3861
muitommy

muitommy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 737 posts
  • Interests:Piano x Mac OS X
Anyone knows if there're something else that could mess up with this HDA?
i can't get it set up right on some installations and some can ...
some may lost the full HDA after i got i right on previous reboot ..

Thanks!

#3862
ckybam69

ckybam69

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
at least ur getting some sound, i get nothing

#3863
hplaptopmac

hplaptopmac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Location:A place where Apple allows us to install Mac on our PC's (I can dream right?)
Does anyone know the solution to the shutdown issue (with ALC268) detailed here? :
http://forum.insanel...showtopic=96434
Thanks
-hplaptopmac

#3864
mrnegitoro

mrnegitoro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Canada
[codebox]AppleHDA Patcher - 2006/2007 by Taruga v1.20

_______________________________________________________
Codec : Analog Devices AD1988B
Vendor Id : 0x11d4198b
Subsystem Id : 0x104381f6
_______________________________________________________


This codec is not working at the moment, it needs more research[/codebox]

Damn, so I'm out of luck then? Arrrrgggghhhh, :P !!!

#3865
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom

AppleHDA Patcher - 2006/2007 by Taruga v1.20                                                                       _______________________________________________________          Codec    : Analog Devices AD1988B       Vendor Id    : 0x11d4198b    Subsystem Id    : 0x104381f6_______________________________________________________This codec is not working at the moment, it needs more research
Damn, so I'm out of luck then? Arrrrgggghhhh, ;) !!!

It is being done as we speak. There will be news on the next few weeks. meanwhile, Taruga is gathering a database on: http://wiki.taruga.net/

at least ur getting some sound, i get nothing

First of all, check http://wiki.taruga.net/next, explain exactly what are you doing, and are you getting your own codec dump from your system? Or just using the one made by others? If so, check, on this forum how to make one from your system

#3866
The Vietnamese love Mac

The Vietnamese love Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:HANOI-VIETNAM
Hi guys,

I tried 22/12/2007 AD1986 0x11d41986 for testing and it works 80% for me.

Before this, I had only sound thru my internal speakers. After installing this, I have got options to send sound to either internal speakers or headphone (my loudspeakers, great for music maniac). However, I notice 2 problems:

1. No microphone in, though there're echoes from microphones (internal and external line-in)
2. Main volume bar (near system clock) is disabled (but it is adjustable in all multimedia programs)

Patcher 1.20 doesn't work with my code dump, and Patch 2.0 has still been delayed. Anyone can help to fix to enable microphone-in work?


Note Added: My laptop is Asus V1JP and its sound hardware is AD1986A 0x11d41986. (Taruga says: Laptop W3 -- AD1986a 0x11d41986 -- Nothing works???)

Here is my codec:

Attached Files



#3867
mrnegitoro

mrnegitoro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Canada

It is being done as we speak. There will be news on the next few weeks. meanwhile, Taruga is gathering a database on: http://wiki.taruga.net/First of all, check http://wiki.taruga.net/next, explain exactly what are you doing, and are you getting your own codec dump from your system? Or just using the one made by others? If so, check, on this forum how to make one from your system


Hi jjduro,

Thanks for the reply, I used my own codec dump from Ubuntu...

That's great news, re: "It is being done as we speak."

I will check the web address above, Thanks again...

#3868
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom

Note Added: My laptop is Asus V1JP and its sound hardware is AD1986A 0x11d41986. (Taruga says: Laptop W3 -- AD1986a 0x11d41986 -- Nothing works???)


It's the users of Taruga Wiki that update the working and not working sound devices table. Go there and insert you Asus V1JP it will help Taruga to keep track of the several codecs and sound issues.

#3869
QMax

QMax

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts
  • Gender:Male
  • Location:Italy
Still having big problems here:

Asus F9S
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
Realtek ALC660-VD

No sound at all, Azalia doesn't work too.
Taruga patcher 1.17 seems able to patch HDA kext using codec dump from Ubuntu (in Ubuntu audio works but need some change in drivers). but still have no sound.

Looking into system.log I can see this error line at every boot:

kernel[0]: AppleHDAController::start ERROR no layout-id found.

I hope this could help...

Thanks !

Max

#3870
xristoforos

xristoforos

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Greece
I hope Taruga is going to make the Analog Devices AD1988B chip of the Asus P5K-E work!!!

#3871
Gensei

Gensei

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi mates I'm reallt new here and a newbie in osx.
I don't think I'm the first one to have problems with ACL 880.It seems like i found out a trick or maybe it was the procedure to follow, i dont know i'm not skilled at all in osx, let me explain myself:

There are different solutions available throught the forums (the appleHDA patcher with your linux txt dump)the 880 and others drivers called betaforsome 861-881 ect).I tried several times and i did not get any success.So i decided to do my own dump with using xubuntu.

launch your xubuntu/ubuntu live cd and then :
browse to home/proc/asound/card0 right click and open terminal with left click and type : sudo thunar (nautilus is for ubuntu) to open your file browser in root mode then copy the file which is named codec to somewhere you can get it later.

under osx:
use your file with a drag and drop to applehdapatcher then as said replace your applehda in your kext folder, then reboot.

sound wont work now so lauch appleacl882 applehda v0,4b.mpkg (a sound fix if i'm right) let it install files automatically and then finally lauch beta4some861-880 installer reboot and you should have sound.

I dont know if my method is good as it might sound strange and may be not correct but it did work for me.If you have bad results dont blame me.
I really hope it will help out some people

PS: my kernel is the speedstep one under leopard 9,5,2 even if I have an intel SSE3

#3872
magic0200

magic0200

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I hope that people read this and could help me out (as I have Taruga looking at this problem as well).

SOUND CHIP: SigmaTel 92HD71B

REAL NAME: 92HD71B8

SPECIFICATIONS: http://www.idt.com/p...?docID=18452184

RELATED LINK WITH LINUX SUPPORT : http://ubuntuforums....ad.php?t=676550


PROBLEM: I have worked with HDA Patcher however I am getting a generic codec error due to the fact that my Chipset under Linux (unbutu 7.10 live) finds two codecs and not one (codec#1 codec#2). It classifies my card as two devices that are found as:

HDA INTEL (ALSA MIXER) = Dump1
GENERIC 111D ID 76B0 (OSS MIXER) = Dump2

Talking to members in #osx86 one felt that my chipset might be running through northbridge and using a dummy patch to cross. I have attached the dumps below and would love any help on this.

DUMP ONE

Codec: Generic 11c1 Si3054
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x107b0690
Revision Id: 0x100200


DUMP TWO

Codec: Generic 111d ID 76b0
Address: 2
Vendor Id: 0x111d76b0
Subsystem Id: 0x107b0692
Revision Id: 0x100101
Default PCM:
rates [0x7e0]: 44100 48000 88200 96000 176400 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Default Amp-Out caps: ofs=0x7f, nsteps=0x7f, stepsize=0x02, mute=1
Node 0x0a [Pin Complex] wcaps 0x400183: Stereo Amp-In
Amp-In caps: N/A
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00]
Pincap 0x081c: OUT HP Detect
Pin Default 0x0321101f: [Jack] HP Out at Ext Left
Conn = 1/8, Color = Black
Pin-ctls: 0xc0: OUT HP
Connection: 3
0x10* 0x11 0x17
Node 0x0b [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081724: IN Detect
Pin Default 0x03a11020: [Jack] Mic at Ext Left
Conn = 1/8, Color = Black
Pin-ctls: 0x24: IN
Node 0x0c [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081724: IN Detect
Pin Default 0x40f000f0: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Node 0x0d [Pin Complex] wcaps 0x400183: Stereo Amp-In
Amp-In caps: N/A
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00]
Pincap 0x0814: OUT Detect
Pin Default 0x90170110: [Fixed] Speaker at Int N/A
Conn = Analog, Color = Unknown
Pin-ctls: 0x40: OUT
Connection: 3
0x10* 0x11 0x17
Node 0x0e [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081724: IN Detect
Pin Default 0x40f000f1: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Node 0x0f [Pin Complex] wcaps 0x400183: Stereo Amp-In
Amp-In caps: N/A
Amp-In vals: [0x80 0x80] [0x00 0x00] [0x00 0x00]
Pincap 0x0814: OUT Detect
Pin Default 0x40f000f2: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Connection: 3
0x10* 0x11 0x17
Node 0x10 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
Amp-Out caps: N/A
Amp-Out vals: [0x71 0x71]
Power: 0x0
Node 0x11 [Audio Output] wcaps 0xd0c05: Stereo Amp-Out
Amp-Out caps: N/A
Amp-Out vals: [0xff 0xff]
Power: 0x0
Node 0x12 [Audio Input] wcaps 0x1d0541: Stereo
Power: 0x0
Connection: 1
0x1c
Node 0x13 [Audio Input] wcaps 0x1d0541: Stereo
Power: 0x0
Connection: 1
0x1d
Node 0x14 [Pin Complex] wcaps 0x400102: Mono Amp-In
Amp-In caps: N/A
Amp-In vals: [0x80]
Pincap 0x0810: OUT
Pin Default 0x40f000f3: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Connection: 1
0x16
Node 0x15 [Audio Selector] wcaps 0x300101: Stereo
Connection: 3
0x10* 0x11 0x17
Node 0x16 [Audio Mixer] wcaps 0x200100: Mono
Connection: 1
0x15
Node 0x17 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x97 0x97] [0x97 0x97] [0x97 0x97] [0x97 0x97] [0x97 0x97]
Connection: 5
0x10 0x11 0x27 0x1a 0x1b
Node 0x18 [Pin Complex] wcaps 0x40000d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-Out vals: [0x00 0x00]
Pincap 0x0820: IN
Pin Default 0x90a6012e: [Fixed] Mic at Int N/A
Conn = Digital, Color = Unknown
Pin-ctls: 0x00:
Node 0x19 [Pin Complex] wcaps 0x40000d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-Out vals: [0x00 0x00]
Pincap 0x0820: IN
Pin Default 0x40f000f5: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Node 0x1a [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-Out vals: [0x03 0x03]
Connection: 3
0x0b* 0x0c 0x0e
Node 0x1b [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 3
0x0b* 0x0c 0x0e
Node 0x1c [Audio Selector] wcaps 0x30090d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Amp-Out vals: [0x0f 0x0f]
Connection: 4
0x1a* 0x17 0x18 0x19
Node 0x1d [Audio Selector] wcaps 0x30090d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 4
0x1b* 0x17 0x18 0x19
Node 0x1e [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x044513a0: [Jack] SPDIF Out at Ext Right
Conn = Optical, Color = Black
Pin-ctls: 0x00:
Connection: 1
0x24
Node 0x1f [Pin Complex] wcaps 0x400701: Stereo Digital
Pincap 0x0810010: OUT EAPD
Pin Default 0x40f000f8: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Power: 0x0
Connection: 2
0x24* 0x25
Node 0x20 [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x90451360: [Fixed] SPDIF Out at Int N/A
Conn = Optical, Color = Black
Pin-ctls: 0x00:
Connection: 1
0x25
Node 0x21 [Audio Output] wcaps 0x40211: Stereo Digital
PCM:
rates [0x7e0]: 44100 48000 88200 96000 176400 192000
bits [0xe]: 16 20 24
formats [0x5]: PCM AC3
Node 0x22 [Audio Output] wcaps 0x40211: Stereo Digital
PCM:
rates [0x7e0]: 44100 48000 88200 96000 176400 192000
bits [0xe]: 16 20 24
formats [0x5]: PCM AC3
Node 0x23 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x24 [Audio Selector] wcaps 0x300101: Stereo
Connection: 3
0x21* 0x1c 0x1d
Node 0x25 [Audio Selector] wcaps 0x300101: Stereo
Connection: 3
0x22* 0x1c 0x1d
Node 0x26 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=1
Amp-Out vals: [0x00]
Node 0x27 [Pin Complex] wcaps 0x400000: Mono
Pincap 0x0820: IN
Pin Default 0x40f000f7: [N/A] Other at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Node 0x28 [Volume Knob Widget] wcaps 0x600000: Mono



#3873
Taruga

Taruga

    Retired

  • Retired Developers
  • 532 posts
  • Gender:Male
  • Location:Portugal
AppleHDA Project has moved to http://wiki.taruga.net
Feel free to join, participate, post sound issues, etc ... only this way I can do my best to help

ps. Reason for moving... I needed better organization and control.

#3874
somersmaarten

somersmaarten

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Where do I find the AppleHDA 1.2, theire website is down and i need it

#3875
SirOcelot

SirOcelot

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Yeah I agree with the above poster. Taruga, you suggest we goto this "wiki" and all I get is a cPanel page. Please fix it, as my wife is pissed cause she doesn't have sound on her laptop due to my...meddling with her laptop and putting OSX86 on it ;)

#3876
MILAN0

MILAN0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Still output does not work! It is working in speakers only.
I used USB adapter from plantronis but sound quality sucks. HD Codec works much better.

ТАНЦЫ С БУБНОМ ПРОДОЛЖАЮТСЯ БЛЯ!

#3877
gHIS

gHIS

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:france
Hy, yes taruga's website is down but i have the taruga's patcher v1,2 if you need it ? So give me your mail adresss and i can send it by mail...But i have the patcher but not the codec that i need ^^... So if someone have the ACL882 codec please can you send me it by mail at ghislain.s@orange.fr please???THX

#3878
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom
for those who need taruga's sollutions, go to: http://osxupdate.blogspot.com/

#3879
strangedaze

strangedaze

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
Could someone pretty please upload taruga's AppleHDA Patcher 1.20 (or latest avalible one) to mediafire/rapidshare/or any file hosting network. ALL current ones I've found are down except for 1.16 which is rather old.

Thanks....hopefully someone see's this on page 195 :P

BTW BIG thank you to taruga!

:wacko: :wacko: :D :D Found it lingering in an old post around here when his site went MIA last summer(think do to a server change) anyways here it is for anyone else that needs it.

AppleHDA Patcher v1.20 (newest) FYI must be logged in to download.

Attached Files



#3880
kingcezar

kingcezar

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Did anyone get the sound working.. i really want Sound.. plz anyone HELP!!!

im runing in on a hp Compaq Nc6320.. its 11d4 and 1981.. the ones that ppl have on here.. plz help me out.. i got wireless working with a usb adapter..

Other word about ethernet would be helpful and if someone can help me get the best res on my computer..

Plz take the time and help..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy