Jump to content

Intel HD 620 issue after 10.12.6 update

sierra intel hd kabylake hd 620 graphics

Best Answer soumaxetuirk, 19 August 2017 - 05:49 PM

Problem fixed with Rehabman's guide.

patchable for DVMT-prealloc:


0x591b0000 01030303 00006002 00005001
0x59260007 00030303 00009003 00005001

Working ig-platform-id =  0x591b0000

 

Kext to patch :

Name: AppleIntelKBLGraphicsFramebuffer
Find: 01030303 00006002 00005001
Replace: 01030303 00003001 00009000

Inject IntelGFX=Yes

SMBIOS = Macbook Pro 14,1

 

Kext used = Lilu.kext + IntelGraphicsFixup.kext

 

 

Go to the full post


  • Please log in to reply
1 reply to this topic

#1
soumaxetuirk

soumaxetuirk

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
Hello,
 
After updating to 10.12.6 I removed fake CPU id and GPU id kexts and replaced ig-platform-id with 0x51960000 also injected intel GFX 0x51968086.
 
Tried with IntelGraphics fixup kext. But still getting only 7mb video memory with no graphics acceleration and no brightness control.
 
Please help me to fix my clover config.

Attached Files



#2
soumaxetuirk

soumaxetuirk

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male

Best Answer

Problem fixed with Rehabman's guide.

patchable for DVMT-prealloc:


0x591b0000 01030303 00006002 00005001
0x59260007 00030303 00009003 00005001

Working ig-platform-id =  0x591b0000

 

Kext to patch :

Name: AppleIntelKBLGraphicsFramebuffer
Find: 01030303 00006002 00005001
Replace: 01030303 00003001 00009000

Inject IntelGFX=Yes

SMBIOS = Macbook Pro 14,1

 

Kext used = Lilu.kext + IntelGraphicsFixup.kext

 

 







Also tagged with one or more of these keywords: sierra, intel hd, kabylake, hd 620, graphics


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy