Jump to content

Sierra 10.12.4 on Dell Inspiron 7537 start from USB installer but not from installed OSX on the SSD

Dell Inspiron 7537 Sierra DSDT Kexts Clover Dual boot Post install Patching DSDT

  • Please log in to reply
2 replies to this topic

#1
BoomBoomBastic

BoomBoomBastic

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi to all of you happy users of hackintosh community ! :)

 

This is my first post here on InsanelyMac and it will be a bit longer because I have a problems that I couldn't solve without someones help who's a bit more experianced then me in tweaking and patching a hackintosh.

This laptop will be a present to someone and I have only one week from now to finish it up and then I have to send it abroad. Thanks in advance.

 

The configuration is dual boot with prior Widows 10 installed on Samsung EVO 850 - 250 GB partitioned like: 

 

1st partion was 100 MB EFI and is now 550 MB after deleting second Windows MSR partition

2nd partiton is still 16 MB MSR Windows

3th partition is Windows 10 NTFS with 99 GB

4th partiton is Downloads NTFS with 70 GB

5th partition is OSX Extended journaled with 35 GB

6th partition is OSX Recovery Extended journaled with 620 MB

7th partition is Acronis FAT32 with 27GB

 

It's a Dell Inspiron 7537 Notebook:

        

Motherboard Product: 038M0M - Intel Lynx Point-LP, Intel Haswell

BUS ratio: min 8 max 20, 20, 28, 31 x 100 MHz

CPU and RAM:  Mobile DualCore Intel Core i7-4510U CPU @ 2.00GHz - RAM: 16GB DDR3 - 1600MHz

Graphics:           Intel HD Graphics 4400 and nVIDIA GeForce GT 750M 2GB

Monitor: LP156WF4 Dell 890N5 @ 1920 x 1080 - Touchscreen

BIOS: A14 - Audio: Realtek ALC283 - Intel 8 Series Chipset SATA AHCI

WiFi: Intel Wireless N7260/Bluetooth is changed for Broadcom BCM94352HM

Ethernet-RTL8168/8111

CardReader RTL8411B - 4 Intel USB 3.0 ports

Dell Touchpad

Webcam - DWGV8

SSD 850 EVO 250GB

 

 I have found on the internet working installer image with Sierra 10.12.4 and I placed it on the USB with TransMac and I tried to install it, but it didn't work right from the box untill I didin't find a "good" .config file with good flags for this laptop and I replaced it in the Clover. It has Clover 4049 in the EFI partition on the USB installer.

 That was my first problem to get Clover working on SSD but after some time I succeed to install the newest Clover 4128 on the SSD - EFI partition.

 I have installed at least 10 times this Sierra image on this laptop before I came here to post all of this because apparently I make always same mistake and I can't go any further with it. I hope that I did not messed too much with all of this because there is still working Windows 10 with working 4128 Clover. The only problem is that in biginning after first few times unsuccessful install of OSX I had different behavior then now of OSX if I would like to start it from SSD.

In beginning, if I check flag -V and I try to start from SSD it will come to one point and it will hang enternally at that point and I must to restart notebook via the power button because it will never boot to OSX desktop without USB installer. I "played" apparently a bit too much and after changing and putting the same . config to EFI partition on Clover and sometimes even Clover will not show up untill I don't swich off the power on notebook.

I went further and I thought, O.K. I will continue with installing kexts to see what I can get working. It was also not so easy and acctually I still don't know exactly which kext I really need to install and what I should avoid to install assuming I didn't use any patched DSDT cause I never make it so far.

What I got it to work somehow till now with Pandora's Box (Before that I tried and other post install tools as Vietnam tool 1.9.6 with not so much succes, actually after using the Vietnam tool I got this kernel panic and immediate rebooting if I try to boot from SSD and it's never gone even after deleting the whole OSX partition and Pandora's box is noob's friendly tool) is:

Booting from USB installer, Sound, Ethernet, USB (but I don't know if it's full speed or not) Some hardware monitoring info, touch pad and keyboard, trimming.

I changed internal WiFi Intel N7260 card with bluetooth for the one Broadcom BCM94352HM WiFi+Bluetooth card which is here and overall advertised as working out the box with OSX but I didn't get it working untill now.

Dedicated Nvidia GT 750M video card is not working and also Intel HD 4400 looks a bit too slow by opening applicatons box in the OSX.

Webcam doesn't work, hibernate doesn't work, touchscreen doesn't work and booting from SSD doesn't work.

This time I have installed OSX again and I have pressed F4 to extract my original DSDT file from this notebook(I don't know if it does a metter that I pulled DSDT.aml file after install of OSX and not before installation, I mean after rebooting) but I didn't boot to finish installing until I don't get good information from someone who knows where I make mistake. I only tried to boot once from SSD to see if something is changed with immediate kernel panic, but there is still one there waiting to be removed. :)

- I have attached here Clover config file which is in the EFI partition on the USB and it's a same config file from EFI on the SSD.

- Also I have attached an already patched DSDT file for Dell Inspiron 7537 which I found here in Download section but it is patched for El Capitane and is not from this laptop so I don't know if it can help.

- I also added a full folder of Clover from the EFI partition on the SSD.

 

Who can help me to bring this installation to the end ?

I have not so much time to finish it so please don't hesitate to help me in it. Thanks !

Greetings from Holland !

Attached Files



#2
BoomBoomBastic

BoomBoomBastic

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi to all,

 

I made a bit of progress on this thread...

I solve a problem with Clover and now I have working bootable OSX from SSD. Also I have installed a few available kexts and I have now working ethernet, audio, touchpad and keyboard, USB 3.0 and hardware monitoring. 

There is stil  to be done WiFi and bluetooth, Webcam, Cardreader and nVidia 750M.

 

Anyone who can help abuot it , please ?

Thanks in advance.

 

Oh, I almost forgot to mention, I also updated macOS to OSX Sierra 10.12.6



#3
TrustAugustus

TrustAugustus

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Hey

the nvidia card has optimus so, unless I am much mistaken, you will not be able to use it. There might be a chance if you can disable your igpu but there are risks involved.

 

Your wifi card needs some compatible kexts for bluetooth to run. see here, credit RehabMan

You also need FakePCIID.kext and FakePCIID_Broadcom_WiFi.kexts from here, credit RehabMan

 

There are multiple ways to get the WiFi up an running. The simplest I have found is a clover patch, see post #1 from darkvoid here

 

Your webcam isn't working? How about your mic? Odds are we would need to fix it with a dsdt and/or ssdt edits. Lets try to get the WiFi up and running first.







Also tagged with one or more of these keywords: Dell Inspiron 7537, Sierra, DSDT, Kexts, Clover, Dual boot, Post install, Patching DSDT


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy