Jump to content

Dell latitude E5430 graphic support - Help please!

dell latitude e5430 glitch help problem graphic card GPU

  • Please log in to reply
2 replies to this topic

#1
MadFive

MadFive

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hello!

 
I'd like to ask for some help with the installation of OS X 10.11.6 on a Dell latitude E5430.
The problem is, that I can't get to the installation screen.
More precisely, when I get there the screen glitches out so I can't even start the installation. After connecting the laptop to an external monitor the install screen appears with a cursor but the screen is still completely unreadable...
I'm not an expert but I think the problem is somewhere in the video support... So I've tried several guides and fixes but none of them worked for me. (I managed to get past a missing IOBluetooth panic by using a patched dsdt)
 
With a combination of different config settings, dsdts and kexts I managed to reach the installation screen but only without any input at all... After fixing the input problem the screen was gone again...
 
Do you have any similar experience? Please help if you have any idea for a solution!
Thank you in advance,
 
MadFive
 
SPECS:
  • model:    Dell latitude E5430
  • resolution:    1366 x 768
  • CPU:    Intel Core i5 3320M / 2.6 GHz (SandyBridge?)
  • GPU:    Intel HD Graphics 4000
  • memory:   8GB
  • Boot Loader:   Clover 4128

files:

https://drive.google...UDF0OUFUM0dSY0k



#2
Slice

Slice

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,312 posts
  • Gender:Male
  • Location:Moscow

I have 6430 with the same CPU, it is IvyBridge. Same screen.

The graphics works with Inject->intel=YES

ig-platform-id=0x01660003

I also have Nvidia NVS5200M. It is not working, so I set Optimus=Enable in BIOS. Yes, enable!

 

EDIT1:

Looking your config I notice you did the same, but

InjectEDID=YES is obsolete

you have to write

EDID->Inject=YES

 

And I set DualLink=1



#3
Hervé

Hervé

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,955 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

DualLink is not normally required on low-res LCD; only on high res models (1600x900 and above) with which you must also use layout-id 0x01660004.

 

Use MacBookPro9,2 SMBIOS, not MBP8,1 which is SandyBridge/HD3000...

 

Here's your revised DSDT where _DSM method of Device (IGPU) has been modified as follows:

  1. layout-id changed from hires 01660004 to lores 01660003
  2. Dualink changed from 1 to 0

Give that a try.

Attached File  DSDT.aml.zip   17.45KB   3 downloads


And here's a revised Clover config.plist because yours was quite messy and erroneous (devices, patches, SMBIOS, etc.).

Attached File  config.plist.zip   2.56KB   3 downloads







Also tagged with one or more of these keywords: dell latitude, e5430, glitch, help, problem, graphic card, GPU


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy