Jump to content

Nvidia Web Driver updates for macOS High Sierra (UPDATE 12/08/2017)

nvidia web driver

  • Please log in to reply
993 replies to this topic

#1
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,597 posts
  • Gender:Male

*
POPULAR

Hi InsanelyMacaliens     :)

 

Use this thread to link / talk about of the futur Nvidia Web Driver updates for macOS High Sierra.

 

10.13.2

 

Nvidia Web Driver - 378.10.10.10.25.103 --> build 17C89 (thanks to Il Francy MacPcNew!

 

Nvidia Web Driver - 378.10.10.10.25.102 --> build 17C88 (thanks to piiggggg)

 

 

10.13.1

 

Nvidia Web Driver - 378.10.10.10.20.109 --> build 17B1003 (see this post)

 

Nvidia Web Driver - 378.10.10.10.20.108 --> build 17B1002 (thanks to BreBo

 

Nvidia Web Driver -378.10.10.10.20.107 --> build 17B48 (thanks to piiggggg

 

 

10.13.0

 

Nvidia Web Driver - 378.10.10.10.15.121 --> build 17A405 (thanks to Asgorath)

 

Nvidia Web Driver - 378.10.10.10.15.120 --> build 17A405 (thanks to phi777

 

Nvidia Web Driver - 378.10.10.10.15.117 --> build 17A405 (thanks to phi777)

 

Nvidia Web Driver - 378.10.10.10.15.114 --> build 17A365 (thanks to Asgorath).


Edited by fantomas1, 09 December 2017 - 10:06 AM.
UPDATE 12/08/2017 - added Nvidia Web Driver - 378.10.10.10.25.103 for macOS High Sierra build 17C88


#2
stillmoms

stillmoms

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Big question as far as I’m concerned is whether we’ll see interface performance improvements on-par with what I’ve been seeing on native Mac hardware with Apple-tested Metal support. I believe Metal support was added in NVIDIA’s Web Drivers a little while ago, but I wonder if that’ll be the stumbling block in seeing new beta drivers for these developer previews.



#3
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,157 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

just waitin'Attached File  beachball.gif   2.85KB   154 downloads



#4
魔道逆天地

魔道逆天地

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:China

10.13 NVIDIA 660   boot failure        -v  reboot           Clover     nv_disable=1  Successful startup

 

 

 

 

      Kernel Extensions in backtrace:
         com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000->0xffffff7f86441fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
         com.apple.nvidia.driver.NVDAResman(10.2.2)[31F1CA86-E625-320E-A6DC-46FF7FC3943B]@0xffffff7f8646a000->0xffffff7f86750fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IONDRVSupport(516.28)[3EA927A7-90EC-356A-A07E-B7E4246E5C40]@0xffffff7f8644e000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
            dependency: com.apple.AppleGraphicsDeviceControl(3.15.26)[DD390B93-7A57-3981-B709-CE0EE9127B5C]@0xffffff7f8645e000
         com.apple.iokit.IOAcceleratorFamily2(348.5)[D748F500-65D8-30C4-AA70-2D245E7851C9]@0xffffff7f86827000->0xffffff7f868b8fff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[441A112D-E54F-3B2C-82A9-9FE928BBE7F9]@0xffffff7f86812000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
         com.apple.GeForce(10.2.2)[0D8C53A6-A9AC-3DB9-8DA0-FF9477799500]@0xffffff7f868c8000->0xffffff7f86962fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IONDRVSupport(516.28)[3EA927A7-90EC-356A-A07E-B7E4246E5C40]@0xffffff7f8644e000
            dependency: com.apple.nvidia.driver.NVDAResman(10.2.2)[31F1CA86-E625-320E-A6DC-46FF7FC3943B]@0xffffff7f8646a000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
            dependency: com.apple.iokit.IOAcceleratorFamily2(348.5)[D748F500-65D8-30C4-AA70-2D245E7851C9]@0xffffff7f86827000



#5
Shikumo

Shikumo

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Getting a black screen with mouse cursor I can interact with. This is with an internal NVIDIA Quadro 1000M that worked oob until Sierra. Booting in safe mode (-x) works with full resolution but no acceleration. Any help appreciated :worried_anim:



#6
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

Nvidia driver Updater did the job again!|

Attached Files



#7
gagaraz

gagaraz

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Bucuresti, Romania

How did you do it?



#8
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

Nvidia driver updater app to patch this NVDAStartupWeb.kext

then I patched policy with  old 10.12.5 kext AppleGraphicsControl.kext



#9
burkett375

burkett375

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

How did you do it?

 

Nvidia driver Updater did the job again!|

 

Yeah, I'm curious.  I can't edit the NVDAStartup.kext for the life of me.  The required OS is blank and the app is saying I don't have that kext



#10
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

I put 17A

 

Yeah, I'm curious.  I can't edit the NVDAStartup.kext for the life of me.  The required OS is blank and the app is saying I don't have that kext

 

Attached Files



#11
Kajos200

Kajos200

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I put 17A

From where did you got the NVDAStartupWeb.kext?
Can I just copy my 10.2.5 Sierra version of it to 10.13?



#12
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

config1 to none in MacPro6.1 related part (I use a Mac Pro 6.1 smbios)

this with original 10.13 beta kext in my case does not work

 

so I have used my old 10.12.5 kext (installed with kext utility)

It is working with dual monitor but acceleration is not present



#13
gagaraz

gagaraz

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Bucuresti, Romania

does not work..please send NVDAStartupWeb.kext AppleGraphicsControl.kext (thank you very much)



#14
burkett375

burkett375

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

I put 17A

 

That's the thing...it says that the kext doesn't exist, so I can't edit it.  When I try to manually edit, I can't.  And I can't change permissions on the file...



#15
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

I will try to explain what I did...I am testing like you and I am not an expert or coder at all..I like to try things:-)

 

so:

I have a working system with 10.12.5 installed

I have downloaded 10.13 beta from apple store

to have it working I have to use clover 4081 (thanks to sherlocks)

I have also to change my cpu kernel patch (thank to PMHeart and Matthew82 to point me in right direction)

I installed from 10.12.5 to a clean disk launching Install macOS 10.13 Beta from application

then when all process is finished I have transferred all my setting from 10.12.5 to 10.13 beta with migration assistant

in this way I have cuda and nvidiadriver installed but not working

I patched with 17A and NVIDIA® WebDriver Updater app

then I have modified AppleGraphicsControl.kext in the same way I do from time

in this way apple policy produce a black screen

if I change inside new kext applegraphiccontrol kext/contents/plugin this file: AppleGraphicsDevicePolicy.kext with an old and patched 10.12.5 one...I have two monitors working and nvidiaweb drivers loaded fine

but poor performance...

so someone could understand how to have performance if possible..or we have to wait nvdia for a correct driver...

 

I can't explain better in English..sorry! :-)


here you go

does not work..please send NVDAStartupWeb.kext AppleGraphicsControl.kext (thank you very much)

 

Attached Files



#16
burkett375

burkett375

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

I will try to explain what I did...I am testing like you and I am not an expert or coder at all..I like to try things:-)

 

so:

I have a working system with 10.12.5 installed

I have downloaded 10.13 beta from apple store

to have it working I have to use clover 4081 (thanks to sherlocks)

I have also to change my cpu kernel patch (thank to PMHeart and Matthew82 to point me in right direction)

I installed from 10.12.5 to a clean disk launching Install macOS 10.13 Beta from application

then when all process is finished I have transferred all my setting from 10.12.5 to 10.13 beta with migration assistant

in this way I have cuda and nvidiadriver installed but not working

I patched with 17A and NVIDIA® WebDriver Updater app

then I have modified AppleGraphicsControl.kext in the same way I do from time

in this way apple policy produce a black screen

if I change inside new kext applegraphiccontrol kext/contents/plugin this file: AppleGraphicsDevicePolicy.kext with an old and patched 10.12.5 one...I have two monitors working and nvidiaweb drivers loaded fine

but poor performance...

so someone could understand how to have performance if possible..or we have to wait nvdia for a correct driver...

 

I can't explain better in English..sorry! :-)


here you go

 

Out of curiosity, did you upgrade to APFS? or leave it as HFS?



#17
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male
Hfs

#18
burkett375

burkett375

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

Hfs

 

Bingo...that's what I thought.



#19
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,545 posts
  • Gender:Male

cuda is working (it seems to work)

 


Blackmagic davinci resolve 14 NO! :-(

 

Attached Files



#20
Badruzeus

Badruzeus

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 634 posts
  • Gender:Male
  • Location:Indonesia
  • Interests:Graphics Design.

For quick report, my NVIDIA GeForce GT 520M (10de:1050 / GF119) using 10.13's Native NVDA* && Ge* got only a working Cursor with Black Screen and never reach Desktop. But, I think it' s way better than previously WindowServer crash under 10.12.x. Too bad, I then use 10.12.5's CoreDisplay binary framework and it "just works". :lol:

Still waiting for Web Driver under 10.13, but I'm not sure NVIDIA would release it soon for macOS Beta. << I think it would be same on G610 or GT520 which is also GF119. FYi, I'm using Clover v2.4k r4084 and GFX0 Graphics personalities on DSDT (or InjectNvidia=True).

Attached Files

  • Attached File  03.png   981.73KB   74 downloads






Also tagged with one or more of these keywords: nvidia web driver


4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy