Jump to content

Creative X-Fi Titanium Pro mic doesn't work

pinconfig emu20k2 sb0880 voodoohda creative mic microphone

  • Please log in to reply
10 replies to this topic

#1
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

VodooHDA makes sound output (2.1) work but Microphone and Line-Out wont work.

I've been trying to get the PinConfigOverrideVerbs from Windows regedit and the codec dumps from linux but this card (Emu20k2, SB0880) doesnt have any codecs on linux even though microphone works perfectly fine there and windows doesnt have a PinConfig entry in the registry for this card.

 

I'm at a loss... what else can I do to make at least the mic work?



#2
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,549 posts
  • Gender:Male

Try AppleALC + Lilu in S/L/E or Clover/kexts, never at both places!



#3
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

Try AppleALC + Lilu in S/L/E or Clover/kexts, never at both places!

Do I need anything else besides those both kexts?

I uninstalled VodooHDA and removed the AppleHDADisabler.kext(not sure if thats correct).

But with Lilu + AppleALC I have no audio device at all.



#4
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,549 posts
  • Gender:Male
Hmmm, I was doing a researching, and to get this card working you'll need try out a lot of process.
 
If Lilu and ALC didn't work out, maybe you can try use a patched AppleHDA.
 
Or the new version of VoodooHDA.


#5
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

 

Hmmm, I was doing a researching, and to get this card working you'll need try out a lot of process.
 
If Lilu and ALC didn't work out, maybe you can try use a patched AppleHDA.
 
Or the new version of VoodooHDA.

 

I've tried the latest voodoo and Lilu + ALC already. Do you have any recommendation for patched AppleHDA?



#6
ITzTravelInTime

ITzTravelInTime

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
  • Location:Italy
  • Interests:computer science, programming, hardware, software developing

apple ale will not work with that card, simply because it doe not supports the audio chipset that the card uses, try to use voodoo had version 2.9.0



#7
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

apple ale will not work with that card, simply because it doe not supports the audio chipset that the card uses, try to use voodoo had version 2.9.0

I tried 2.9.0d10 but only 1 output is working and I cant figure out how to fix the pin config without any dump :(



#8
chippackage

chippackage

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

I have full surround sound working.

 

 

 

 

Once Voodoo is onstalled then create the aggregate layout. Initially upon reboot the sound will be 2.1, but click on the sound icon top right, select aggregate device and immediately again select the Line Out (Green Rear) again. The sound will now be 5.1 and when I play games or watch movies, I mean true 5.1sound. Not duplicating the stereo to all speakers.

 

 


PS: My card is the same as yours: Emu20k2, SB0880. Let me know if you need help.

Attached Files



#9
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

I have full surround sound working.




Once Voodoo is onstalled then create the aggregate layout. Initially upon reboot the sound will be 2.1, but click on the sound icon top right, select aggregate device and immediately again select the Line Out (Green Rear) again. The sound will now be 5.1 and when I play games or watch movies, I mean true 5.1sound. Not duplicating the stereo to all speakers.


PS: My card is the same as yours: Emu20k2, SB0880. Let me know if you need help.


Does your microphone also work with that?

#10
chippackage

chippackage

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

Does your microphone also work with that?

 

Unfortunately not. I use an external Logitech Mic.



#11
illfatedIM

illfatedIM

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

Unfortunately not. I use an external Logitech Mic.

Damn :( I think I had it working once with some odd PinOverride i found in a thread but I cant seem to find it anymore.

I guess I either have to give up hackintosh or live with my terrible onboard.

 

But thanks a lot for you trying to help with this. If you find anything useful for your/our card I'd be happy to hear as infos about this specific card seem to be quite rare around here.

 

Edit: does the volume slider lag your whole system as well?







Also tagged with one or more of these keywords: pinconfig, emu20k2, sb0880, voodoohda, creative, mic, microphone


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy