Jump to content

HD4600 (mobile) - can't use HDMI

hdmi hd4600 laptop freeze

  • Please log in to reply
34 replies to this topic

#21
dedede2137

dedede2137

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Frozen screen with this...
Lenovo Z710, i5-4200M

 

Config:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Fixes</key>
			<dict>
				<key>AddPNLF_1000000</key>
				<true/>
				<key>FixLAN_2000</key>
				<true/>
				<key>NewWay_80000000</key>
				<true/>
			</dict>
			<key>Patches</key>
			<array>
				<dict>
					<key>Comment</key>
					<string>change EHC1 to EH01</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMQ==
					</data>
					<key>Replace</key>
					<data>
					RUgwMQ==
					</data>
				</dict>
				<dict>
					<key>Comment</key>
					<string>change EHC2 to EH02</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMg==
					</data>
					<key>Replace</key>
					<data>
					RUgwMg==
					</data>
				</dict>
				<dict>
					<key>Comment</key>
					<string>change GFX0 to IGPU</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					R0ZYMA==
					</data>
					<key>Replace</key>
					<data>
					SUdQVQ==
					</data>
				</dict>
				<dict>
					<key>Comment</key>
					<string>change B0D3 to HDAU</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					QjBEMw==
					</data>
					<key>Replace</key>
					<data>
					SERBVQ==
					</data>
				</dict>
			</array>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>#MCFG</string>
			</dict>
		</array>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<false/>
			<key>PluginType</key>
			<integer>1</integer>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>nv_disable=1 kext-dev-mode=1</string>
		<key>Debug</key>
		<false/>
		<key>Legacy</key>
		<string>LegacyBiosDefault</string>
		<key>NeverHibernate</key>
		<true/>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>5</integer>
		<key>XMPDetection</key>
		<string>Yes</string>
	</dict>
	<key>CPU</key>
	<dict>
		<key>UseARTFrequency</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>FakeID</key>
		<dict>
			<key>IntelGFX</key>
			<string>0x04128086</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>AddClockID</key>
			<true/>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>
	</dict>
	<key>DisableDrivers</key>
	<array>
		<string>VBoxHfs</string>
	</array>
	<key>GUI</key>
	<dict>
		<key>Custom</key>
		<dict>
			<key>Entries</key>
			<array>
				<dict>
					<key>Disabled</key>
					<false/>
					<key>FullTitle</key>
					<string>UEFI internal</string>
					<key>Hidden</key>
					<string>Always</string>
					<key>Ignore</key>
					<false/>
					<key>NoCaches</key>
					<false/>
					<key>Type</key>
					<string>Other</string>
				</dict>
			</array>
		</dict>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<true/>
			<key>Linux</key>
			<false/>
			<key>Tool</key>
			<true/>
		</dict>
		<key>Theme</key>
		<string>El Capitan</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
		<key>LoadVBios</key>
		<true/>
		<key>NvidiaSingle</key>
		<false/>
		<key>VideoPorts</key>
		<integer>3</integer>
		<key>ig-platform-id</key>
		<string>0x0a260006</string>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<true/>
		<key>AsusAICPUPM</key>
		<false/>
		<key>Debug</key>
		<false/>
		<key>DellSMBIOSPatch</key>
		<false/>
		<key>ForceKextsToLoad</key>
		<array>
			<string>\System\Library\Extensions\IONetworkingFamily.kext</string>
		</array>
		<key>KernelCpu</key>
		<false/>
		<key>KernelHaswellE</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelPm</key>
		<true/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>t2-10.10-10.11-Azul-Port_0x5-DP2HDMI</string>
				<key>Disabled</key>
				<true/>
				<key>Find</key>
				<data>
				AQUJAAAEAACHAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelFramebufferAzul</string>
				<key>Replace</key>
				<data>
				AQUSAAAIAAAGAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>t2-10.9-10.11-HD4600_HDMI_Audio-1of2</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				PQsMAAA=
				</data>
				<key>Name</key>
				<string>AppleHDAController</string>
				<key>Replace</key>
				<data>
				PQwMAAA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>t2-10.9-10.11-HD4600_HDMI_Audio-2of2</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				PQwKAAA=
				</data>
				<key>Name</key>
				<string>AppleHDAController</string>
				<key>Replace</key>
				<data>
				PQwMAAA=
				</data>
			</dict>
			<dict>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AQAAdSU=
				</data>
				<key>Name</key>
				<string>IOGraphicsFamily</string>
				<key>Replace</key>
				<data>
				AQAA6yU=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string></string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				BgAmCgEDAwMAAAACAAAwAQAAYAAAAABg2QoAANkKAAAA
				AAAAAAAAAAAACAACAAAAMAAAAAEFCQAABAAAhwAAAA==
				</data>
				<key>MatchBuild</key>
				<string></string>
				<key>MatchOS</key>
				<string></string>
				<key>Name</key>
				<string>AppleIntelFramebufferAzul</string>
				<key>Replace</key>
				<data>
				BgAmCgEDAwMAAAACAAAwAQAAYAAAAABg2QoAANkKAAAA
				AAAAAAAAAAAACAACAAAAMAAAAAEFEgAACAAAhwAAAA==
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>BooterConfig</key>
		<string>0x28</string>
		<key>CsrActiveConfig</key>
		<string>0x3</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>12/22/2016</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>MBP111.88Z.0138.B21.1612221936</string>
		<key>Board-ID</key>
		<string>Mac-189A3D4F975D5FFC</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardType</key>
		<integer>10</integer>
		<key>ChassisAssetTag</key>
		<string>MacBook-Aluminum</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>0x08</string>
		<key>Family</key>
		<string>MacBook Pro</string>
		<key>LocationInChassis</key>
		<string>Part Component</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<true/>
		<key>ProductName</key>
		<string>MacBookPro11,1</string>
		<key>SerialNumber</key>
		<string>C02L3Y0FFGYY</string>
		<key>Trust</key>
		<false/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Yes</string>
	</dict>
</dict>
</plist>



#22
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

Sorry but Your Clover Folder are little bit strange

:P  :lol:

 

captu186.png

 

You can try EFI attaching bellow :) Clover r4064  Intel HD 46000 working its just Inject Intel=true

Only 10.12 kexts folder for Sierra!

 

Edit****

Correct config.plist ,  I remove patch  boot glitch HD4000

You can change> MBP 9.1  for Mac Book Air

I handed over the ACPI file that you had already

Hope this help ? I am not an expert of laptop  :angel:

Attached Files

  • Attached File  EFI.zip   44.34MB   9 downloads


#23
MARZILLO

MARZILLO

    InsanelyMacaholic

  • Donators
  • 2,552 posts
  • Gender:Male
  • Location:Roma

aaarrgg

 

i don't see other



#24
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

aaarrgg

 

i don't see other

Not need for Sierra  just need 10.12

I correct config.plist , see my post , just edit**

Dont worry for Other Thats not your fault



#25
MARZILLO

MARZILLO

    InsanelyMacaholic

  • Donators
  • 2,552 posts
  • Gender:Male
  • Location:Roma

Hi Criss
I meant that I did not see "others" because I did not use it  :lol:



#26
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

Hi Criss
I meant that I did not see "others" because I did not use it  :lol:

Yey me to not used  :D



#27
dedede2137

dedede2137

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

I tried to boot with this... Restart after +++++++, even with KernelPM checked (i5-4200M needs this).
But when I unplugged the pendrive and launched Clover from the disk... THE SAME THING HAPPENED!
I was really scared, because I need the computer tomorrow. Fortunately, it started after few tries (and changing config.plist to exactly the same, but with other name).



#28
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

Try no DSDT maybe works? 

My laptop works with or with out DSDT dont know about your ?



#29
dedede2137

dedede2137

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Mine needs DSDT for AppStore, battery status and even audio.



#30
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

Mine needs DSDT for AppStore, battery status and even audio.

Yes me also but my laptop  boot on desktop with out DSDt



#31
dedede2137

dedede2137

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

I don't have a desktop



#32
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

I don't have a desktop

You dont have a Desktop on your Mac  :lol:



#33
dedede2137

dedede2137

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Wait, what? I think I don't understand :D


Oh, I have to run it once to check if it works, true? I will do it tomorrow evening because I need the computer and I don't want to break anything.



#34
chris1111

chris1111

    Packager

  • Donators
  • 4,454 posts
  • Gender:Male
  • Location:Montreal Canada
  • Interests:Mac OS X Packaging / scripts

Wait, what? I think I don't understand :D


Oh, I have to run it once to check if it works, true?

Now its me dont understand ?



#35
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,035 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

I believe AppleAlc does the work with ur ig-platform-id

 

The Clover have fix "UseInteHDMI", use kexts in Clover/Kexts/Others

 

RehabMan have kext for HDMI too

 

Check e.g.

Attached File  CLOVER.zip   4.8MB   16 downloads







Also tagged with one or more of these keywords: hdmi, hd4600, laptop, freeze

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy