Jump to content

HP Elitebook 8560p USB 3 & Radeon video card inoperable

HP Elitebook 8560p Radeon 6470m HD USB 3.0 problems Sierra

  • Please log in to reply
7 replies to this topic

#1
misterphoton

misterphoton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Denver Colorado USA

Thanks to the website for being a resource and making hacktintosh a valuable resource to the little guy.

 

I have a HP Elitebook 8560p with a Radeon HD 6470m video card / Hackintosh that I was able to get Mavericks onto with everything working but Sierra has problems with the USB 3.0, as well the Radeon Card working with GPU acceleration.

 

I have installed Sierra and I cannot get the GPU to work with OPEN CL, resolution or the USB 3.0 to be recognized, unlike the Mavericks partition.

 

As far as the Radeon goes, It is in VGA mode with no GPU acceleration, but it sees it in the system profiler but not correctly with the V RAM. I for the life of me cannot remember how I resolved these issues in Mavericks, as I was foolish enough not to take notes or make a build sheet.

 

Can you point me in the right direction on these 2 issues? I can provide my contact information as well if this is OK to?

 

Hardware is: (Bolder text being an immediate priority for assistance if anyone can)

 

  • i7 quad core

  • 16gb ram (OK)

  • 2 USB 2 ports working

  • 2 USB 3.0 port not working

  • Radeon HD 6470m with 1024 v RAM, that is in VGA mode with no GPU acceleration

  • motherboard:  Intel MX67QM (not sure if this is a 6, 7, 8 or 9 series chipset) The chipset is listed as MX67QM

  • BIOS: AMI 64 (updated)

  • NO Intel HD graphics enabled on the motherboard

  • HDMI not tested, but says the audio is working via HDMI

  • Intel 82579LM Gigabit LAN not tested

  • Intel 82574 PCIe LAN not tested (not seen, but listed in motherboard specs)

  • Intel Centrino Ultimate N6300 AGN (says for network adapter, but I 

  • Realtek ALC 887 working by Voodoo 2,8,8

  • Card Reader: Not recognized

  • No dual Intel HD graphics (not seen by system profiler) and HP stated the card is either removed or disabled (perhaps by BIOS)

 

 

Thanks for your time, Nick Teti, Mister Photon Media. ##### worked in the past for USB 3, but I do not remember how I got the GPU issue fixed. I can be contacted through the forum or by my profile if this is not breaking the rules?



#2
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

Welcome at InsanelyMac  :lol:

 

What is your CPU? i7xxxx?

 

Post your DSDT and config.plist. 

 

If you want, you can test your USB ports with FakePCIID_XHCIMux + FakePCIID. If this don't work, we can adjust your files.


And here we don't give support for Tonymac tools:



#3
misterphoton

misterphoton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Denver Colorado USA

Here is a reply to the inoperable HP EliteBook 8560p issues that I am having.

 

A)  Intel Core i7 (2720) , sandy bridge @ 2.2 ghz, (256 L2 & 6MB L3 cache) on an Intel MX67QM motherboard ( I think the MB is a 6 series on the chipset )

 

B) Post your DSDT and config.plist.

 

RE DSDT: If I'm not mistaken you hit f4 at the Clover boot screen, but am uncertain where the system stores the DSDT?

config.plist would be located in 

 

C) RE testing my USB ports with FakePCIID_XHCIMux + FakePCIID. Are these kexts to try?

 

 

Issues is Sierra: 

 

No USB 3.0

No Radeon Card working (AMD HD 6470m)

I would also love to get the ethernet going, the wifi, bluetooth and card reader if there are recommended kexts as well??

 

Thanks for helping the NUB-EE out here. Nick, Mister Photon. Is it ok to put up my contact information on my profile? Anyone? 

 

You can read below the specs on this machine...

 

Intel Core i7 (2720) , sandy bridge @ 2.2 ghz, (256 L2 & 6MB L3 cache) on an Intel MX67QM motherboard ( I think the MB is a 6 series on the chipset )

 

Reneseas USB 3.0 and also has 2.0 ports (they all work in Mavericks with the generic kext, not Sierra) (let me know if there is a kext)

 

Alcor Smart Card Reader / SDHC card port - not working (let me know if there is a kext) it say JMicron on the manufacturer's website for the MB

 

Realtek audio works

 

LAN: either Intel 82579 or 82579v (let me know if there is a kext)

 

Wifi: Broadcom 2070 (let me know if there is a kext) or it may be a Qualcomm Atheros AR900 (i'm not sure because HP does not support the machine anymore)

 

Bluetooth: Broadcomm 2070 (let me know if there is a kext) or it could be Qualcomm Atheros (HP won't tell me)

 

Network I can get going with WIFI on an Aftermarket ASUS N13 USB 2.0 adapter, but it would be nice to get the rest of network hardware going. 

 

Thanks again..



#4
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,537 posts
  • Gender:Male

This forum will not allow me to post my DSDT and config.plist. 

You can post .plist and .aml here.

 

Look: How to upload files or kexts.  ;) 



#5
misterphoton

misterphoton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Denver Colorado USA

Here is the attached Config.plist


& Here is the attached DSDT.aml file 

 

As well the AMD kext that worked on 10.9 but not working in Sierra has been attached. 

 

I also mounted the EFI in the working Mavericks HDD, copied the folder structure and pasted into the EFI partition on the HDD with Sierra. Something did not work and the Radeon is still not working. I also installed the working AMD controller kext into the Sierra HDD, and repaired the S/L/E but that did not work. Maybe a best version of Clover can be recommended?

 

So it convinces me that the config plist or the kext needs to be tweaked in order for the Radeon to work in Sierra with maybe something else as well?

 

I imagine maybe a kext(s) to get the USB 3 recognized & optimized in the Sierra partition/HDD. I am now working on a Sierra only HDD to try to isolate the problem and not a dual partition HDD.  

 

Each config.plist file and dsdt.aml file both in zip format added in the uploaded files. Thank You, Nick

 

Here also is the text from the Config.plist copied below. Please let me know if the fixed files are uploaded if & when. Thanks for helping, Nick

 

Spoiler

Attached Files



#6
gazixq

gazixq

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Syria
  • Interests:Respect all people

Please brother , can you show me how did you installed the mac osx ? cause i have the same laptop Modell ?



#7
misterphoton

misterphoton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Denver Colorado USA

Ask the administrators if you can have my contact information or post yours somewhere. I'm not sure it is worth the time with anything aside from Yosmite operating system or earlier. I used ta specific app for post installation that is available for download I think on bitbucket.  The Radeon video card I was able to get to work in Mavericks following the pro book installer instructions, but I can't confirm if that did it or it was a combination of tries.

 

The Radeon video card is a major pain to deal with, as well I have USB 3.0 issues in Yosemite or higher. In Mavericks everything works but I am not entirely sure how I got the video card to work in Sierra. The USB 3.0 "works" but I'm not sure at the highest speed that it can, and the controller does not show un in the system profiler in Sierra, unlike Mavericks.. so I have to do some tests when I get a chance. I'm still trying to decide what version of clover and what is needed to get the Radeon working as well the best. 

 

I see that this app i mentioned above is available there and some other places. Some places that have it are illegal to mention on this forum. Can I recommend search engines for some resources? and steps?

 

( my posts have seemed to have a still pending status on the Radeon issue).. I posted by DSDT, the config.plist and I think a 6000 series kext. Has anyone had a chance to tweak these on the forum? or may be interested for conquests sake??

 

Ask one of the forum admins if you can have my contact information.

 

If the forum can help me with the video card (Radeon HD 6470M) & recommend a kext to get the USB 3.0 optimized, (renseas controller & 6 series Intel chipset). I can probably help you with a successful install then. It's a waste of time if your USB 3.0 and video card won't work. Have you made a USB installer? start with that. Does the forum already have this as an install guide for any of the MAC OS X versions?

 

I have to use these boot flags to boot and install: dart=0 rootless=0 kext-dev-mode=1 

 

I don't have time to put down all the steps today or this weekend or week. You can find install steps on this website if I am not mistaken.  

 

Can anyone look at what on the Radeon issue:

 

Here's a patch I see in the config.plist that works in Mavericks and not Sierra: (in an above post)

 

<string>0200000000010000090100001204030300040000040300000001000010000505000400000403000000010000110201010004000000010000000910002103020200040000000100000009100022050404</string>

<key>ATIConnectorsPatch</key>
<string>0200000040000000090100001001010500040000040300000001000011020204000400000403000000010000210303020004000004030000000100001204040310000000100000000001000000000001</string>

 

and a specific non generic kext for the chipset / USB controller combination?


I also tried mounting the EFI from a cloned HDD with a working Mavericks partition and copying the EFI entire folder structure to the cloned HDD with Sierra to see if that would work.. no dice but it could be operator error..

 

Here is the attached Config.plist


& Here is the attached DSDT.aml file 

 

As well the AMD kext that worked on 10.9 but not working in Sierra has been attached. 

 

Each config.plist file and dsdt.aml file both in zip format added in the uploaded files. Thank You, Nick

 

Here also is the text from the Config.plist copied below. Please let me know if the fixed files are uploaded if & when. Thanks for helping, Nick

 

Spoiler


#8
misterphoton

misterphoton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Denver Colorado USA

Please brother , can you show me how did you installed the mac osx ? cause i have the same laptop Modell ?

You can easily get the vanilla version of Mavericks installed onto the HP Elitebook laptop. Then you can use the HP Probook Installer app that is available to get the Radeon video card working. If you have both the intel graphics card and AMd card I have heard it is impossible or very difficult. Make sure to use UEFI bios booting. As well it's important to follow the instructions of the HP Probook Installer (clover edition). You will need an app that enables you to mount the EFI partition. When you get the to the Probook Installer App, before you boot, mount the EFI partition by pressing F4 at the clover boot screen. Then you can mount the EFI, then launch the Pro Book Installer app to get the machine hardware working including the video card. 







Also tagged with one or more of these keywords: HP, Elitebook, 8560p, Radeon, 6470m HD, USB 3.0, problems, Sierra


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy