Jump to content

[Guide] Sierra / High Sierra on Intel 5, 6, 7, 8 and 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

* * * * * 7 votes intel asus gigabyte msi asrock dsdt sierra installation postinstallation ssdt

  • Please log in to reply
573 replies to this topic

#21
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

With that clover folder i get the Stop sign on boot (circle with line through it)

unfortunately the text showing what it died on is blurred, it gets to the pic i have attached just prior to the Stop. 

 

 

 

 

Attached Files



#22
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

boot from usb and run it

Attached File  Olarila.command.zip   1.02KB   5 downloads

if dont work use DSDT in Clover/Acpi/Patched in ur old Folder



#23
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

it did not like the .command file  couldn't find kextcache nor the update_* command so i replaced the dsdt and i am back to my desktop


This is my ioreg from post replacing dsdt.aml in my clover /acpi/patch folder

 

 


My USB 3.0's are behaving better under 10.11.6 since I used your CLOVER folder!   That is awesome!

Attached Files



#24
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

Put DSDT in Clover/Acpi/Patched

Attached File  DSDT.01.zip   23.16KB   10 downloads

Run KextUtility

Attached File  Kext Utility.app.zip   285.89KB   11 downloads

Reboot

 

Send me new ioreg



#25
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Booted that time with the new dsdt.aml.  I swear the Rig is 76% faster to boot.

 

 


Ok, 92.33%......  :angel_not:

Attached Files



#26
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

test onboard audio, test hdmi audio, etc

if u have problem with audio(alc1150 have problems in many cases)

 

put codec comander in s/l/e

Attached File  CodecCommander.kext.zip   26.52KB   6 downloads

and run KextUtility


btw, use fakesmc inside my folder ;)



#27
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

On board audio works like it did bebefore.  This is my 10.11.6 build.  When I go to 10.12.4 I will probably need that right?



#28
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

same files for both system ;)

 

CodecCommander for Alc1150 is a good idea, go to Sierra 10.12.4 and let me know



#29
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Do I use the Clover folder you sent me for the Sierra install (on the USB), but replace the DSDT with the one you sent me that works?

 

The screenshot you took of the Clover Screen.  What is checked to install inside of the "Drivers64UEFI"  Option?  In the past I have just used OsxAptioFix2Drv-64



#30
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

after install Sierra

Install Clover with options above, dont need check in drivers, my folder have all u need, just replace

http://www.insanelym...lake/?p=2413230


if u have problem, use same folder but changed DSDT, use it

http://www.insanelym...lake/?p=2413304

but use only if u have problem, all u need have inside Clover folder



#31
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I figured that after rereading your post again. I am in the process of installing Sierra on my spare ssd. Looks good so far!!!!

#32
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

just install Clover, replace folder, install webdriver(if u need), reboot ;)



#33
FFForever

FFForever

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

Hey hey,

 

Mind lending me a hand with my DSDT / checking it over?

 

Changes made to the DSDT:

- Injected layout-id (probably incorrectly as I still need the HDAEnabler)

- Fixed codepaths not returning a value by appending return (Zero)

- Removed random Arg0 after a return statement causing an unexpected end of file

- Fixed possible timeout error by changing 0x0FFF to 0xFFFF

- Removed unused locals

- Removed 20+ lines of Zero repeated

 

The SSDT.aml is the output from the latest version of ssdtPRGen.sh.

 

System: Dell Inspiron 3847

Graphics card: r9 270

CPU: i5-4440

Memory: 8gb

SSD: 1x Samsung Pro

HDD: 1x WD Black 3tib

Lan: RTL8168G / 8111G via Realtek8111.kext

Audio: ALC662v2 via AppleALC.kext

 

Links:

System specs (for reference): https://downloads.de...guide_en-us.pdf

IOReg: https://mega.nz/#!lNpiUYJB!XlaNWUyYgacLCsbSKMfBQLebihFHYbexzl9PchV2kvs

App output: https://mega.nz/#!xdoXkSqb!HXgXo1M13QuhppHfZs5eBPODlM0UHzRYMzl_Z2U0-4g

Clover: https://mega.nz/#!5RQwlLZI!8_HBy9jqLCh7RJPr_wF3yErUgVQ97yrqI-3jjWII7Y0



#34
xEclipse2

xEclipse2

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

MaLd0n, wow, wow and more Wow.

 

Everything under 10.12.4 works like a complete charm, and the rig is smoking fast in booting up.

 

So Smoooooooth!

 

Thank you ever so much.



#35
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

System: Dell Inspiron 3847

Attached File  CLOVER.zip   2.2MB   8 downloads

for Alc662 u can try id 5, 7, 11 and 12, if dont work native, u need a AppleHdaPatcher, yes!


MaLd0n, wow, wow and more Wow.

 

Everything under 10.12.4 works like a complete charm, and the rig is smoking fast in booting up.

 

So Smoooooooth!

 

Thank you ever so much.

Welcome!

Enjoy!



#36
FFForever

FFForever

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

attachicon.gifCLOVER.zip

for Alc662 u can try id 5, 7, 11 and 12, if dont work native, u need a AppleHdaPatcher, yes!


Welcome!

Enjoy!

 

Wow! I am floored by how much of a change a proper DSDT / clover configuration can make. I can't test HDMI audio out unfortunately so I can't comment on if that's working or not. The audio is working just fine without the hda enabler loading. The only issue I have left to fix on my system is the graphics not waking from boot, but that's a known AMD issue from the looks of it on <= 10.11.

 

Thanks a lot for taking a look at my setup MaLd0n!

 

Edit:

 

Looking at hwmonitor from rehabman / fakesmc it looks like only drive temps and ssd life remaining is showing. It use to include fan speeds, temps, etc. This could be due to my ssdt changes from earlier. Should I try adding the other ssdt-# files into my patched folder (after fixing any errors of course)?


Edited by FFForever, 28 April 2017 - 04:16 AM.


#37
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

fakesmc sensors cause many problems in many cases, but if u can test use it

Just replace in Clover/Kexts/Other

Attached File  FakeSMC.SENSORS.zip   164.11KB   4 downloads

and Check with HWMonitor

Attached File  HWMonitor.app.zip   3.62MB   3 downloads



#38
FFForever

FFForever

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

fakesmc sensors cause many problems in many cases, but if u can test use it

Just replace in Clover/Kexts/Other

attachicon.gifFakeSMC.SENSORS.zip

and Check with HWMonitor

attachicon.gifHWMonitor.app.zip

 

Ah. I was using hwmonitor as a way to test speedsteping / monitor temperatures. Do you have a recommendation on something else to use?

 

I noticed in my verbose boot output I have ACPI errors relating GPX0 with a note on AE_NOT_FOUND. I tried searching console for ACPI, and found nothing. Is there a log file I can check to get the exact error?



#39
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 16,135 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

AE_NOT_FOUND

it is common to see these in 10.12 with this new version of AppleACPIPlatform.kext. Older versions of OS X didn't do checks like this. ;)

 

Check ur speedstep use IGP

Attached File  Intel® Power Gadget SIERRA.zip   1014.82KB   26 downloads

 

Send me new ioreg

Attached File  IORegistryExplorer 3.app.zip   211.26KB   10 downloads



#40
FFForever

FFForever

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

it is common to see these in 10.12 with this new version of AppleACPIPlatform.kext. Older versions of OS X didn't do checks like this. ;)

 

Check ur speedstep use IGP

attachicon.gifIntel® Power Gadget SIERRA.zip

 

Send me new ioreg

attachicon.gifIORegistryExplorer 3.app.zip

 

ioreg: https://mega.nz/#!xUxHVDaT!G3mHO3-sE8zHz3dZ1NmWMOjarLipUAxYFDXCb4mC-W0

 

Does this look like it's stepping correctly? Even with a 90%+ idle system it's still hovering around the max frequency with minor drops.

 

f9jiWRb.png







Also tagged with one or more of these keywords: intel, asus, gigabyte, msi, asrock, dsdt, sierra, installation, postinstallation, ssdt


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy