Jump to content

Problema Boot Clover Installazione El Capitan 10.11.5 SSD


Best Answer gengik84, 04 February 2017 - 10:16 AM

Per facilitare le prove e per farle più accuratamente...comprimi il dsdt in patched, poi modificalo (questo per avere un backup prima di modificarlo)

elimina il method _dsm sotto visualizzato nel device Hdef

           Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03                                           
                    })
                }


                Return (Package (0x06)
                {
                    "layout-id", 
                    Buffer (0x04)
                    {
                         0x03, 0x00, 0x00, 0x00                         
                    }, 


                    "hda-gfx", 
                    Buffer (0x0A)
                    {
                        "onboard-1"
                    }, 


                    "PinConfigurations", 
                    Buffer (Zero) {}
                })
            }

Compila e salva...

i layout provali sul config, inserendo il "numero" relativo al layout così proprio come lo vedi nel link che ho postato riguardo ad AppleALC

Go to the full post


  • Please log in to reply
93 replies to this topic

#41
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

prova ad avviare senza dsdt e ssdt



#42
Jolly

Jolly

    InsanelyMac Top V.I.P.

  • Local Moderators
  • 10,343 posts
  • Gender:Male

Perché hai selezionato  DropOEM?


Non iniettare la stessa cosa con metodi diversi, mi riferisco a PNLF per cui hai un SSDT 


Meglio se metti anche il rename GFX0-->IGPU



#43
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

Eliminati i DSDT ma nulla, provo a rimetterli e tolgo DropOEM!



#44
Jolly

Jolly

    InsanelyMac Top V.I.P.

  • Local Moderators
  • 10,343 posts
  • Gender:Male

Lascia il solo DSDT e metti quel rename



#45
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

LOL!!!!! Jolly sai che avevi ragione? Era quel maledettissimo Drop OEM!!!! Ho l'accelerazione e pure la backlight!!! :D


Comunque ho lasciato DSDT, SSDT-PNLF ed il Fix ACPI AddPNLF! Cosi worka finalmente!!!


Domanda, il TRIM nativo per l'SSD è gia abilitato su 10.11.6 o devo fare qualcosa per attivarlo?



#46
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

terminale

sudo trimforce enable


#47
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

EDIT: Ok non è abilitato


Grazie Gengik! :D


TRIM Enabled! Ora devo solo pathcare l'audio, uso Pandora perché ricordo che riuscivo solo cosi!

Attached Files



#48
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

usa AppleALC da mettere in EFI...



#49
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

Ho gia AppleALC in EFI ma non va, ti posto pure lo screen del config riguardante l'audio!

Attached Files



#50
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

elimina resetHDA... poi quale è il tuo codec audio?



#51
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

Realtek ALC268 o ALC269, non ricordo quale dei due workasse!


Eliminata la FLAG su ResetHDA, non va comunque!



#52
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

dovresti dire esattamente quale è



#53
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

269, in firma era quello quindi credo sia giusto!



#54
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

Qui trovi tutti i layout da provare... presta attenzione perché devi modificare il layout sul dsdt...



#55
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

Cavolo ho patchato per sbaglio il 268 e ora non riesco a patchare il 269, mi da errore Already Patched, dove trovo l'originale non patchato?



#56
gengik84

gengik84

    InsanelyMac Top V.I.P.

  • Moderators
  • 15,109 posts
  • Gender:Male
  • Location:Toscana

Ma scusa, io non ti seguo... stavamo parlando di AppleALC... perché hai patchato AppleHDA?

Comunque quello originale lo trovi nell'installer...



#57
Jolly

Jolly

    InsanelyMac Top V.I.P.

  • Local Moderators
  • 10,343 posts
  • Gender:Male

Stai mescolando le cose, non puoi patchare e usare AppleALC contemporaneamente. Ti serve AppleHDA originale e provare i layout che gentilmente ti ha passato gengik



#58
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

Si in effetti sto facendo confusione per la fretta, comunque sto reinstallando l'originale con Kext Utility, riavvio e provo con i layout.



#59
Jolly

Jolly

    InsanelyMac Top V.I.P.

  • Local Moderators
  • 10,343 posts
  • Gender:Male

Togli le kext to patch dal config se sono state aggiunte



#60
eelet

eelet

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Sardinia, Italy

No nel config ci sono solo le patch del framebuffer!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy