Jump to content

Natit.kext - Titan imitation with source.


  • This topic is locked This topic is locked
82 replies to this topic

#41
dm_webd

dm_webd

    InsanelyMac Protégé

  • Retired Developers
  • 63 posts
  • Gender:Male
  • Location:Denmark

Any suggestions on what I could do then? I have a 7900 GS[device id 0x0292]. This also seems to happen to a few other people I know, so I'm not alone.

I'm remaking the kext with a different method of finding the right entry, which doesn't require iterating the registry. That might help.

#42
FabricioGS

FabricioGS

    Hackint0sh Lover

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
  • Location:Brazil
:compress: Yeaaaaah!!! Finally get my 7900GT working with QE/CI!!! Thanks a lot man, great work.

PS: I runned the installer: http://www.necnet.de...tit_1.0.pkg.zip

#43
katmail

katmail

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
Can't wait for ATI

HIS today has launched the first PCI graphics card based on an ATI X1300 3D chip. The passively cooled HIS X1300 silence Dual DVI 256MB PCI sports a dual link DVI connection, ATI's Avivo technology and H264/VC1 acceleration.


#44
ChuckDSanders

ChuckDSanders

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
ok I ran the natit installer and I didn't get the QE or CI support nor did I get the hibernate sleep support. Am I missing something? I have 10.4.7 patched to 10.4.8 and registering in the system profiler. I have a leadtech nothing fancy 7800gtx pci e. Do I need to install 10.4.8 fresh and then install the natit and that will solve everything? Or am I missing something like I need to install the titan kext still and configure it? I am sorry to be such a noob.

#45
FabricioGS

FabricioGS

    Hackint0sh Lover

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
  • Location:Brazil

ok I ran the natit installer and I didn't get the QE or CI support nor did I get the hibernate sleep support. Am I missing something? I have 10.4.7 patched to 10.4.8 and registering in the system profiler. I have a leadtech nothing fancy 7800gtx pci e. Do I need to install 10.4.8 fresh and then install the natit and that will solve everything? Or am I missing something like I need to install the titan kext still and configure it? I am sorry to be such a noob.


ChuckDSanders,

You need to be running 10.4.8 with kernel 8.8.1. TO see that digit on the console: uname -a

This will show you what version of the Darwin kernel you are running. Its probably 8.4.1.

#46
ChuckDSanders

ChuckDSanders

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male

ChuckDSanders,

You need to be running 10.4.8 with kernel 8.8.1. TO see that digit on the console: uname -a

This will show you what version of the Darwin kernel you are running. Its probably 8.4.1.


Thank you, yeah you are right, so where does one get the 8.8.1 kernel? I am assuming its a download or patch away from being good? So after I update the kernel will everything else be kosher? Thank you again

#47
REVENGE

REVENGE

    Made of Win

  • Retired Developers
  • 684 posts
  • Gender:Male
  • Location:California, USA
I think you can search yourself at torrent sites or check the IRC where it might already be listed. Either way, please use The Genius Bar to get all the help you need with 8.8.1 kernels. There are good guides and people knowledgeable about all variants of the kernel there. Good luck!

#48
ChuckDSanders

ChuckDSanders

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male

I think you can search yourself at torrent sites or check the IRC where it might already be listed. Either way, please use The Genius Bar to get all the help you need with 8.8.1 kernels. There are good guides and people knowledgeable about all variants of the kernel there. Good luck!


Ok I am downloading the JAS 10.4.8 ISO, does that have the necessary Kernel provided I do a fresh install?

#49
VN Man

VN Man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
There is no need to download the whole ISO, you only need the new kernel and the needed kext. Make for smaller downloads....Don't forget to update to latest 10.4.8 from Apple...

Atleast it work for me...Mind I have ATI card but to upgrade to 10.4.8 with 8.8.1 only need the above files and nothing more...

#50
lord_muad_dib

lord_muad_dib

    InsanelyMacaholic

  • Retired
  • 3,398 posts
  • Gender:Male
  • Location:italy
i have problems with my 6800 ultra

id 0x00f910de

the kernel panics if i leave geforce.kext in extensions folder

what do i need to do/edit?

thx for your help

#51
jester1o1

jester1o1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
you have to edit the Geforce.kext plist to have only your vid cards id. other wise it matches to the other nvidia gear in your pc and causes a kernel panic (like your sata controller etc).

#52
lord_muad_dib

lord_muad_dib

    InsanelyMacaholic

  • Retired
  • 3,398 posts
  • Gender:Male
  • Location:italy
in the plist there's already another id with this form 0x000010de&0xfff0ffff

i have to modify it this way? 0x00f910de&0xfff0ffff

or 0x00f910de;0xfff0ffff

or 0x00f910de&amp

or 0x00f910de

?

thx jester!

#53
CoolBits

CoolBits

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
0x00f910de

Is ok...

#54
vassalle

vassalle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts

After installing Titan or Natiti.kext your System does not restart properly? Simply run your hackint0sh install DVD, go into Disk Utility and repair permissions from DVD, that fixed the restart bug here.


hey bugs,

Thanks for the tip. but which install dvd? the 10.4.8 or the 10.4.6? i heard that the 10.4.8 diskutil is corrupted.

EDIT: tried and no go here. specs are as below. just change the 6600GT to a 6800. my setup had always had the reboot problem, even when using 10.4.6. remember i had to edit the kernel using the hex editor back then to make it boot. Guess my reboot problem is not titan related then. :)

#55
Guest: Kal_*

Guest: Kal_*
  • Guests
No luck here. Using JaS's 10.4.7 dvd (then updated using the 10.4.8 AMD SSE2 updater that still uses the old kernel).
Installed update, added the kexts from .8;
IONDRVSupport.kext
NVDAResman.kext
NVDANV10Hal.kext
NVDANV20Hal.kext
NVDANV30Hal.kext
NVDANV40Hal.kext
GeForce.kext
GeForce2MXGLDriver.bundle
GeForceGA.plugin
GeForceFXGLDriver.bundle
GeForce3GLDriver.bundle
GeForceVADriver.bundle
then deleted the kextcache files/kext -e -z -a etc, ran the Natit installer and repaired permissions.
It gives a few errors relating to nvdares* and a few others, appears to detect the card correctly, but loginwindow crashes (something about loginwindow security agent started appears too). The card is a PCI-E Geforce 7600 GS (512MB). Deleting Geforce.kext as suggested makes no difference.
Ideas? Theories?

#56
RnKstle

RnKstle

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:El Salvador, Santa Tecla
  • Interests:Mac
I Have Mac OSx 10.4.6 Goatsecx Installed, Today i install the Driver with The installer and...

The Login window Doesnt Load :S

Somebody can Help me? :)

Sorry for my bad english... :$

#57
jester1o1

jester1o1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
You Have to use the NEW KERNEL. That is - install the JAS 10.4.8 Dvd. without it you will get unpredictable results (ie: Kernel Panics).

Perhaps those folks making an installer should do a uname as part of the process? Hopefully that will stop this fscking question being asked a billion more times.

#58
Guest: Kal_*

Guest: Kal_*
  • Guests
I get no kernel panic, and there are definitely many many people who have it working (minus QE/CI) on the older kernel. It's been reported since the very first day that the .4 kernel can do this.

#59
alienbiker99

alienbiker99

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
it will work with the .4 kernel IF and ONLY IF you have the 4.8 kexts

#60
RnKstle

RnKstle

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:El Salvador, Santa Tecla
  • Interests:Mac
Can i install only the kernel? :S





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy