Jump to content

macOS Sierra/High Sierra on Broadwell E/EP (not a guide but maybe a working in progress)

X99 Sierra unsupported cpu xeon 2696V4 macOS High Sierra nvme 128gb

  • Please log in to reply
921 replies to this topic

#901
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

What do you mean?

I have had before your same cpu (2696 V3) and it was working as intel specific for all cores in turbo mode (IE 2.8 Ghz for all 36 threads)

 

Anyone tried to unlock the bios to enable max turbo on all cores for haswell cpu? 

Wondering if a bios like that will work on hackintosh



#902
maxx7650

maxx7650

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

What do you mean?

I have had before your same cpu (2696 V3) and it was working as intel specific for all cores in turbo mode (IE 2.8 Ghz for all 36 threads)

 

I read somewhere that is possible to unlock the bios for haswell so it will turbo up to max cpu freq in my case the cpu on all cores goes up to 2.8 ghz with that patch is possible to turbo up all the cores to 3.8 in theory, in practice is a bit lower more like 3.2-3.5 ghz.
https://forums.anand...-xeons.2496647/



#903
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

@maxx7650

Are you Adam something there?

A man reached for all cores 3.1 Ghz..and if it is true it is a very great result

Can you confirm this ?

I saw on this site some bioses

I have to read well, but if it is true could be a great finding 

grazie maxx

:-)



#904
maxx7650

maxx7650

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

@maxx7650

Are you Adam something there?

A man reached for all cores 3.1 Ghz..and if it is true it is a very great result

Can you confirm this ?

I saw on this site some bioses

I have to read well, but if it is true could be a great finding 

grazie maxx

:-)

Yeah that s me i ll have to do some digging too, I read there someone   fcked up his mobo after doing this 



#905
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

I have downloaded patched bios from link found there

Then I have also unlocked msr but I miss the microcode part

l have flashed it and system works as usual

 

Very interesting for Hackintosh users  is to use some efi drivers to unlock it after microcode bypass

your Haswell has some prove that it is working at least @3.1 ghz instead 2.8 ghz for all cores!

if someone unlock also broadwellEP should be very interesting and I will try it immediately! :-)

 

Yeah that s me i ll have to do some digging too, I read there someone   fcked up his mobo after doing this 



#906
MMido

MMido

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Bergen-Norway

I have downloaded patched bios from link found there

Then I have also unlocked msr but I miss the microcode part

l have flashed it and system works as usual

 

Very interesting for Hackintosh users  is to use some efi drivers to unlock it after microcode bypass

your Haswell has some prove that it is working at least @3.1 ghz instead 2.8 ghz for all cores!

if someone unlock also broadwellEP should be very interesting and I will try it immediately! :-)

But they said it's just a bug on Haswell that allowed this hack to work and maybe intel didn't do the same mistake when they design Broadwell-EP l am not sure. but if you make any progress gladly I will help.



#907
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

It is not so clear that aspect..

Someone says it is possible also for broadwell ep

We will see

And if so I will try! .-)

 

But they said it's just a bug on Haswell that allowed this hack to work and maybe intel didn't do the same mistake when they design Broadwell-EP l am not sure. but if you make any progress gladly I will help.



#908
maxx7650

maxx7650

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

It is not so clear that aspect..

Someone says it is possible also for broadwell ep

We will see

And if so I will try! .-)

 

It is not so clear that aspect..

Someone says it is possible also for broadwell ep

We will see

And if so I will try! .-)

 

It is not so clear that aspect..

Someone says it is possible also for broadwell ep

We will see

And if so I will try! .-)

I m missing that efi file that's why I didn t tried to do it ,I don t have any windows partitions on my hack so it s useless to flash the bios without the patch ,but maybe I'll find something  then I post here the results once is done


I m missing that efi file that's why I didn t tried to do it ,I don t have any windows partitions on my hack so it s useless to flash the bios without the patch ,but maybe I'll find something  then I post here the results once is done



#909
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

@maxx7650

bios from here

#1805

 

efi drivers from here

 

https://github.com/f...y/v3x4/releases

 

I am waiting for Broadwell microcode remove

I installed bios for my motherboard but microcode is there

so no results



#910
mysticmerlin

mysticmerlin

    InsanelyMac Protégé

  • Donators
  • 37 posts
  • Gender:Male
  • Location:Paris / France
Hi , I’m trying to update from 12.2 to 12.6 and I keep getting this : Setting this P-limit is unsupported KP.
Any ideas ? ThanksAttached File  IMG_5212.JPG   373.2KB   2 downloads



Envoyé de mon iPhone en utilisant Tapatalk

#911
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

I Mysticmerlin

​check kernel Patches 

If I don't do an error from 10.12.2 to 10.12.6 changed

find in this thread 10.12.6 efi i posted and copy Patches you are using



#912
mysticmerlin

mysticmerlin

    InsanelyMac Protégé

  • Donators
  • 37 posts
  • Gender:Male
  • Location:Paris / France

Thanks Fabio, 

That worked great. 10.12.6 up and running fine.

 

USB still not working well, need to look into that and play with bios settings.

And I get x86PlatformShim: Failed to send stepper. Need to figure out what's wrong with my ssdt

Should I be using boot flag xcpm_ipi if I run 2 processors?



#913
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

no

for x86PlatformShim: Failed to send stepper.

you have to use Pikeralpha frequency vector.sh script as always to inject frequency

for usb I don't know you motherboard so I can't help USB in z10pe d16 was working out of the box, but I have had it for too few time to say in secure way! .-9

 

 

 

That worked great. 10.12.6 up and running fine.

 

USB still not working well, need to look into that and play with bios settings.

And I get x86PlatformShim: Failed to send stepper. Need to figure out what's wrong with my ssdt

Should I be using boot flag xcpm_ipi if I run 2 processors?


Edited by fabiosun, 21 November 2017 - 07:15 AM.


#914
mysticmerlin

mysticmerlin

    InsanelyMac Protégé

  • Donators
  • 37 posts
  • Gender:Male
  • Location:Paris / France

no
for x86PlatformShim: Failed to send stepper.
you have to use Pikeralpha frequency vector.sh script as always to inject frequency
for usb I don't know you motherboard so I can't help USB in z10pe d16 was working out of the box, but I have had it for too few time to say in secure way! .-9



As usual you are right.
Reinstalled the vectors and xcpm is functional.
The usb issues seem mainly dependent on bios settings. Need to test more before changing anything .

I still don’t understand how my Geekbench can be only 2400/24000 with these processors. I know that the single core is low due to the base frequency but the multicore seems very low for 32 physical cores (On this system I can only enable 16 cores per processor and hyper threading doesn’t work properly)

#915
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male
Geekbench in the past does not work very well in dual cpu system
Could you do a cpu benchmark with cinebench15?
When i have had two 2696 v4 i have to limit to 16 core for each cpu but hypertrheading was working well

#916
mysticmerlin

mysticmerlin

    InsanelyMac Protégé

  • Donators
  • 37 posts
  • Gender:Male
  • Location:Paris / France

Geekbench in the past does not work very well in dual cpu system
Could you do a cpu benchmark with cinebench15?
When i have had two 2696 v4 i have to limit to 16 core for each cpu but hypertrheading was working well

 

The cinebench 15 gave me 2610. Don't know if that's normal or not



#917
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

No Mysticmerlin it is too low if you have retail 2699 V4 cpu

take a look on mine with a single 2696V4

if I remember well when I have the dual @64 cores it reaches about 4000 or up..

 

The cinebench 15 gave me 2610. Don't know if that's normal or not

Attached Files



#918
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

Updated from developer beta 6 to 10.13.2 final

clover 4318

no problem

Nvidia driver fix with gengik84 app

Attached Files



#919
fabiosun

fabiosun

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,533 posts
  • Gender:Male

final new release 17c89 with 103 Nvidia driver

 

Attached Files



#920
Sygey02

Sygey02

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Romania
  • Interests:IT

Hi Fabio! How did you managed to update to 10.13.2

My sistem won't update to 10.13.2 from 10.13.1

It download the update then restarts and begin to update then shortly restarts after 1 min...but no update changes!


looks like working on update but ..it docent finish or sorting like that!







Also tagged with one or more of these keywords: X99, Sierra, unsupported cpu, xeon 2696V4, macOS High Sierra, nvme, 128gb


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy