Jump to content

Nvidia Web Driver updates for macOS Sierra (UPDATE 07/21/2017)

nvidia web driver updates macOS Sierra

  • Please log in to reply
1001 replies to this topic

#361
Doublepranks

Doublepranks

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 193 posts
  • Gender:Male
  • Location:Belém / Pará

I believe the transparency bug is related to Metal support on basically any nvidia chip and that should be sorted out by the 20th



#362
Squidderlee

Squidderlee

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Lima, Peru

Nvidia just added the support for the latest macOS 10.12 GM3 build 16A322.

 

The driver seems to be the same since DP4/PB3 so don't expect to see any improvement.

Just read the build number for this latest "update" is 16A322 whereas my build is 16A320... and there is seeminly no update in Mas..... what's the story there? But indeed... same build for the driver so no update!

There is however an update for iTunes... I really hope at least there is colour again... they stripped out all the good thigs I like about it!



#363
Riley Freeman

Riley Freeman

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,630 posts
  • Gender:Male
  • Location:The Streets

To get 16A322 I think you'll need to download the whole installer again from MAS. It's not delivered as an update.



#364
Frank-o

Frank-o

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Oklahoma, USA

My gtx 980 isn't working with 16A322 drivers with same macOS build

 

tried forcing it, with no luck



#365
familygw

familygw

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Córdoba, ARG

My gtx 980 isn't working with 16A322 drivers with same macOS build

 

tried forcing it, with no luck

Well, I had a similar problem I guess (the difference is that my video card is an GTX 750ti).
I've found that the boot_args with nvda_drv=1 is not enough and, for my case to be using a z97 motherboard, is not necessary to have the EmuVariableUefi file at /Volumes/EFI/EFI/CLOVER/drivers64UEFI, so, I've deleted it, cleared the nvram (sudo nvram -c) and then use the NV Web Driver to set the nvram variable, restarted and now is working fine (excepts for the transparency issue)  :thumbsup_anim:

 

Hope this helps you.


#366
vielgi

vielgi

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I have GTX 980 and X99 platform. nvidia drivers working well dont use boot arg nvda_drv=1 on Mac OS Sierra . slice autor of clover write about that here http://www.insanelymac.com/forum/topic/304530-clover-change-explanations/page-2 last time when clover has been updated  "

Rev 3733

It was my mistake setting nvda_drv=1 flag as boot-args. No! It is NVRAM variable nvda_drv that can have a value "1".

So I make new config value"

 

    <key>SystemParameters</key>
    <dict>
        <key>NvidiaWeb</key>
        <true/>
    </dict>

 

thats all guys everything works :)



#367
xtddd

xtddd

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 281 posts
  • Gender:Male

I have GTX 980 and X99 platform. nvidia drivers working well dont use boot arg nvda_drv=1 on Mac OS Sierra . slice autor of clover write about that here http://www.insanelymac.com/forum/topic/304530-clover-change-explanations/page-2 last time when clover has been updated  "

Rev 3733

It was my mistake setting nvda_drv=1 flag as boot-args. No! It is NVRAM variable nvda_drv that can have a value "1".

So I make new config value"

 

    <key>SystemParameters</key>
    <dict>
        <key>NvidiaWeb</key>
        <true/>
    </dict>

 

thats all guys everything works :)

do you add emuvariableuefi-64.efi to clover?



#368
drLB

drLB

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi Everybody,

I have successfully installed the driver under Sierra with a Gigabyte GTX 970 on a Skylake system (Gigabyte z170m + 6600k), but could not activate it, until I installed the EmuUefiVariables.efi extension in Clover.

Perhaps will it helpful to somebody...


But with the newest Clover 3751, i can set the NVRAM variable NvidiaWeb=true, so i don't need the EmuUefiVariables extension at all, again...

Thanks for the great work!



#369
xtddd

xtddd

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 281 posts
  • Gender:Male

Hi Everybody,

I have successfully installed the driver under Sierra with a Gigabyte GTX 970 on a Skylake system (Gigabyte z170m + 6600k), but could not activate it, until I installed the EmuUefiVariables.efi extension in Clover.

Perhaps will it helpful to somebody...


But with the newest Clover 3751, i can set the NVRAM variable NvidiaWeb=true, so i don't need the EmuUefiVariables extension at all, again...

Thanks for the great work!

also dont need boot flag nvda_drv=1



#370
iamtheonlyone4ever

iamtheonlyone4ever

    InsanelyMac Sage

  • Banned
  • PipPipPipPipPip
  • 345 posts
  • Gender:Male

i told them like 6 pages back but they didn't listen to me , now my board works without having to use emuvariable, so that weird problem that i had is now fixed thanks to this new version of clover, so i only needed to use emuvariable only in sierra and only for the card to work in sierra , my board has support for nvram without having to use emuvariable so it turn out to be a problem that clover fixed , technically i was forced to use emuvariable in sierra if i wanted my card to work, i explain this a million times, then they say that i didn't know what i was doing or i didn't know what i was talking about, that there it was something wrong with my board or my configuration. so time proved me right. anyway let's just forget the whole thing and move on, i'm happy and i can't wait for Sep 20. Sierra  :thumbsup_anim:

 

windows 10 sucks


Hi Everybody,

I have successfully installed the driver under Sierra with a Gigabyte GTX 970 on a Skylake system (Gigabyte z170m + 6600k), but could not activate it, until I installed the EmuUefiVariables.efi extension in Clover.

Perhaps will it helpful to somebody...


But with the newest Clover 3751, i can set the NVRAM variable NvidiaWeb=true, so i don't need the EmuUefiVariables extension at all, again...

Thanks for the great work!

exactly the same thing happened to me 

 

now we are not forced to use emuvariable if our boards have support for nvram , the only person now that needs to use emuvariable are the ones that don't have nvram support in their boards and they are using clover in EUFI mode, so things are now back to normal.



#371
UltraLaser

UltraLaser

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 456 posts
  • Gender:Male
  • Location:Italy

I have these graphics issues...

does anyone know how to fix?

 

@GTX 750Ti with web driver

Attached Files



#372
phi777

phi777

    InsanelyMac Protégé

  • Donators
  • 64 posts
  • Gender:Not Telling

Updated Driver 367.15.10.05f01 !!!

Just got it via the Update Button in the NVIDIA pref plane.

 

Changelog:

- New G-SYNC Option added in NVIDIA Driver Manager pref plane.

- Geekbench 4.0.1 still aborts in the 2nd openCL test for me

- ???



#373
WeBeRiO

WeBeRiO

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 210 posts
  • Gender:Male
  • Location:Motril (GR) - Spain
  • Interests:Hackintosh

New webdriver Final for Sierra, waiting link of download.

 

Attached Files



#374
MaeseppTarvo

MaeseppTarvo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Updated Driver 367.15.10.05f01 !!!

Just got it via the Update Button in the NVIDIA pref plan.

Have you tried it, any pascal promises? :D



#375
UltraLaser

UltraLaser

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 456 posts
  • Gender:Male
  • Location:Italy

And finally with the latest driver my Nvidia 750ti works very well, no glitches!!!



#376
phi777

phi777

    InsanelyMac Protégé

  • Donators
  • 64 posts
  • Gender:Not Telling

Have you tried it, any pascal promises? :D

That's something I would like too.

I can't find the download link, but it's just 59MB in size, so....



#377
MaeseppTarvo

MaeseppTarvo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I can't find the download link, but it's just 69MB in size...

 

here you can download.

 

http://www.insanelym...pdate-09202016/



#378
tarasis

tarasis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
  • Location:Near Hamburg, Germany

Just updated to the newest driver "http://www.insanelym...date-09202016/"its working well, btw is the option for GSYNC monitors new? I don't remember seeing it previously.



#379
steve-lucky

steve-lucky

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I'm running the Sierra GM but I can't install the newest Nvidia driver. It tells me:

 

 

Mac OS X version 10.12 (16A323) is required for this update. Please update your OS version and try again.

 

Any thoughts?



#380
bankkopf

bankkopf

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts

Redownload from Appstore. That build is newest release of GM and is the official one that got released yesterday.

Previous versions, downloaded with the public beta code, are older builds.







Also tagged with one or more of these keywords: nvidia web driver, updates, macOS, Sierra


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy