Jump to content

Nvidia Web Driver updates for macOS Sierra (UPDATE 07/21/2017)

nvidia web driver updates macOS Sierra

  • Please log in to reply
1001 replies to this topic

#1
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,474 posts
  • Gender:Male

Hi InsanelyMacaholics    :)

 

Use this thread to link / talk about of the futur Nvidia Web Driver updates for macOS Sierra.

 

10.12.6

 

Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to BadruzeusNew!

 

 

 

10.12.5

 

Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)

 

 

 

10.12.4

 

Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)

 

Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr Pascal support!!!

 

Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)

 

 

 

10.12.3


Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)

 

 

 

10.12.2

 

Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)

 

Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)

 

Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)

 

 

 

10.12.1

 

Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).

 

Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)

 

 

 

10.12.0

 

Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)

 

 

 

 

GM

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3) 

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)

 

 

 

 

 

DP/PB

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)

 

Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)

 

Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)

 

Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun)  

 

Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun

 

Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)

 

 

 

 


Edited by fantomas1, 21 July 2017 - 06:36 PM.
added Nvidia Web Driver 378.05.05.25f01 for macOS 10.12.6 build 16G29


#2
calibre™

calibre™

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts
  • Gender:Male
^^ that fast :shock:


non yet. slow down :)

#3
larrikinaus

larrikinaus

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Does anyone know how soon NVIDIA are likely to produce a driver for Sierra?



#4
01tt0ly

01tt0ly

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

Cut the jobs inside Nvidia,only around 20 engineers for Mac OS X or macOS drivers.

Not expecting too much about the drivers,which full of bugs already.

Most probably Apple would take more AMD graphics. 



#5
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,474 posts
  • Gender:Male

Did somebody try 346.03.15b01 web driver with macOS Sierra?  :)

<key>NVDARequiredOS</key>
<string>16A</string>


#6
Shad0wWalk3r

Shad0wWalk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Greece
  • Interests:C++,PHP,C#,Java,raspberry pi projects,chess,math,building PCs & fixing the broken ones ;)

 

Did somebody try 346.03.15b01 web driver with macOS Sierra?  :)

<key>NVDARequiredOS</key>
<string>16A</string>

 

can i try using the web drivers of 10.11.6 with sierra?how should i use the above string you have written?



#7
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,474 posts
  • Gender:Male

Edit Info.plist in NVDAStartupWeb.kext manually or with Nvidia WebDriver Updater app - Boot with nvda_drv=1

 

No guarantee it will work but good luck.   ;)



#8
Shad0wWalk3r

Shad0wWalk3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Greece
  • Interests:C++,PHP,C#,Java,raspberry pi projects,chess,math,building PCs & fixing the broken ones ;)

thx fantomas....i will try probably tomorrow and post the results :) 



#9
Xmedik

Xmedik

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

web-driver Sierra 16A201w

http://us.download.n...05.10.05b03.pkg



#10
sroddy

sroddy

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

I checked inside the .pkg and it doesn't seem to contain support for Pascal cards.

Can anyone with a Pascal card confirm that these drivers don't work yet?



#11
Moviemakergr

Moviemakergr

    InsanelyMac Sage

  • Donators
  • 436 posts
  • Gender:Male

Someone with GTX 10x0 to try the pascal GPU with these drivers ?



#12
larrikinaus

larrikinaus

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

I've just tried to boot with Sierra and this new driver. Unfortunately it won't work with my GTX 950.

 

If I go into terminal, and type this I get an error:

 

Mac-Pro-Server:~ me$ sudo nvram boot-args="nvda_drv=1"

Password:

nvram: Error setting variable - 'boot-args': (iokit/common) general error

Mac-Pro-Server:~ me$ 

 

So close yet so far :)


Does anyone have a contact at NVIDIA for the web driver?  It clearly needs fixing as it just doesn't work with Sierra GTX950 - in fact, whilst the card is in my machine, it won't even boot! It gets caught in a kernel panic loop.



#13
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,967 posts
  • Gender:Male
  • Location:France

Works great here ! :thumbsup_anim:
 

Spoiler


#14
larrikinaus

larrikinaus

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Works great here ! :thumbsup_anim:
 

 

What Mac Pro are you running?...  actually, looks like you are running a hackintosh... 

 

I'm actually trying to get it to work in a MacPro3,1. 



#15
polyzargone

polyzargone

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,967 posts
  • Gender:Male
  • Location:France

What Mac Pro are you running?...  actually, looks like you are running a hackintosh...


Of course I am ! It's a Hackintosh forum here :P. But FYI I use an iMac13,2 SMBios.
 

I'm actually trying to get it to work in a MacPro3,1.


What are you trying to do actually ? Install macOS Sierra on a MacPro3,1 or NVIDIA Webdrivers ? If the package refuse to install them, then you should try NVIDIA® WebDriver Updater.app 1.4.



#16
larrikinaus

larrikinaus

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

I have Sierra running on my MacPro3,1 - had to hack it to do so. I have installed the beta driver for Sierra and it installed successfully. However, when I try and boot with my GTX950 card, it won't boot, it crashes, and loops. This didn't happen in el capitan and the drivers for that OS. Therefore, I suspect the driver isn't working properly yet - it clearly works in a PC hackintosh environment (well, at least for you which is great) but not in the Mac Pro world yet.



#17
CoderPro12

CoderPro12

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male

Im getting the following error when installing.

 

Screen%20Shot%202016-06-14%20at%209.19.5

Any Suggestions?



#18
MinusZwei

MinusZwei

    InsanelyMac Protégé

  • Coders
  • 49 posts
  • Gender:Male
  • Location:France

Someone with GTX 10x0 to try the pascal GPU with these drivers ?

 

I had a quick look to the PKG contents, and I don't think it is gonna work.

There are 3 kexts:

 - GF100

 - GK100

 - GM100



#19
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 4,474 posts
  • Gender:Male

The next CUDA 8.0 is fully supporting the pascal GPUs so we should expect the same with Web Driver.



#20
cnrd

cnrd

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

I'm having problems getting my GTX 980TI working correctly on 10.12.

 

I'm getting that dreaded "black screen" bug.

 

I have already modified AppleGraphicsDevicePolicy.kext setting Mac-65CE76090165799A to none.

 

It kind of seems like the kernel cache is not "sticking", as I'm able to boot up with nv_disable=1, rebuild the kernel cache (sudo kextcache -system-prelinked-kernel & sudo kextcache -system-caches), reboot.

 

This makes the "black screen" bug go away, but only for a few restarts.

 

Anyone who have experienced this?







Also tagged with one or more of these keywords: nvidia web driver, updates, macOS, Sierra


14 user(s) are reading this topic

0 members, 14 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy